Cannot install vlc, broken packages on 14.04

Asked by gal

The following is shown when I am trying to (re)-install vlc:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 vlc : Depends: vlc-nox (= 3.0.0~~git20141112+r58596+31~ubuntu14.04.1) but it is not going to be installed
       Depends: libavcodec55 (>= 6:9.1-1) but it is not installable or
                libavcodec-extra-55 (>= 6:10~~git20131218.b3189af~ubuntu14.04.1) but it is not installable
       Depends: libavutil53 (>= 6:9.1-1) but it is not installable
       Recommends: vlc-plugin-notify (= 3.0.0~~git20141112+r58596+31~ubuntu14.04.1) but it is not going to be installed
       Recommends: vlc-plugin-samba (= 3.0.0~~git20141112+r58596+31~ubuntu14.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Note that a week ago I wanted to install acroread and followed a tutorial online (I cannot find it anymore) which did not work (probably because I am on a 64 bits machine). The commands I did back then were:

sudo add-apt-repository "deb http://archive.canonical.com/ precise partner"
sudo apt-get update
sudo apt-get install acroread
sudo add-apt-repository -r "deb http://archive.canonical.com/ precise partner"
sudo apt-get update

I don't know if it is correlated (probably is, but I did not find how to clean this up :(), today vlc disappeared after I did an update through the software updater.

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu apt Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

Probably because you have added a billion PPAs. This will help
https://answers.launchpad.net/ubuntu/+question/256209

Revision history for this message
Manfred Hampl (m-hampl) said :
#2

Could be a build problem in one of the PPAs. There currently is an error message on https://launchpad.net/~videolan/+archive/ubuntu/master-daily/+packages
"Copying failed of libav (6:10~~git20131218.b3189af~ubuntu14.04.1)"

What is the output of the terminal commands

apt-cache policy vlc vlc-nox libavcodec55 libavutil53
apt-get --simulate vlc vlc-nox libavcodec55 libavutil53
grep videolan /etc/apt/sources.list /etc/apt/sources.list.d/*.list
grep motumedia /etc/apt/sources.list /etc/apt/sources.list.d/*.list

Revision history for this message
gal (gal-l) said :
#3

apt-cache policy vlc vlc-nox libavcodec55 libavutil53

vlc:
  Installed: (none)
  Candidate: 3.0.0~~git20141112+r58596+31~ubuntu14.04.1
  Version table:
     3.0.0~~git20141112+r58596+31~ubuntu14.04.1 0
        500 http://ppa.launchpad.net/videolan/master-daily/ubuntu/ trusty/main amd64 Packages
     2.1.4-0ubuntu14.04.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ trusty-updates/universe amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ trusty-security/universe amd64 Packages
     2.1.2-2build2 0
        500 http://fr.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
vlc-nox:
  Installed: (none)
  Candidate: 3.0.0~~git20141112+r58596+31~ubuntu14.04.1
  Version table:
     3.0.0~~git20141112+r58596+31~ubuntu14.04.1 0
        500 http://ppa.launchpad.net/videolan/master-daily/ubuntu/ trusty/main amd64 Packages
     2.1.4-0ubuntu14.04.1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ trusty-updates/universe amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ trusty-security/universe amd64 Packages
     2.1.2-2build2 0
        500 http://fr.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
libavcodec55:
  Installed: (none)
  Candidate: (none)
  Version table:
libavutil53:
  Installed: (none)
  Candidate: (none)
  Version table:

apt-get install --simulate vlc vlc-nox libavcodec55 libavutil53 (i added the install part, figured this was what you meant)

NOTE: This is only a simulation!
      apt-get needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libavcodec55 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package libavutil53 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libavcodec55' has no installation candidate
E: Package 'libavutil53' has no installation candidate

grep videolan /etc/apt/sources.list /etc/apt/sources.list.d/*.list

/etc/apt/sources.list.d/libdvdcss.list:# deb http://download.videolan.org/pub/debian/stable / # disabled on upgrade to trusty
/etc/apt/sources.list.d/libdvdcss.list:# deb-src http://download.videolan.org/pub/debian/stable/ / # disabled on upgrade to trusty
/etc/apt/sources.list.d/videolan-master-daily-trusty.list:deb http://ppa.launchpad.net/videolan/master-daily/ubuntu trusty main
/etc/apt/sources.list.d/videolan-master-daily-trusty.list:# deb-src http://ppa.launchpad.net/videolan/master-daily/ubuntu trusty main

grep motumedia /etc/apt/sources.list /etc/apt/sources.list.d/*.list

empty

Revision history for this message
gal (gal-l) said :
#4

@actionparsnip: I don't know if it is similar, I don't have that many ppas in others:
- indepedent,
- google talk plugin,
- webupd8team and
- videolan

(anyway I tried to follow their steps and it did not do anything)

Thanks anyway

Revision history for this message
Best Manfred Hampl (m-hampl) said :
#5

You could try enabling the ppa:motumedia/libav10-trusty PPA, because that one seems to contain the required libav packages.

Revision history for this message
gal (gal-l) said :
#6

Thanks! It worked. So apparently it was not because of the thing with acroread.
Just to be clear for future generation:

sudo add-apt-repository ppa:motumedia/libav10-trusty
sudo apt-get update
sudo apt-get install vlc

Revision history for this message
gal (gal-l) said :
#7

Thanks Manfred Hampl, that solved my question.

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#8

Please don't add PPAs. I have seen this far too many times. Manfred is the man at this stuff :)

If you avoid PPAs and stick to the official sources you will have significantly fewer issues with pacages.

Revision history for this message
Manfred Hampl (m-hampl) said :
#9

Just a final comment:
The root cause in this case seems to have been that the videolan PPA depends on software from another PPA which is an undesired and non-standard case.
I fully agree with actionparsnip that going back from the PPA versions of vlc to the standard Ubuntu ones should have provided an easy solution to your problem, too.

Revision history for this message
Allan Deamon (rea-aft) said :
#10

This solution doesn't work anymore. The ppa:motumedia/libav10-trusty gives "Forbidden access", so i can't install it anymore.

The version in VLC is very buggy, so I always having to trying (and falling) to install a newer version of it in Ubuntu, or having to change the OS just to use a working version of it. It's really frustrating those "stable" versions which are buggy and you cannot install a unstable bug free version of it.

Revision history for this message
Manfred Hampl (m-hampl) said :
#11

@Allan Deamon:

Please don't blame Ubuntu if one of the PPA providers decides to abandon one of his PPAs.

A quick search shows that there is a PPA ppa:motumedia/libav-daily that also provides versions of libav, maybe that works as desired.
And if not, please contact the provider of the PPA or videolan.org, because there is the clear statement that there is no support here for software that you install from PPAs or from outside the standard Ubuntu repositories.

You would not experience such problems if you stick to the standard Ubuntu versions.

Revision history for this message
Janis Elmeris (janis-elmeris) said :
#12

MOTU media's archive didn't work for me, but this one worked: https://launchpad.net/~bkgaley/+archive/ubuntu/ppa Thank you for pointing out a solution!