Failed to fetch .....Packages.gz 404 Not Found

Asked by ThreadedKernel

Trying to update / upgrade the system from 10.04 to 12.

upon running 'sudo apt-get -y update'

the following output is returned:

Hit http://dl.google.com stable Release.gpg
Hit http://dl.google.com stable Release
Hit http://ubuntu.bigbluebutton.org bigbluebutton-lucid Release.gpg
Hit http://dl.google.com stable/main Packages
Hit http://ubuntu.bigbluebutton.org bigbluebutton-lucid Release
Ign http://ubuntu.bigbluebutton.org bigbluebutton-lucid/main Packages
Hit http://archive.ubuntu.com lucid-updates Release.gpg
Hit http://ppa.launchpad.net lucid Release.gpg
Ign http://ppa.launchpad.net lucid Release.gpg
Hit http://packages.medibuntu.org lucid Release.gpg
Ign http://ubuntu.bigbluebutton.org bigbluebutton-lucid/main Packages
Hit http://ubuntu.bigbluebutton.org bigbluebutton-lucid/main Packages
Hit http://archive.ubuntu.com lucid-updates Release
Hit http://ppa.launchpad.net lucid Release
Ign http://ppa.launchpad.net lucid Release
Hit http://archive.ubuntu.com lucid-updates/main Packages
Hit http://packages.medibuntu.org lucid Release
Hit http://ppa.launchpad.net lucid/main Packages
Hit http://archive.ubuntu.com lucid-updates/universe Packages
Hit http://archive.ubuntu.com lucid-updates/multiverse Packages
Hit http://archive.ubuntu.com lucid-updates/restricted Packages
Ign http://ppa.launchpad.net lucid/main Packages
Hit http://packages.medibuntu.org lucid/free Packages
Ign http://ppa.launchpad.net lucid/main Packages
Err http://ppa.launchpad.net lucid/main Packages
  404 Not Found
W: Failed to fetch http://ppa.launchpad.net/user/ppa-name/ubuntu/dists/lucid/main/binary-i386/Packages.gz 404 Not Found

E: Some index files failed to download, they have been ignored, or old ones used instead.

---------------------------

Ran the command outlined in step 6 of the Package Manager Troubleshooting Procedure. Here's the output from that:
user@foo:/etc/apt$ sudo grep -R proxy /etc/apt/*
user@foo:/etc/apt$ echo $http_proxy

user@foo:/etc/apt$ echo $ftp_proxy

user@foo:/etc/apt$ grep proxy /etc/bash.bashrc
user@foo:/etc/apt$ sudo fuser -vvv /var/lib/dpkg/lock
user@foo:/etc/apt$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu 10.04.4 LTS"
user@foo:/etc/apt$ uname -a
Linux foo 2.6.32-45-generic #100-Ubuntu SMP Wed Nov 14 10:41:11 UTC 2012 i686 GNU/Linux
user@foo:/etc/apt$ sudo rm /var/lib/apt/lists/lock
user@foo:/etc/apt$ sudo cp -arf /var/lib/dpkg /var/lib/dpkg.backup
user@foo:/etc/apt$ sudo mv /var/lib/dpkg/status /var/lib/dpkg/status-bad
user@foo:/etc/apt$ sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status || sudo cp /var/backups/apt.extended_states.0 /var/lib/dpkg/status
user@foo:/etc/apt$ sudo mv /var/lib/dpkg/available /var/lib/dpkg/available-bad
user@foo:/etc/apt$ sudo cp /var/lib/dpkg/available-old /var/lib/dpkg/available
user@foo:/etc/apt$ sudo rm -rf /var/lib/dpkg/updates/*
user@foo:/etc/apt$ sudo rm -rf /var/lib/apt/lists
user@foo:/etc/apt$ sudo rm /var/cache/apt/*.bin
user@foo:/etc/apt$ sudo mkdir /var/lib/apt/lists
user@foo:/etc/apt$ sudo mkdir /var/lib/apt/lists/partial
user@foo:/etc/apt$ LANG=C;sudo apt-get clean
user@foo:/etc/apt$ LANG=C;sudo apt-get autoclean
Reading package lists... Done
Building dependency tree
Reading state information... Done
user@foo:/etc/apt$ LANG=C;sudo apt-get --purge autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
11 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up google-chrome-beta (24.0.1312.27-r170126) ...

Setting up linux-image-2.6.32-45-generic (2.6.32-45.100) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.32-45-generic
Not updating initrd symbolic links since we are being updated/reinstalled
(2.6.32-45.99 was configured last, according to dpkg)
Not updating image symbolic links since we are being updated/reinstalled
(2.6.32-45.99 was configured last, according to dpkg)
Running postinst hook script /sbin/update-grub.
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /vmlinuz-2.6.32-45-generic
Found kernel: /vmlinuz-2.6.32-44-generic
Found kernel: /vmlinuz-2.6.32-43-generic
Found kernel: /vmlinuz-2.6.32-42-generic
Found kernel: /vmlinuz-2.6.32-41-generic
Found kernel: /vmlinuz-2.6.32-40-generic
Found kernel: /memtest86+.bin
Updating /boot/grub/menu.lst ... done

Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/dkms 2.6.32-45-generic /boot/vmlinuz-2.6.32-45-generic
run-parts: executing /etc/kernel/postinst.d/nvidia-common 2.6.32-45-generic /boot/vmlinuz-2.6.32-45-generic
run-parts: executing /etc/kernel/postinst.d/pm-utils 2.6.32-45-generic /boot/vmlinuz-2.6.32-45-generic

Setting up virtualbox-4.0 (4.0.16-75491~Ubuntu~lucid) ...
addgroup: The group `vboxusers' already exists as a system group. Exiting.
 * Stopping VirtualBox kernel modules [ OK ]
 * Uninstalling old VirtualBox DKMS kernel modules [ OK ]
 * Trying to register the VirtualBox kernel modules using DKMS [ OK ]
 * Starting VirtualBox kernel modules [ OK ]

Setting up libperl5.10 (5.10.1-8ubuntu2.2) ...

Setting up linux-headers-2.6.32-45 (2.6.32-45.100) ...
Setting up linux-headers-2.6.32-45-generic (2.6.32-45.100) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/nvidia-common 2.6.32-45-generic /boot/vmlinuz-2.6.32-45-generic

Setting up linux-libc-dev (2.6.32-45.100) ...
Setting up lynx-cur (2.8.8dev.2-1ubuntu0.1) ...

Setting up lynx (2.8.8dev.2-1ubuntu0.1) ...
Setting up perl-modules (5.10.1-8ubuntu2.2) ...
Setting up perl (5.10.1-8ubuntu2.2) ...

Processing triggers for python-central ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
user@foo:/etc/apt$ LANG=C;sudo apt-get update -o APT::Cache-Limit=100000000
Get:1 http://dl.google.com stable Release.gpg [198B]
Get:2 http://dl.google.com stable Release [1347B]
Get:3 http://dl.google.com stable/main Packages [1242B]
Get:4 http://archive.ubuntu.com lucid-updates Release.gpg [198B]
Get:5 http://packages.medibuntu.org lucid Release.gpg [198B]
Get:6 http://ppa.launchpad.net lucid Release.gpg [316B]
Ign http://ppa.launchpad.net lucid Release.gpg
Get:7 http://ubuntu.bigbluebutton.org bigbluebutton-lucid Release.gpg [198B]
Get:8 http://archive.ubuntu.com lucid-updates Release [58.3kB]
Get:9 http://ppa.launchpad.net lucid Release [13.9kB]
Get:10 http://ubuntu.bigbluebutton.org bigbluebutton-lucid Release [1647B]
Ign http://ubuntu.bigbluebutton.org bigbluebutton-lucid/main Packages
Ign http://ubuntu.bigbluebutton.org bigbluebutton-lucid/main Packages
Get:11 http://packages.medibuntu.org lucid Release [6854B]
Get:12 http://ubuntu.bigbluebutton.org bigbluebutton-lucid/main Packages [4983B]
Ign http://ppa.launchpad.net lucid Release
Get:13 http://ppa.launchpad.net lucid/main Packages [4338B]
Ign http://ppa.launchpad.net lucid/main Packages
Get:14 http://packages.medibuntu.org lucid/free Packages [3260B]
Ign http://ppa.launchpad.net lucid/main Packages
Err http://ppa.launchpad.net lucid/main Packages
  404 Not Found
Get:15 http://archive.ubuntu.com lucid-updates/main Packages [664kB]
Get:16 http://archive.ubuntu.com lucid-updates/universe Packages [284kB]
Get:17 http://archive.ubuntu.com lucid-updates/multiverse Packages [11.5kB]
Get:18 http://archive.ubuntu.com lucid-updates/restricted Packages [4630B]
Fetched 1061kB in 4s (254kB/s)
W: Failed to fetch http://ppa.launchpad.net/user/ppa-name/ubuntu/dists/lucid/main/binary-i386/Packages.gz 404 Not Found

E: Some index files failed to download, they have been ignored, or old ones used instead.
user@foo:/etc/apt$ sudo dpkg --configure -a
user@foo:/etc/apt$ sudo dpkg --clear-avail
user@foo:/etc/apt$ LANG=C;sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 30 not upgraded.
user@foo:/etc/apt$ LANG=C;sudo apt-get --fix-missing install
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 30 not upgraded.
user@foo:/etc/apt$ LANG=C;sudo apt-get update -o APT::Cache-Limit=100000000 && sudo apt-get dist-upgrade
Hit http://dl.google.com stable Release.gpg
Hit http://dl.google.com stable Release
Hit http://dl.google.com stable/main Packages
Hit http://archive.ubuntu.com lucid-updates Release.gpg
Hit http://ppa.launchpad.net lucid Release.gpg
Ign http://ppa.launchpad.net lucid Release.gpg
Hit http://packages.medibuntu.org lucid Release.gpg
Hit http://archive.ubuntu.com lucid-updates Release
Hit http://ppa.launchpad.net lucid Release
Hit http://archive.ubuntu.com lucid-updates/main Packages
Ign http://ppa.launchpad.net lucid Release
Hit http://packages.medibuntu.org lucid Release
Hit http://archive.ubuntu.com lucid-updates/universe Packages
Hit http://archive.ubuntu.com lucid-updates/multiverse Packages
Hit http://archive.ubuntu.com lucid-updates/restricted Packages
Hit http://ppa.launchpad.net lucid/main Packages
Ign http://ppa.launchpad.net lucid/main Packages
Hit http://packages.medibuntu.org lucid/free Packages
Ign http://ppa.launchpad.net lucid/main Packages
Err http://ppa.launchpad.net lucid/main Packages
  404 Not Found
Hit http://ubuntu.bigbluebutton.org bigbluebutton-lucid Release.gpg
Hit http://ubuntu.bigbluebutton.org bigbluebutton-lucid Release
Ign http://ubuntu.bigbluebutton.org bigbluebutton-lucid/main Packages
Ign http://ubuntu.bigbluebutton.org bigbluebutton-lucid/main Packages
Hit http://ubuntu.bigbluebutton.org bigbluebutton-lucid/main Packages
W: Failed to fetch http://ppa.launchpad.net/user/ppa-name/ubuntu/dists/lucid/main/binary-i386/Packages.gz 404 Not Found

E: Some index files failed to download, they have been ignored, or old ones used instead.
user@foo:/etc/apt$ find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; cat -n "$1"' _ '{}' \;

/etc/apt/sources.list

     1 #
     2 # deb cdrom:[Xubuntu 8.10 _Intrepid Ibex_ - Release i386 (20081028)]/ intrepid main multiverse restricted universe
     3
     4 # deb cdrom:[Xubuntu 8.10 _Intrepid Ibex_ - Release i386 (20081028)]/ intrepid main multiverse restricted universe
     5 # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
     6 # newer versions of the distribution.
     7
     8 #__________________________________
     9 # deb http://archive.ubuntu.com/ubuntu/dists/lucid/ lucid main universe multiverse restricted
    10 #__________________________________
    11
    12
    13 # deb http://archive.ubuntu.com/ubuntu lucid main restricted
    14 # deb-src http://archive.ubuntu.com/ubuntu lucid main restricted #Added by software-properties
    15
    16 ## Major bug fix updates produced after the final release of the
    17 ## distribution.
    18
    19 deb http://archive.ubuntu.com/ubuntu lucid-updates main universe multiverse restricted # lucid-security
    20
    21 # deb-src http://archive.ubuntu.com/ubuntu lucid-updates main restricted #Added by software-properties
    22
    23 ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    24 ## team. Also, please note that software in universe WILL NOT receive any
    25 ## review or updates from the Ubuntu security team.
    26 # deb http://us.archive.ubuntu.com/ubuntu/ lucid universe
    27 # deb-src http://us.archive.ubuntu.com/ubuntu/ lucid universe
    28 # deb http://us.archive.ubuntu.com/ubuntu/ lucid-updates universe
    29 # deb-src http://us.archive.ubuntu.com/ubuntu/ lucid-updates universe
    30
    31 ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    32 ## team, and may not be under a free licence. Please satisfy yourself as to
    33 ## your rights to use the software. Also, please note that software in
    34 ## multiverse WILL NOT receive any review or updates from the Ubuntu
    35 ## security team.
    36 # deb http://us.archive.ubuntu.com/ubuntu/ lucid multiverse
    37 # deb-src http://us.archive.ubuntu.com/ubuntu/ lucid multiverse
    38 # deb http://us.archive.ubuntu.com/ubuntu/ lucid-updates multiverse
    39 # deb-src http://us.archive.ubuntu.com/ubuntu/ lucid-updates multiverse
    40
    41 ## Uncomment the following two lines to add software from the 'backports'
    42 ## repository.
    43 ## N.B. software from this repository may not have been tested as
    44 ## extensively as that contained in the main release, although it includes
    45 ## newer versions of some applications which may provide useful features.
    46 ## Also, please note that software in backports WILL NOT receive any review
    47 ## or updates from the Ubuntu security team.
    48 # deb http://us.archive.ubuntu.com/ubuntu/ intrepid-backports main restricted universe multiverse
    49 # deb-src http://us.archive.ubuntu.com/ubuntu/ intrepid-backports main restricted universe multiverse
    50
    51 ## Uncomment the following two lines to add software from Canonical's
    52 ## 'partner' repository. This software is not part of Ubuntu, but is
    53 ## offered by Canonical and the respective vendors as a service to Ubuntu
    54 ## users.
    55 # deb http://archive.canonical.com/ubuntu lucid partner
    56 # deb-src http://archive.canonical.com/ubuntu lucid partner
    57
    58
    59 # Added by software-properties
    60 # deb-src http://archive.ubuntu.com/ubuntu lucid-security restricted main multiverse universe
    61
    62 # deb http://archive.ubuntu.com/ubuntu lucid-security universe
    63
    64 # deb http://download.virtualbox.org/virtualbox/debian lucid non-free
    65 # deb http://download.virtualbox.org/virtualbox/debian lucid contrib non-free
    66
    67 # Google stuff here
    68 # deb http://dl.google.com/linux/deb/ stable non-free main # disabled on upgrade to lucid
    69
    70 # deb http://us.archive.ubuntu.com/ubuntu/ lucid multiverse

/etc/apt/sources.list.d/bigbluebutton.list

     1 deb http://ubuntu.bigbluebutton.org/lucid_dev_08/ bigbluebutton-lucid main

/etc/apt/sources.list.d/medibuntu.list

     1 ## Please report any bug on https://bugs.launchpad.net/medibuntu/
     2 deb http://packages.medibuntu.org/ lucid free #Medibuntu - Ubuntu 10.04 "lucid lynx"
     3 # deb-src http://packages.medibuntu.org/ lucid free #Medibuntu (source) - Ubuntu 10.04 "lucid lynx"

/etc/apt/sources.list.d/freenx-team-ppa-lucid.list

     1 deb http://ppa.launchpad.net/freenx-team/ppa/ubuntu lucid main

/etc/apt/sources.list.d/user-ppa-name-lucid.list

     1 deb http://ppa.launchpad.net/user/ppa-name/ubuntu lucid main

/etc/apt/sources.list.d/opera.list

     1 # This file makes sure that Opera Browser is kept up-to-date
     2 # as part of regular system upgrades
     3
     4 # deb http://deb.opera.com/opera/ stable non-free # disabled on upgrade to lucid
     5
     6 # The line above will make sure you get all final public releases.
     7 # Uncomment the following line if you want to get alpha and beta
     8 # releases, too.
     9
    10 # deb http://deb.opera.com/opera-beta/ stable non-free

/etc/apt/sources.list.d/google-chrome.list

     1 ### THIS FILE IS AUTOMATICALLY CONFIGURED ###
     2 # You may comment out this entry, but any other modifications may be lost.
     3 deb http://dl.google.com/linux/chrome/deb/ stable main

---------------------------

It appears I need to straighten out an old / defunct reference to a source no longer in use.

Your help is appreciated.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu apt Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
marcobra (Marco Braida) (marcobra) said :
#1

Please copy and paste here the content of /etc/apt/sources.list file... there are some wrong line in it...

from terminal type:

gedit /etc/apt/sources.list

copy and paste content here...

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#2

sudo rm /etc/apt/sources.list.d/user-ppa-name-lucid.list
sudo apt-get update

Should now be smooth

Can you help with this problem?

Provide an answer of your own, or ask ThreadedKernel for more information if necessary.

To post a message you must log in.