How to set proxy address (my proxy address is 172.31.100.9) for software center in 12.04

Asked by sandipan on 2012-11-09

I have already set proxy in system settings> network > proxy ..
Web page is openning but i am not able to download any software from software center or any where ...

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu apt Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Warren Hill (warren-hill) said :
#1
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#2

Can you also please not post in all caps! It's harder to read and looks like you are SHOUTING! Take your finger off the SHIFT key and it makes everything ok.

Revision history for this message
marcobra (Marco Braida) (marcobra) said :
#3

Converted question in lowercase...

Revision history for this message
marcobra (Marco Braida) (marcobra) said :
#4

Please add an apt wide proxy set... and retry from terminal type:

gksudo gedit /etc/apt/apt.conf.d/proxy

and put in this file a row like this substitute the ip and the port with your settings:

Acquire::http::proxy "http://192.168.1.40:3128/";

or if your proxy need a ser and password put this row:

Acquire::http::proxy "http://user:password@proxy_ip:proxy_port/";

Hth

Revision history for this message
marcobra (Marco Braida) (marcobra) said :
#5

or set it directly in

gksudo gedit /etc/apt/apt.conf

Can you help with this problem?

Provide an answer of your own, or ask sandipan for more information if necessary.

To post a message you must log in.