dpkg error diagnostic

Asked by erl diarkara on 2012-10-06

prongs@prongs-desktop:~$ sudo grep -R proxy /etc/apt/*
prongs@prongs-desktop:~$ sudo fuser -vvv /var/lib/dpkg/lock
prongs@prongs-desktop:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu 10.04.3 LTS"
prongs@prongs-desktop:~$ uname -a
Linux prongs-desktop 2.6.32-33-generic #70-Ubuntu SMP Thu Jul 7 21:09:46 UTC 2011 i686 GNU/Linux
prongs@prongs-desktop:~$ sudo rm /var/lib/apt/lists/lock
prongs@prongs-desktop:~$ sudo cp -arf /var/lib/dpkg /var/lib/dpkg.backup
prongs@prongs-desktop:~$ sudo mv /var/lib/dpkg/status /var/lib/dpkg/status-bad
prongs@prongs-desktop:~$ sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status
prongs@prongs-desktop:~$ sudo mv /var/lib/dpkg/available /var/lib/dpkg/available-bad
prongs@prongs-desktop:~$ sudo cp /var/lib/dpkg/available-old /var/lib/dpkg/available
prongs@prongs-desktop:~$ sudo rm -rf /var/lib/dpkg/updates/*
prongs@prongs-desktop:~$ sudo rm -rf /var/lib/apt/lists
prongs@prongs-desktop:~$ sudo rm /var/cache/apt/*.bin
prongs@prongs-desktop:~$ sudo mkdir /var/lib/apt/lists
prongs@prongs-desktop:~$ sudo mkdir /var/lib/apt/lists/partial
prongs@prongs-desktop:~$ LANG=C;sudo apt-get clean
prongs@prongs-desktop:~$ LANG=C;sudo apt-get autoclean
Reading package lists... Done
Building dependency tree
Reading state information... Done
prongs@prongs-desktop:~$ LANG=C;sudo apt-get --purge autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  man-db: Depends: groff-base (>= 1.18.1.1-15) but it is not installable
          Depends: bsdmainutils but it is not installable
          Depends: debconf (>= 1.2.0) but it is not installable or
                   debconf-2.0 but it is not installable
          Depends: dpkg (>= 1.9.0) but it is not installable
          Depends: libc6 (>= 2.8) but it is not installable
          Depends: libgdbm3 (>= 1.8.3) but it is not installable
          Depends: zlib1g (>= 1:1.1.4) but it is not installable
E: Unmet dependencies. Try using -f.
prongs@prongs-desktop:~$ LANG=C;sudo apt-get update -o APT::Cache-Limit=25165824Get:1 http://ppa.launchpad.net lucid Release.gpg [316B]
Get:2 http://archive.ubuntu.com lucid Release.gpg [189B]
Get:3 http://ppa.launchpad.net lucid Release [14.0kB]
Get:4 http://archive.ubuntu.com lucid-updates Release.gpg [198B]
Get:5 http://archive.ubuntu.com lucid-security Release.gpg [198B]
Get:6 http://ppa.launchpad.net lucid/main Packages [5721B]
Get:7 http://archive.ubuntu.com lucid Release [57.2kB]
Get:8 http://archive.ubuntu.com lucid-updates Release [58.3kB]
Get:9 http://archive.ubuntu.com lucid-security Release [57.3kB]
Get:10 http://archive.ubuntu.com lucid/main Packages [1386kB]
Get:11 http://archive.ubuntu.com lucid/restricted Packages [6208B]
Get:12 http://archive.ubuntu.com lucid/main Sources [659kB]
Get:13 http://archive.ubuntu.com lucid/restricted Sources [3775B]
Get:14 http://archive.ubuntu.com lucid/universe Packages [5448kB]
Get:15 http://archive.ubuntu.com lucid/universe Sources [3165kB]
Get:16 http://archive.ubuntu.com lucid/multiverse Packages [180kB]
Get:17 http://archive.ubuntu.com lucid/multiverse Sources [119kB]
Get:18 http://archive.ubuntu.com lucid-updates/main Packages [648kB]
Get:19 http://archive.ubuntu.com lucid-updates/restricted Packages [4630B]
Get:20 http://archive.ubuntu.com lucid-updates/main Sources [230kB]
Get:21 http://archive.ubuntu.com lucid-updates/restricted Sources [2196B]
Get:22 http://archive.ubuntu.com lucid-updates/universe Packages [278kB]
Get:23 http://archive.ubuntu.com lucid-updates/universe Sources [104kB]
Get:24 http://archive.ubuntu.com lucid-updates/multiverse Packages [11.5kB]
Get:25 http://archive.ubuntu.com lucid-updates/multiverse Sources [5821B]
Get:26 http://archive.ubuntu.com lucid-security/main Packages [455kB]
Get:27 http://archive.ubuntu.com lucid-security/restricted Packages [2867B]
Get:28 http://archive.ubuntu.com lucid-security/main Sources [131kB]
Get:29 http://archive.ubuntu.com lucid-security/restricted Sources [1267B]
Get:30 http://archive.ubuntu.com lucid-security/universe Packages [135kB]
Get:31 http://archive.ubuntu.com lucid-security/universe Sources [42.0kB]
Get:32 http://archive.ubuntu.com lucid-security/multiverse Packages [5372B]
Get:33 http://archive.ubuntu.com lucid-security/multiverse Sources [2321B]
Fetched 13.2MB in 2min 4s (106kB/s)
Reading package lists... Error!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_lucid_universe_binary-i386_Packages
E: The package lists or status file could not be parsed or opened.
prongs@prongs-desktop:~$ sudo dpkg --configure -a
prongs@prongs-desktop:~$ sudo dpkg --clear-avail
prongs@prongs-desktop:~$ LANG=C;sudo apt-get -f install
Reading package lists... Error!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_lucid_universe_binary-i386_Packages
E: The package lists or status file could not be parsed or opened.
prongs@prongs-desktop:~$ LANG=C;sudo apt-get --fix-missing install
Reading package lists... Error!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_lucid_universe_binary-i386_Packages
E: The package lists or status file could not be parsed or opened.
prongs@prongs-desktop:~$ LANG=C;sudo apt-get update -o APT::Cache-Limit=25165824 && sudo apt-get dist-upgrade
Hit http://archive.ubuntu.com lucid Release.gpg
Hit http://ppa.launchpad.net lucid Release.gpg
Hit http://archive.ubuntu.com lucid-updates Release.gpg
Hit http://ppa.launchpad.net lucid Release
Hit http://archive.ubuntu.com lucid-security Release.gpg
Hit http://archive.ubuntu.com lucid Release
Hit http://ppa.launchpad.net lucid/main Packages
Hit http://archive.ubuntu.com lucid-updates Release
Hit http://archive.ubuntu.com lucid-security Release
Hit http://archive.ubuntu.com lucid/main Packages
Hit http://archive.ubuntu.com lucid/restricted Packages
Hit http://archive.ubuntu.com lucid/main Sources
Hit http://archive.ubuntu.com lucid/restricted Sources
Hit http://archive.ubuntu.com lucid/universe Packages
Hit http://archive.ubuntu.com lucid/universe Sources
Hit http://archive.ubuntu.com lucid/multiverse Packages
Hit http://archive.ubuntu.com lucid/multiverse Sources
Hit http://archive.ubuntu.com lucid-updates/main Packages
Hit http://archive.ubuntu.com lucid-updates/restricted Packages
Hit http://archive.ubuntu.com lucid-updates/main Sources
Hit http://archive.ubuntu.com lucid-updates/restricted Sources
Hit http://archive.ubuntu.com lucid-updates/universe Packages
Hit http://archive.ubuntu.com lucid-updates/universe Sources
Hit http://archive.ubuntu.com lucid-updates/multiverse Packages
Hit http://archive.ubuntu.com lucid-updates/multiverse Sources
Hit http://archive.ubuntu.com lucid-security/main Packages
Hit http://archive.ubuntu.com lucid-security/restricted Packages
Hit http://archive.ubuntu.com lucid-security/main Sources
Hit http://archive.ubuntu.com lucid-security/restricted Sources
Hit http://archive.ubuntu.com lucid-security/universe Packages
Hit http://archive.ubuntu.com lucid-security/universe Sources
Hit http://archive.ubuntu.com lucid-security/multiverse Packages
Hit http://archive.ubuntu.com lucid-security/multiverse Sources
Reading package lists... Error!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_lucid_universe_binary-i386_Packages
E: The package lists or status file could not be parsed or opened.
prongs@prongs-desktop:~$ find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; cat -n "$1"' _ '{}' \;

/etc/apt/sources.list.d/tldm217-tahutek.net-lucid.list

     1 deb http://ppa.launchpad.net/tldm217/tahutek.net/ubuntu lucid main

/etc/apt/sources.list

     1 # deb cdrom:[Ubuntu 10.04.3 LTS _Lucid Lynx_ - Release i386 (20110720.1)]/ lucid main restricted
     2 # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
     3 # newer versions of the distribution.
     4
     5 deb http://archive.ubuntu.com/ubuntu lucid main restricted
     6 deb-src http://archive.ubuntu.com/ubuntu lucid main restricted
     7
     8 ## Major bug fix updates produced after the final release of the
     9 ## distribution.
    10 deb http://archive.ubuntu.com/ubuntu lucid-updates main restricted
    11 deb-src http://archive.ubuntu.com/ubuntu lucid-updates main restricted
    12
    13 ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    14 ## team. Also, please note that software in universe WILL NOT receive any
    15 ## review or updates from the Ubuntu security team.
    16 deb http://archive.ubuntu.com/ubuntu lucid universe
    17 deb-src http://archive.ubuntu.com/ubuntu lucid universe
    18 deb http://archive.ubuntu.com/ubuntu lucid-updates universe
    19 deb-src http://archive.ubuntu.com/ubuntu lucid-updates universe
    20
    21 ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    22 ## team, and may not be under a free licence. Please satisfy yourself as to
    23 ## your rights to use the software. Also, please note that software in
    24 ## multiverse WILL NOT receive any review or updates from the Ubuntu
    25 ## security team.
    26 deb http://archive.ubuntu.com/ubuntu lucid multiverse
    27 deb-src http://archive.ubuntu.com/ubuntu lucid multiverse
    28 deb http://archive.ubuntu.com/ubuntu lucid-updates multiverse
    29 deb-src http://archive.ubuntu.com/ubuntu lucid-updates multiverse
    30
    31 ## Uncomment the following two lines to add software from the 'backports'
    32 ## repository.
    33 ## N.B. software from this repository may not have been tested as
    34 ## extensively as that contained in the main release, although it includes
    35 ## newer versions of some applications which may provide useful features.
    36 ## Also, please note that software in backports WILL NOT receive any review
    37 ## or updates from the Ubuntu security team.
    38 # deb http://id.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse
    39 # deb-src http://id.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse
    40
    41 ## Uncomment the following two lines to add software from Canonical's
    42 ## 'partner' repository.
    43 ## This software is not part of Ubuntu, but is offered by Canonical and the
    44 ## respective vendors as a service to Ubuntu users.
    45 # deb http://archive.canonical.com/ubuntu lucid partner
    46 # deb-src http://archive.canonical.com/ubuntu lucid partner
    47
    48 deb http://archive.ubuntu.com/ubuntu lucid-security main restricted
    49 deb-src http://archive.ubuntu.com/ubuntu lucid-security main restricted
    50 deb http://archive.ubuntu.com/ubuntu lucid-security universe
    51 deb-src http://archive.ubuntu.com/ubuntu lucid-security universe
    52 deb http://archive.ubuntu.com/ubuntu lucid-security multiverse
    53 deb-src http://archive.ubuntu.com/ubuntu lucid-security multiverse

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu apt Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
marcobra (Marco Braida) (marcobra) said :
#1

Please try:

sudo rm /var/lib/apt/lists/* -vf
sudo apt-get update

Can you help with this problem?

Provide an answer of your own, or ask erl diarkara for more information if necessary.

To post a message you must log in.