java not updating (apt-get update)

Asked by Anton Kanishchev on 2012-05-13

I try to update my packages and get the following error (12.04 lts, 3.2 kernel)

...Ign http://linux.dropbox.com precise/main Translation-en
Hit http://www.geekconnection.org karmic/ Packages
Ign http://www.geekconnection.org karmic/ Translation-en_GB
Ign http://www.geekconnection.org karmic/ Translation-en
Fetched 2,813 B in 3s (806 B/s)
W: Failed to fetch http://ppa.launchpad.net/ferramroberto/java/ubuntu/dists/precise/main/source/Sources 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/ferramroberto/java/ubuntu/dists/precise/main/binary-i386/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

I am quite new to this--do i just uncheck the failing packages from the software list or point the apt-get towards another mirror or something???

I do have an internet connection so that isnt a problem. I understand that it cant update because the server is down- is that correct or have i messed some setting up that is preventing the update. Firewall is on but it only rejects connections on port 22.

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu apt Edit question
Assignee:
No assignee Edit question
Solved by:
Grzegorz G.
Solved:
2012-05-13
Last query:
2012-05-13
Last reply:
2012-05-13
Best Grzegorz G. (grzesiek1e5) said : #1

It's because ferramroberto builds (packages? distributes?) Java only for Lucid, Maverick, Natty and Oneiric. See this link:
http://ppa.launchpad.net/ferramroberto/java/ubuntu/dists/
There are no packages for precise in this PPA. Maybe you don't need closed Java, and OpenJDK together with IcedTea is enough for you? You can find them in Ubuntu Software Center. But if you need it... AFAIK newest closed Java is Java 7, not Java 6. See this link for info on how to install Java 7:
http://www.webupd8.org/2012/01/install-oracle-java-jdk-7-in-ubuntu-via.html

Nwm i solved it--- just for archiving purposes went to this link to solve :

http://askubuntu.com/questions/65911/how-can-i-fix-a-404-error-using-a-ppa

Thanks Grzegorz G., that solved my question.

ye- i understand what i was doing now-- i was trying to install a ppa that no longer works with 12.04. I have installed the openjdk from ubuntu software centre--- does this mean i get the jre as well???

Thanks

Grzegorz G. (grzesiek1e5) said : #5

Yes, JRE is included. But install IcedTea too, it's Java plugin for your browser.