Broken packages after upgrade to precise

Asked by James Cowgill on 2012-04-03

During the upgrade I had a power failure. After running an apt-get dist-upgrade, everything seems to work except I have a few broken packages:

Following the instructions in https://help.ubuntu.com/community/PackageManagerTroubleshootingProcedure

james@pingo:~$ sudo fuser -vvv /var/lib/dpkg/lock
james@pingo:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu precise (development branch)"
james@pingo:~$ uname -a
Linux pingo 3.2.0-21-generic #34-Ubuntu SMP Fri Mar 30 04:25:35 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
james@pingo:~$ sudo rm /var/lib/apt/lists/lock
james@pingo:~$ sudo cp -arf /var/lib/dpkg /var/lib/dpkg.backup
james@pingo:~$ sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status
james@pingo:~$ sudo cp /var/lib/dpkg/available-old /var/lib/dpkg/available
james@pingo:~$ sudo rm -rf /var/lib/dpkg/updates/*
james@pingo:~$ sudo rm -rf /var/lib/apt/lists
james@pingo:~$ sudo rm /var/cache/apt/*.bin
james@pingo:~$ sudo mkdir /var/lib/apt/lists
james@pingo:~$ sudo mkdir /var/lib/apt/lists/partial
james@pingo:~$ LANG=C;sudo apt-get clean
james@pingo:~$ LANG=C;sudo apt-get autoclean
Reading package lists... Done
Building dependency tree
Reading state information... Done
james@pingo:~$ LANG=C;sudo apt-get --purge autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run ‘apt-get -f install’ to correct these.
The following packages have unmet dependencies.
 libsoup-gnome2.4-1 : Breaks: libsoup-gnome2.4-1:i386 (!= 2.38.0-1) but 2.38.0-0ubuntu1 is installed
 libsoup-gnome2.4-1:i386 : Breaks: libsoup-gnome2.4-1 (!= 2.38.0-0ubuntu1) but 2.38.0-1 is installed
 libsoup2.4-1 : Breaks: libsoup2.4-1:i386 (!= 2.38.0-1) but 2.38.0-0ubuntu1 is installed
 libsoup2.4-1:i386 : Breaks: libsoup2.4-1 (!= 2.38.0-0ubuntu1) but 2.38.0-1 is installed
E: Unmet dependencies. Try using -f.
james@pingo:~$ LANG=C;sudo apt-get update -o APT::Cache-Limit=25165824
Ign http://extras.ubuntu.com precise InRelease
Ign http://archive.canonical.com precise InRelease
Get:1 http://extras.ubuntu.com precise Release.gpg [72 B]
Get:2 http://archive.canonical.com precise Release.gpg [198 B]
Ign http://archive.ubuntu.com precise InRelease
Ign http://archive.ubuntu.com precise-updates InRelease
Ign http://archive.ubuntu.com precise-security InRelease
Get:3 http://extras.ubuntu.com precise Release [11.9 kB]
Get:4 http://archive.canonical.com precise Release [7078 B]
Get:5 http://archive.ubuntu.com precise Release.gpg [198 B]
Get:6 http://archive.ubuntu.com precise-updates Release.gpg [198 B]
Get:7 http://archive.ubuntu.com precise-security Release.gpg [198 B]
Get:8 http://archive.canonical.com precise/partner Sources [2979 B]
Get:9 http://archive.ubuntu.com precise Release [49.6 kB]
Get:10 http://extras.ubuntu.com precise/main Sources [14 B]
Get:11 http://archive.canonical.com precise/partner amd64 Packages [3762 B]
Get:12 http://archive.canonical.com precise/partner i386 Packages [4868 B]
Get:13 http://extras.ubuntu.com precise/main amd64 Packages [14 B]
Get:14 http://extras.ubuntu.com precise/main i386 Packages [14 B]
Ign http://extras.ubuntu.com precise/main TranslationIndex
Ign http://archive.canonical.com precise/partner TranslationIndex
Get:15 http://archive.ubuntu.com precise-updates Release [28.9 kB]
Get:16 http://archive.ubuntu.com precise-security Release [28.9 kB]
Get:17 http://archive.ubuntu.com precise/main Sources [928 kB]
Ign http://extras.ubuntu.com precise/main Translation-en_GB
Ign http://extras.ubuntu.com precise/main Translation-en
Ign http://archive.canonical.com precise/partner Translation-en_GB
Ign http://archive.canonical.com precise/partner Translation-en
Get:18 http://archive.ubuntu.com precise/restricted Sources [5011 B]
Get:19 http://archive.ubuntu.com precise/universe Sources [5064 kB]
Get:20 http://archive.ubuntu.com precise/multiverse Sources [157 kB]
Get:21 http://archive.ubuntu.com precise/main amd64 Packages [1284 kB]
Get:22 http://archive.ubuntu.com precise/restricted amd64 Packages [8421 B]
Get:23 http://archive.ubuntu.com precise/universe amd64 Packages [4831 kB]
Get:24 http://archive.ubuntu.com precise/multiverse amd64 Packages [120 kB]
Get:25 http://archive.ubuntu.com precise/main i386 Packages [1284 kB]
Get:26 http://archive.ubuntu.com precise/restricted i386 Packages [8356 B]
Get:27 http://archive.ubuntu.com precise/universe i386 Packages [4841 kB]
Get:28 http://archive.ubuntu.com precise/multiverse i386 Packages [122 kB]
Get:29 http://archive.ubuntu.com precise/main TranslationIndex [3570 B]
Get:30 http://archive.ubuntu.com precise/multiverse TranslationIndex [2540 B]
Get:31 http://archive.ubuntu.com precise/restricted TranslationIndex [2464 B]
Get:32 http://archive.ubuntu.com precise/universe TranslationIndex [2784 B]
Get:33 http://archive.ubuntu.com precise-updates/main Sources [14 B]
Get:34 http://archive.ubuntu.com precise-updates/restricted Sources [14 B]
Get:35 http://archive.ubuntu.com precise-updates/universe Sources [14 B]
Get:36 http://archive.ubuntu.com precise-updates/multiverse Sources [14 B]
Get:37 http://archive.ubuntu.com precise-updates/main amd64 Packages [14 B]
Get:38 http://archive.ubuntu.com precise-updates/restricted amd64 Packages [14 B]
Get:39 http://archive.ubuntu.com precise-updates/universe amd64 Packages [14 B]
Get:40 http://archive.ubuntu.com precise-updates/multiverse amd64 Packages [14 B]
Get:41 http://archive.ubuntu.com precise-updates/main i386 Packages [14 B]
Get:42 http://archive.ubuntu.com precise-updates/restricted i386 Packages [14 B]
Get:43 http://archive.ubuntu.com precise-updates/universe i386 Packages [14 B]
Get:44 http://archive.ubuntu.com precise-updates/multiverse i386 Packages [14 B]
Get:45 http://archive.ubuntu.com precise-updates/main TranslationIndex [70 B]
Get:46 http://archive.ubuntu.com precise-updates/multiverse TranslationIndex [70 B]
Get:47 http://archive.ubuntu.com precise-updates/restricted TranslationIndex [70 B]
Get:48 http://archive.ubuntu.com precise-updates/universe TranslationIndex [70 B]
Get:49 http://archive.ubuntu.com precise-security/main Sources [14 B]
Get:50 http://archive.ubuntu.com precise-security/restricted Sources [14 B]
Get:51 http://archive.ubuntu.com precise-security/universe Sources [14 B]
Get:52 http://archive.ubuntu.com precise-security/multiverse Sources [14 B]
Get:53 http://archive.ubuntu.com precise-security/main amd64 Packages [14 B]
Get:54 http://archive.ubuntu.com precise-security/restricted amd64 Packages [14 B]
Get:55 http://archive.ubuntu.com precise-security/universe amd64 Packages [14 B]
Get:56 http://archive.ubuntu.com precise-security/multiverse amd64 Packages [14 B]
Get:57 http://archive.ubuntu.com precise-security/main i386 Packages [14 B]
Get:58 http://archive.ubuntu.com precise-security/restricted i386 Packages [14 B]
Get:59 http://archive.ubuntu.com precise-security/universe i386 Packages [14 B]
Get:60 http://archive.ubuntu.com precise-security/multiverse i386 Packages [14 B]
Get:61 http://archive.ubuntu.com precise-security/main TranslationIndex [70 B]
Get:62 http://archive.ubuntu.com precise-security/multiverse TranslationIndex [70 B]
Get:63 http://archive.ubuntu.com precise-security/restricted TranslationIndex [70 B]
Get:64 http://archive.ubuntu.com precise-security/universe TranslationIndex [70 B]
Get:65 http://archive.ubuntu.com precise/main Translation-en_GB [77.3 kB]
Get:66 http://archive.ubuntu.com precise/main Translation-en [723 kB]
Get:67 http://archive.ubuntu.com precise/multiverse Translation-en_GB [79.9 kB]
Get:68 http://archive.ubuntu.com precise/multiverse Translation-en [94.6 kB]
Get:69 http://archive.ubuntu.com precise/restricted Translation-en_GB [2406 B]
Get:70 http://archive.ubuntu.com precise/restricted Translation-en [2229 B]
Get:71 http://archive.ubuntu.com precise/universe Translation-en_GB [5416 B]
Get:72 http://archive.ubuntu.com precise/universe Translation-en [3369 kB]
Get:73 http://archive.ubuntu.com precise-updates/main Translation-en [14 B]
Get:74 http://archive.ubuntu.com precise-updates/multiverse Translation-en [14 B]
Get:75 http://archive.ubuntu.com precise-updates/restricted Translation-en [14 B]
Get:76 http://archive.ubuntu.com precise-updates/universe Translation-en [14 B]
Get:77 http://archive.ubuntu.com precise-security/main Translation-en [14 B]
Get:78 http://archive.ubuntu.com precise-security/multiverse Translation-en [14 B]
Get:79 http://archive.ubuntu.com precise-security/restricted Translation-en [14 B]
Get:80 http://archive.ubuntu.com precise-security/universe Translation-en [14 B]
Fetched 23.2 MB in 33s (691 kB/s)
E: Dynamic MMap ran out of room. Please increase the size of APT::Cache-Limit. Current value: 25165824. (man 5 apt.conf)
Reading package lists... Error!
E: Unable to increase the size of the MMap as the limit of 25165824 bytes is already reached.
E: Dynamic MMap ran out of room. Please increase the size of APT::Cache-Limit. Current value: 25165824. (man 5 apt.conf)
E: Error occurred while processing isdnutils-base (NewVersion2)
E: Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_precise_universe_binary-i386_Packages
E: The package lists or status file could not be parsed or opened.
james@pingo:~$ sudo dpkg --configure -a
dpkg: error processing libsoup2.4-1 (--configure):
 libsoup2.4-1:amd64 2.38.0-1 cannot be configured because libsoup2.4-1:i386 is in a different version (2.38.0-0ubuntu1)
dpkg: error processing libsoup2.4-1:i386 (--configure):
 libsoup2.4-1:i386 2.38.0-0ubuntu1 cannot be configured because libsoup2.4-1:amd64 is in a different version (2.38.0-1)
dpkg: error processing libsoup-gnome2.4-1 (--configure):
 libsoup-gnome2.4-1:amd64 2.38.0-1 cannot be configured because libsoup-gnome2.4-1:i386 is in a different version (2.38.0-0ubuntu1)
dpkg: error processing libsoup-gnome2.4-1:i386 (--configure):
 libsoup-gnome2.4-1:i386 2.38.0-0ubuntu1 cannot be configured because libsoup-gnome2.4-1:amd64 is in a different version (2.38.0-1)
dpkg: dependency problems prevent configuration of gstreamer0.10-plugins-good:i386:
 gstreamer0.10-plugins-good:i386 depends on libsoup-gnome2.4-1 (>= 2.27.4); however:
  Package libsoup-gnome2.4-1:i386 is not configured yet.
 gstreamer0.10-plugins-good:i386 depends on libsoup2.4-1 (>= 2.26.1); however:
  Package libsoup2.4-1:i386 is not configured yet.
dpkg: error processing gstreamer0.10-plugins-good:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ia32-libs-multiarch:i386:
 ia32-libs-multiarch:i386 depends on gstreamer0.10-plugins-good; however:
  Package gstreamer0.10-plugins-good:i386 is not configured yet.
dpkg: error processing ia32-libs-multiarch:i386 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libsoup2.4-1
 libsoup2.4-1:i386
 libsoup-gnome2.4-1
 libsoup-gnome2.4-1:i386
 gstreamer0.10-plugins-good:i386
 ia32-libs-multiarch:i386
james@pingo:~$ sudo dpkg --clear-avail
james@pingo:~$ LANG=C;sudo apt-get -y -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libsoup-gnome2.4-1:i386 libsoup2.4-1:i386
The following packages will be upgraded:
  libsoup-gnome2.4-1:i386 libsoup2.4-1:i386
2 upgraded, 0 newly installed, 0 to remove and 72 not upgraded.
6 not fully installed or removed.
Need to get 221 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu/ precise/main libsoup2.4-1 i386 2.38.0-1 [211 kB]
Get:2 http://archive.ubuntu.com/ubuntu/ precise/main libsoup-gnome2.4-1 i386 2.38.0-1 [9548 B]
Fetched 221 kB in 0s (482 kB/s)
dpkg: error processing libsoup2.4-1:i386 (--configure):
 libsoup2.4-1:i386 2.38.0-0ubuntu1 cannot be configured because libsoup2.4-1:amd64 is in a different version (2.38.0-1)
dpkg: error processing libsoup2.4-1 (--configure):
 libsoup2.4-1:amd64 2.38.0-1 cannot be configured because libsoup2.4-1:i386 is in a different version (2.38.0-0ubuntu1)
dpkg: error processing libsoup-gnome2.4-1:i386 (--configure):
 libsoup-gnome2.4-1:i386 2.38.0-0ubuntu1 cannot be configured because libsoup-gnome2.4-1:amd64 is in a different version (2.38.0-1)
dpkg: error processing libsoup-gnome2.4-1 (--configure):
 libsoup-gnome2.4-1:amd64 2.38.0-1 cannot be configured because libsoup-gnome2.4-1:i386 is in a different version (2.38.0-0ubuntu1)
dpkg: dependency problems prevent configuration of gstreamer0.10-plugins-good:i386:
 gstreamer0.10-plugins-good:i386 depends on libsoup-gnome2.4-1 (>= 2.27.4); however:
  Package libsoup-gnome2.4-1:i386 is not configured yet.
 gstreamer0.10-plugins-good:i386 depends on libsoup2.4-1 (>= 2.26.1); however:
  Package libsoup2.4-1:i386 is not configured yet.
dpkg: error processing gstreamer0.10-plugins-good:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ia32-libs-multiarch:i386:
 ia32-libs-multiarch:i386 depends on gstreamer0.10-plugins-good; however:
  Package gstreamer0.10-plugins-good:i386 is not configured yet.
dpkg: error processing ia32-libs-multiarch:i386 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libsoup2.4-1:i386
 libsoup2.4-1
 libsoup-gnome2.4-1:i386
 libsoup-gnome2.4-1
 gstreamer0.10-plugins-good:i386
 ia32-libs-multiarch:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)
james@pingo:~$ LANG=C;sudo apt-get --fix-missing install
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run ‘apt-get -f install’ to correct these.
The following packages have unmet dependencies.
 libsoup-gnome2.4-1 : Breaks: libsoup-gnome2.4-1:i386 (!= 2.38.0-1) but 2.38.0-0ubuntu1 is installed
 libsoup-gnome2.4-1:i386 : Breaks: libsoup-gnome2.4-1 (!= 2.38.0-0ubuntu1) but 2.38.0-1 is installed
 libsoup2.4-1 : Breaks: libsoup2.4-1:i386 (!= 2.38.0-1) but 2.38.0-0ubuntu1 is installed
 libsoup2.4-1:i386 : Breaks: libsoup2.4-1 (!= 2.38.0-0ubuntu1) but 2.38.0-1 is installed
E: Unmet dependencies. Try using -f.
james@pingo:~$ LANG=C;sudo apt-get update -o APT::Cache-Limit=25165824 && sudo apt-get dist-upgrade
Ign http://extras.ubuntu.com precise InRelease
Ign http://archive.canonical.com precise InRelease
Hit http://extras.ubuntu.com precise Release.gpg
Hit http://archive.canonical.com precise Release.gpg
Hit http://extras.ubuntu.com precise Release
Hit http://archive.canonical.com precise Release
Hit http://extras.ubuntu.com precise/main Sources
Hit http://archive.canonical.com precise/partner Sources
Ign http://archive.ubuntu.com precise InRelease
Ign http://archive.ubuntu.com precise-updates InRelease
Ign http://archive.ubuntu.com precise-security InRelease
Hit http://extras.ubuntu.com precise/main amd64 Packages
Hit http://extras.ubuntu.com precise/main i386 Packages
Ign http://extras.ubuntu.com precise/main TranslationIndex
Hit http://archive.canonical.com precise/partner amd64 Packages
Hit http://archive.canonical.com precise/partner i386 Packages
Ign http://archive.canonical.com precise/partner TranslationIndex
Hit http://archive.ubuntu.com precise Release.gpg
Hit http://archive.ubuntu.com precise-updates Release.gpg
Hit http://archive.ubuntu.com precise-security Release.gpg
Hit http://archive.ubuntu.com precise Release
Hit http://archive.ubuntu.com precise-updates Release
Hit http://archive.ubuntu.com precise-security Release
Hit http://archive.ubuntu.com precise/main Sources
Hit http://archive.ubuntu.com precise/restricted Sources
Hit http://archive.ubuntu.com precise/universe Sources
Hit http://archive.ubuntu.com precise/multiverse Sources
Hit http://archive.ubuntu.com precise/main amd64 Packages
Hit http://archive.ubuntu.com precise/restricted amd64 Packages
Hit http://archive.ubuntu.com precise/universe amd64 Packages
Hit http://archive.ubuntu.com precise/multiverse amd64 Packages
Hit http://archive.ubuntu.com precise/main i386 Packages
Hit http://archive.ubuntu.com precise/restricted i386 Packages
Hit http://archive.ubuntu.com precise/universe i386 Packages
Hit http://archive.ubuntu.com precise/multiverse i386 Packages
Hit http://archive.ubuntu.com precise/main TranslationIndex
Hit http://archive.ubuntu.com precise/multiverse TranslationIndex
Hit http://archive.ubuntu.com precise/restricted TranslationIndex
Hit http://archive.ubuntu.com precise/universe TranslationIndex
Hit http://archive.ubuntu.com precise-updates/main Sources
Hit http://archive.ubuntu.com precise-updates/restricted Sources
Hit http://archive.ubuntu.com precise-updates/universe Sources
Hit http://archive.ubuntu.com precise-updates/multiverse Sources
Hit http://archive.ubuntu.com precise-updates/main amd64 Packages
Hit http://archive.ubuntu.com precise-updates/restricted amd64 Packages
Hit http://archive.ubuntu.com precise-updates/universe amd64 Packages
Hit http://archive.ubuntu.com precise-updates/multiverse amd64 Packages
Ign http://extras.ubuntu.com precise/main Translation-en_GB
Hit http://archive.ubuntu.com precise-updates/main i386 Packages
Hit http://archive.ubuntu.com precise-updates/restricted i386 Packages
Hit http://archive.ubuntu.com precise-updates/universe i386 Packages
Hit http://archive.ubuntu.com precise-updates/multiverse i386 Packages
Hit http://archive.ubuntu.com precise-updates/main TranslationIndex
Ign http://archive.canonical.com precise/partner Translation-en_GB
Hit http://archive.ubuntu.com precise-updates/multiverse TranslationIndex
Ign http://extras.ubuntu.com precise/main Translation-en
Hit http://archive.ubuntu.com precise-updates/restricted TranslationIndex
Hit http://archive.ubuntu.com precise-updates/universe TranslationIndex
Hit http://archive.ubuntu.com precise-security/main Sources
Hit http://archive.ubuntu.com precise-security/restricted Sources
Hit http://archive.ubuntu.com precise-security/universe Sources
Ign http://archive.canonical.com precise/partner Translation-en
Hit http://archive.ubuntu.com precise-security/multiverse Sources
Hit http://archive.ubuntu.com precise-security/main amd64 Packages
Hit http://archive.ubuntu.com precise-security/restricted amd64 Packages
Hit http://archive.ubuntu.com precise-security/universe amd64 Packages
Hit http://archive.ubuntu.com precise-security/multiverse amd64 Packages
Hit http://archive.ubuntu.com precise-security/main i386 Packages
Hit http://archive.ubuntu.com precise-security/restricted i386 Packages
Hit http://archive.ubuntu.com precise-security/universe i386 Packages
Hit http://archive.ubuntu.com precise-security/multiverse i386 Packages
Hit http://archive.ubuntu.com precise-security/main TranslationIndex
Hit http://archive.ubuntu.com precise-security/multiverse TranslationIndex
Hit http://archive.ubuntu.com precise-security/restricted TranslationIndex
Hit http://archive.ubuntu.com precise-security/universe TranslationIndex
Hit http://archive.ubuntu.com precise/main Translation-en_GB
Hit http://archive.ubuntu.com precise/main Translation-en
Hit http://archive.ubuntu.com precise/multiverse Translation-en_GB
Hit http://archive.ubuntu.com precise/multiverse Translation-en
Hit http://archive.ubuntu.com precise/restricted Translation-en_GB
Hit http://archive.ubuntu.com precise/restricted Translation-en
Hit http://archive.ubuntu.com precise/universe Translation-en_GB
Hit http://archive.ubuntu.com precise/universe Translation-en
Hit http://archive.ubuntu.com precise-updates/main Translation-en
Hit http://archive.ubuntu.com precise-updates/multiverse Translation-en
Hit http://archive.ubuntu.com precise-updates/restricted Translation-en
Hit http://archive.ubuntu.com precise-updates/universe Translation-en
Hit http://archive.ubuntu.com precise-security/main Translation-en
Hit http://archive.ubuntu.com precise-security/multiverse Translation-en
Hit http://archive.ubuntu.com precise-security/restricted Translation-en
Hit http://archive.ubuntu.com precise-security/universe Translation-en
E: Dynamic MMap ran out of room. Please increase the size of APT::Cache-Limit. Current value: 25165824. (man 5 apt.conf)
Reading package lists... Error!
E: Unable to increase the size of the MMap as the limit of 25165824 bytes is already reached.
E: Dynamic MMap ran out of room. Please increase the size of APT::Cache-Limit. Current value: 25165824. (man 5 apt.conf)
E: Error occurred while processing isdnutils-base (NewVersion2)
E: Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_precise_universe_binary-i386_Packages
E: The package lists or status file could not be parsed or opened.
james@pingo:~$

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu apt Edit question
Assignee:
No assignee Edit question
Solved by:
James Cowgill
Solved:
2012-04-03
Last query:
2012-04-03
Last reply:
2012-04-03

Try:

sudo apt-get --purge autoremove

James Cowgill (jcowgill) said : #2

I still get this:

james@pingo:~$ sudo apt-get --purge autoremove
[sudo] password for james:
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run ‘apt-get -f install’ to correct these.
The following packages have unmet dependencies.
 libsoup-gnome2.4-1 : Breaks: libsoup-gnome2.4-1:i386 (!= 2.38.0-1) but 2.38.0-0ubuntu1 is installed
 libsoup-gnome2.4-1:i386 : Breaks: libsoup-gnome2.4-1 (!= 2.38.0-0ubuntu1) but 2.38.0-1 is installed
 libsoup2.4-1 : Breaks: libsoup2.4-1:i386 (!= 2.38.0-1) but 2.38.0-0ubuntu1 is installed
 libsoup2.4-1:i386 : Breaks: libsoup2.4-1 (!= 2.38.0-0ubuntu1) but 2.38.0-1 is installed
E: Unmet dependencies. Try using -f.

James Cowgill (jcowgill) said : #3

It still happens

try:

sudo apt-get --purge remove libsoup-gnome2.4-1:i386 libsoup2.4-1:i386

You are running a 64bit OS so it seems weird you have 32bit packages installed.

James Cowgill (jcowgill) said : #5

Ok, after doing this:

sudo apt-get --purge remove libsoup-gnome2.4-1:i386 libsoup2.4-1:i386 gstreamer0.10-plugins-good:i386 ia32-libs-multiarch:i386 ia32-libs

It seems to have solved it.

Sergei Genchev (sgenchev) said : #6

 Same problem. It is not weird to have 32bit packages installed. you need 32bit libraries to run 32bit applications in 64 bit OS. Many 3rd party apps are 32 bit only: Citrix is the one I use but there are plenty of others.
 metapackage ia32-libs is not installable currently.