Apport enabled by default is ridiculous

Asked by Joerg Mueller on 2014-02-04

Dear package maintainers,

Thank you for your great effort and service to the open source community. Apport is a great tool, but I think having it enabled by default in saucy is ridiculous. It constantly annoys millions of users with pop-up windows when they reboot their machines. Most users will click cancel, so the windows occur over and over again. I think the many millions of clicks to dismiss these windows pose a severe burden to mankind, and I think this is the single biggest usability problem of Ubuntu. I would be really grateful if you could fix it! (I am referring to the "System program problem detected, Do you want to report this problem now? Cancel, Report Problem" popup. Most users always click on cancel, and never empty /var/crash, so the popup occurs over and over again).

Kind regards,
Joerg Mueller

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu apport Edit question
Assignee:
No assignee Edit question
Last query:
2014-02-04
Last reply:
2014-02-04

Bugs need reporting to make the OS better and to help the devs. Disabling the feature will slow down bug fixing. You are free to disable it by editting /etc/default/apport but I doubt this will ever be disabled by default.

tobaso (tobreme) said : #2

Constant and frequent apport crash dialogs appearing including re x-server and various applications.
I have Ununtu 13.10, I had the nouveau video driver disabled and the NVidia 319 driver installed and enabled. Constant apport crash notifications in all sorts of graphical apps including Thunderbird. My soulution : uninstall NVidia completely. Uninstall nouveau completely. Blacklist nouveau in /etc/modprobe.d/. Install NVidia from nvidia.com version 331.49 of driver. Result: in full day of heavy usage and three re-boots I have had no apport crash dialogs appear.

Can you help with this problem?

Provide an answer of your own, or ask Joerg Mueller for more information if necessary.

To post a message you must log in.