Can't use apport - 'not an official package'??

Asked by Jmor on 2013-02-11

I've been trying to report a kernel bug but apport doesn't work. I've tried several ways, as instructed;

ubuntu-bug linux
apport-cli -f
apport-cli -f -P 1
apport-cli -f -p linux --save bug.apport
apport-cli -f -p linux-image-3.5.0-17-generic --save bug.apport

These seem to be right based on the man pages and https://help.ubuntu.com/community/ReportingBugs , but all of them report something akin to

'This is not an official Ubuntu package. Please remove any third party package and try again.'

This seems wrong, not helpful, and odd, since I'm just booting from the downloaded official xubuntu 12.10 live DVD. It would seem that all packages in this distribution would be Official.

My question is, how can I report my kernel bug? Also, how can I report this bug against apport (I get the same error when I try to use apport to do so).

Please note other people seem to be having similar problems as well.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu apport Edit question
Assignee:
No assignee Edit question
Last query:
2013-02-11
Last reply:
2013-02-11
Warren Hill (warren-hill) said : #1

You can report a bug against apport here: https://bugs.launchpad.net/ubuntu/+source/apport

The apport system effectively does this in the background; the only difference is that it automatically includes additional information which the developers may find useful.

Include as much detail as you can

For kernal bug reporting see here
https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies or if that's not working file it here:
https://bugs.launchpad.net/ubuntu/+source/linux/+bugs

What is the output of:

uname -a; lsb_release -a

Thanks

N1ck 7h0m4d4k15 (nicktux) said : #3

Apport collects informations from your system , not only from the kernel , so if you have an Unofficial package installed (or upgraded through a PPA) then it will return the message you faced (no official package.. etc).

To report a bug with apport your system must be "clean" from external PPAs , especially those PPAs of upgrading essential system packages.

Thanks

Jmor (ubujoy3) said : #4

$ uname -a; lsb_release -a
Linux xubuntu 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal
$

Note that I filed the bug against apport using the web interface as suggested by Warren Hill above, at https://bugs.launchpad.net/ubuntu/+source/apport/+bug/1122220 . If someone can advise me a quick solution to the apport problem, I'd rather use apport to report the kernel bug, because it can gather all the info the devs might need. If there is no quick solution to apport, I will try to file the kernel bug manually as well.

Jmor (ubujoy3) said : #5

Hi NikTh, as I mentioned, I am just booting the xubuntu 12.10 liveDVD downloaded. I didn't install any new packages. So shouldn't all the package be Official?

Try:

ubuntu-bug linux-image-generic

Jmor (ubujoy3) said : #8

OK, making a little progress. I tried both ubuntu-bug and apport-cli using 'linux' as the package name; no dice. Tried 'linux-image-3.5.0-17-generic', also no good. Tried 'linux-image-generic', also no good.

BUT 'linux-image' seems to work, at least it gets a bit further. apport-cli generated a bug.apport report file with various system info; ubuntu-bug popped up a new 'Send problem report to the developers?' window rather than the same old 'not an official package' error message (I didn't go further than that so far).

HOWEVER, near the top of the ubuntu-bug window that pops up it says
   Package
       linux-image (not installed)

So I'm not certain the bug will be sent to the right place.

Besides the above problem the following issues still exist:

1) At https://help.ubuntu.com/community/ReportingBugs , it says you can file a bug against the kernel by doing

ubuntu-bug linux

and that clearly does not work, at least not for me.

2) There are several packages listed by dpkg-query -l | grep linux, including linux-image-generic, linux-image-3.5.0-17-generic, and a bunch of others. 'linux-image' is not even one of them. There's know way for the user to figure out that 'linux-image' is the secret magic word (if it is, in fact. Still not clear if the report will be filed correctly).

3) When you do 'apport-cli -f -p linux --save bug.apport', the full error message is:
---------------------------------
# apport-cli -f -p linux --save bug3.apport

*** Collecting problem information

The collected information can be sent to the developers to improve the
application. This might take a few minutes.
..........................

*** Problem in linux-image-3.5.0-17-generic

The problem cannot be reported:

This is not an official Ubuntu package. Please remove any third party package and try again.
#
---------------------------------

So it seems apport knows the right package if you type 'linux', but doesn't consider it Official unless you use the secret magic word, 'linux-image', which you would have know way of knowing.

4) apport still can't report a bug in the apport package, still saying its not an official package. dpkg-query -l says the apport package is called apport. I have no idea what other names to try for that package that might make it work.

5) Again, I'm assuming 'linux-image' will send the bug to the right place.

Can you help with this problem?

Provide an answer of your own, or ask Jmor for more information if necessary.

To post a message you must log in.