how to update dbgsym database ?

Asked by dino99 on 2011-09-02

i'm testing Oneiric i386 and report crash when it happen.
Some bug report are declared as "invalid" when missing info, like this one: bug: #839325, so i've followed DebuggingProgramCrash wiki to install the required dbgsym package.
After updating the whole system again, then shutdown/reboot to generate a new similar crash, i try again to report and get the stacktrace as needed (watching the report details before sending it to devs).
But again Apport retracing declare it as "invalid" and give that reason: system not updated, package & package-dbgsym version not matching (bug #839371)

So my questions:
- how is it possible ?
- i've used nautilus to find *dbgsym package/file/list but have not find any older ones: how apport can find them ?
- is there a database that need to be updated ? and how ?

i've reported against Apport for such issue: bug #839419

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu apport Edit question
Assignee:
No assignee Edit question
Solved by:
dino99
Solved:
2011-09-07
Last query:
2011-09-07
Last reply:
dino99 (9d9) said : #1

If Apport is not faulty, does that means dbgsym are only avaliable for Natty and not for testing distro ? or "deb http://ddebs.ubuntu.com oneiric main restricted universe multiverse " not updated ?

Sam_ (and-sam) said : #2

Happened before here once, but worked again after an upgrade. Don't remember Bug number where apported rejected it. Anyway, recently also installed -dbgsym and -dbg in order to create a backtrace for upstream, but no symbols found. Maybe depends on the package that sometimes it does and next time it doesn't get a backtrace. I'll have a look at silent crash reports which are still in /var/crash if they contain debug symbols or not.

dino99 (9d9) said : #3

Looks like the dbgsym package is not synced with the package source upgrade

Chrescht (sekateur) said : #4

Happened to me too..and it's a pity.
Is this a bug that should be reported manually?