Unable to access bug report in Kubuntu Natty

Asked by Shriramana Sharma on 2011-07-25

Last few bootups I have been seeing an "application crashed" icon in my tray on Kubuntu Natty. The tooltip says (as always) "an application has crashed on this system now or in the past".

However, when I try to access the bug report by clicking on the icon it shows an error window saying "You are not allowed to access this problem report".

How do I fix this?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu apport Edit question
Assignee:
No assignee Edit question
Solved by:
Eliah Kagan
Solved:
2011-07-27
Last query:
2011-07-27
Last reply:
2011-07-25

Are you signed in as a user with administrative powers? (If you can perform administrative tasks, like installing new software, then you are.)

If you are signed in as an administrator and you are not asked to type in a password in order to submit the problem report, then I don't know what's wrong, but you should be able to use an alternate method to submit the report. Open a Konsole window and run this command to enter the directory that contains problem reports:

cd /var/crash

Then run this command to list the various crash reports that are available. Please note that some of them might already have been submitted. (But if you are the sole user of the computer, and you have not submitted them, then they have not been.)

ls

(The first letter is a lower-case L, not an upper-case i.)

You can attempt to submit a crash report by running "ubuntu-bug filename" where filename is replaced with the name of the .crash file from which you want to submit a bug report. Rather than typing the entire name out, you might prefer to copy and paste it, or to type the beginning of it and press Tab to autocomplete it.

It's likely that, when you do that for the crash report you were unable to submit before, you will get the same error. If that happens, then instead of running "ubuntu-bug filename", run "kdesudo ubuntu-bug filename". (You can view commands you have previously run by pressing the up arrow key, and you can move the cursor to the beginning of the line with the home key like in most applications.)

Shriramana Sharma (jamadagni) said : #2

Thanks Eliah Kagan, that solved my question.

Shriramana Sharma (jamadagni) said : #3

Clarification to the above: Actually all I wanted was to remove the crash notification since I no longer have that application which crashed. So your response *was* useful in that I did sudo rm on that file inside /var/crash. Thanks.