Global menu broken after an update

Asked by William on 2012-11-27

I updated last (1am Nov. 26, 2012) and after that update the global menu is broken (i.e., I don't have global menu, instead the menu is shown on application windows). Moreover, when I right click on the desktop and select "Change Desktop Background", instead of "Appearance" settings, I get "System Settings" window (from which I can of course get to the appearance settings by clicking "Appearance").

This has happened on all three of my computers. All run Ubuntu 12.10 with unity.

Question information

English Edit question
Ubuntu appmenu-gtk Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
William (wnyessen) said : #1

Also, this might be helpful: I am using pantheon-files daily builds, instead of Nautilus, but I doubt that should be causing any problem (I tried removing pantheon-files and all of its configuration files, but that doesn't help). I've also tried removing appmenu-gtk3, appmenu-gtk, appmenu-qt and indicator-appmenu, then removing all config files, and reinstalling, but that didn't help. All the settings seem to be set properly in dconf-editor (i.e., menu type is set to "global" and hud is in use).

Where are you getting the daily build from?

William (wnyessen) said : #3

Well, for pantheon-files I was getting daily builds from ppa:elementary-os/daily, but I have uninstalled pantheon-files and removed all its config files. As far as Ubuntu, I only get regular updates (security updates and regular releases), no daily builds.

William (wnyessen) said : #4

Also, another interesting thing that happened after those updates is this: now when I right click on the desktop and select "Change Desktop Background", instead of the "Appearance" dialog, I get "System Settings" window (from which I can of course get to Appearance by clicking "Appearance").

William (wnyessen) said : #5

When I run "apt-get upgrade", I get:

The following packages have been kept back:
  gnome-control-center gnome-control-center-data

I am also using ppa:gnome3-team/gnome3

to have gnome 3.6.

N1ck 7h0m4d4k15 (nicktux) said : #6

Well , you have added PPAs that upgrade essential system packages (like the Gnome PPA) so is not weird that some time the environment can crash.
As for the kept back message , try this command

~$ sudo apt-get dist-upgrade


William (wnyessen) said : #7

Thanks guys. I just purged ppa:gnome3-team and reverted back to the previous version. That fixed all the problems.

Hanine HAMZIOUI (hanynowsky) said : #8

I have the same issue. I purged the Gnome-3-team PPA , re-updated, dist-upgraded but still have the same issue.
What do you mean by reverted to the previous version???

Hanine HAMZIOUI (hanynowsky) said : #9

OK. Problem solved by using the latest ppa-purge package.