evince/Apparmor version 2.9.2 for trust

Asked by Raymond on 2015-07-19

I having a minor problem mentioned and fixed in the launchpad bugs titled:
"Evince denied from opening"
and fixed in apparmor 2.9.2
how/where or when can I get a version for trusty 14.04?
I didn't see it in http://packages.ubuntu.com/ as a trusty version.

Ray

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu apparmor Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2015-07-20
Last query:
2015-07-20
Last reply:
2015-07-20

I suggest you report a bug

Raymond (rrogers-b) said : #2

Where? Since this is a "solved" problem I don't know where in the release hierarchy it should be listed.

Best Manfred Hampl (m-hampl) said : #3

If the problem has been solved in the 2.9.2 version for wily, you can request that this package is backported to older Ubuntu releases. see https://wiki.ubuntu.com/UbuntuBackports for the related process

Another option would be to search for a PPA with a suitable version, see the list on https://launchpad.net/ubuntu/+ppas?name_filter=apparmor
https://launchpad.net/~apparmor-upload or https://launchpad.net/~apparmor-dev might be good candidates.

Raymond (rrogers-b) said : #4

Thanks Manfred Hampl, that solved my question.

Raymond (rrogers-b) said : #5

I stilll have the evince/apparmor problem but am looking for the correct bug list.
Ray

Manfred Hampl (m-hampl) said : #6

If you are talking about #bug 1431641 then you need an upgraded version not of apparmor, but of evince (3.14.2-0ubuntu2 or higher).
Such version for trusty seems to be available in PPA https://launchpad.net/~dirk-computer42/+archive/ubuntu/c42-backport-gnome3

Raymond (rrogers-b) said : #7

m-hampl: The backport didn't work; dependency problem.
But!!
Added jdstrand's usr.bin.evince fix from bug 1421641 to evince 3.10.3 in Ubuntu 14.04 trusty release and it seems to fix it.
!!
Ray