127.0.0.1 is down after apache2 install

Asked by Habib Tamala on 2009-10-09

I have problem connecting to my localhost or 127.0.0.1 after apache install i never saw the greetig page "It works !!"
here is my /etc/hosts:
****
127.0.0.1 localhost.localdomain localhost pyro-laptop
127.0.1.1 pyro-laptop

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
****
netstat -naplt:
*****
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 127.0.0.1:3306 0.0.0.0:* LISTEN -
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN -
tcp 0 0 192.168.1.2:46118 80.157.151.43:80 TIME_WAIT -
tcp 0 0 192.168.1.2:35475 62.41.7.58:80 ESTABLISHED 4068/firefox
tcp 0 0 192.168.1.2:34370 69.63.176.198:80 ESTABLISHED 4068/firefox
tcp 0 0 192.168.1.2:35270 62.41.7.59:80 TIME_WAIT -
tcp 0 0 192.168.1.2:50348 194.221.64.58:80 TIME_WAIT -
tcp 0 0 192.168.1.2:35268 62.41.7.59:80 ESTABLISHED 4068/firefox
*****

sudo lsof -i :80:
*****
firefox 4068 pyro 53u IPv4 44242 TCP pyro-laptop.local:35475->static-ip-62-41.eurorings.net:www (ESTABLISHED)
apache2 7368 root 3u IPv4 35132 TCP *:www (LISTEN)
apache2 7373 www-data 3u IPv4 35132 TCP *:www (LISTEN)
apache2 7375 www-data 3u IPv4 35132 TCP *:www (LISTEN)
******

$sudo lsof -i @0.0.0.0:80:
COMMAND PID USER FD TYPE DEVICE SIZE NODE NAME
firefox 4068 pyro 22u IPv4 45692 TCP pyro-laptop.local:50084->channel38.01.05.sf2p.facebook.com:www (ESTABLISHED)
apache2 7368 root 3u IPv4 35132 TCP *:www (LISTEN)
apache2 7373 www-data 3u IPv4 35132 TCP *:www (LISTEN)
apache2 7375 www-data 3u IPv4 35132 TCP *:www (LISTEN)

$nmap 127.0.0.1

Starting Nmap 4.76 ( http://nmap.org ) at 2009-10-09 16:23 CET
Note: Host seems down. If it is really up, but blocking our ping probes, try -PN
Nmap done: 1 IP address (0 hosts up) scanned in 2.05 seconds

$sudo netstat -ntlp | grep :80
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 7368/apache2

on my apache2 configuration i have the lines
ServerName localhost
Listen 80

please can anyone help me please i'm stuck !!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu apache2 Edit question
Assignee:
No assignee Edit question
Solved by:
Habib Tamala
Solved:
2009-10-10
Last query:
2009-10-10
Last reply:
2009-10-09
Habib Tamala (drpyro) said : #1

It seems like i find the problem
I was using WICD i had uninstalled network-manager for gnome a couple of days ago
now when i switch back to network-manager all with these packages get installed automatically
bluez-cups* cups* cups-driver-gutenprint* foomatic-db-hpijs* gnome-nettool* hal-cups-utils* hpijs* hpijs-ppds* hplip* ifupdown* libslp1* net-tools* network-manager* network-manager-gnome* splix* ubuntu-desktop*

Every thing seems to work !!!

Any one have Idea where the problem reside in theses packages ???

wojox (wojox) said : #2

It was your network-manager and this file here /etc/network/interfaces

Habib Tamala (drpyro) said : #3

perhaps
it should be something like that:

/etc/network/interfaces:
---------------------------------------
auto lo
iface lo inet loopback
---------------------------------------

so it can allocate settings && resolve adresses automatically
i think

thanks for the reply