desktop plus webserver

Asked by sudeshmv on 2008-08-30

I want to install ubuntu desktop which should also work as a web server so that other clients can access this machine.

What are the steps to do this.

Thank and regards

sudeshmv

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu apache2 Edit question
Assignee:
No assignee Edit question
Last query:
2008-08-30
Last reply:
2008-08-31
kabads (adamc) said : #1

What kind of services do you want to run as a server and as a desktop? How critical are the services you are planning to run to your users? How many users are you expecting? What are you hardware specs?

It all depends on the specification of your hardware. You can install any packages you like (i.e. webserver and Openoffice.org) but you are purely limited on what your hardware is capable of and how tolerant your users are of a slower service.

sudeshmv (sudeshmv) said : #2

Hardware:

     Intel Core 2 Duo processor
     1GB RAM

Software:

     LAMP.

     So, web and mysql server have to be accessed from clients. There will be one or two clients only excluding the server.

Thanks and regards

sudeshmv

Please install Apache

First i suggest you to be sure your system is fully upgraded, to check:
open a Terminal from the menu Applications->Accessories->Terminal and type:

sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get clean all
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get clean all
sudo apt-get autoremove

give your user password when requested, you don't see nothing when you type it, then press enter.

Then to install apache

sudo apt-get update
sudo apt-get install apache2

Then you must edit the /etc/apache2/apache2.conf type:

sudo gedit /etc/apache2/apache2.conf
and
sudo gedit /etc/apache2/sites-enabled/000-default

after editting the conf files you must restart apache typing:

sudo /etc/init.d/apache2 stop
sudo /etc/init.d/apache2 start
or
sudo /etc/init.d/apache2 restart

Please refer to http://httpd.apache.org/ to faq and related doc.

Hope this helps

Sharar Ravitz (jewfro-macabbi) said : #4

You can install Ubuntu server addition - then install your desktop and X server - or you can install LAMP on top of you desktop install. Either way it's just a matter of apt-get install.

All the settings for apache are in /etc/apache2/

Here's an example for setting it up (goes in sites-enabled)

NameVirtualHost ip.goes.here
<VirtualHost ip.goes.here>
ServerName domain.name.here
ServerAdmin your@email

DocumentRoot /path/to/files

<Directory /path/to/filesx>
Options Indexes FollowSymLinks MultiViews +Includes
AllowOverride None

</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined
ServerSignature On

</VirtualHost>

sudeshmv (sudeshmv) said : #5

Thank you for your advice.

I will try this and inform the status

Thanks and regards

sudeshmv

Hemanth (hemanth-hm) said : #6

U can go for LAMP

P.S : You have to be the root while executing the commands mentioned below

1. apt-get update
2. sudo apt-get install apache2 php5 mysql-server-5.0 phpmyadmin
3. Wait till its done
4. sudo gedit /etc/apache2/apache2.conf
5. The step 4 will open a text file for you
6. Paste the below to the end of the file ,save and exit

# Enable PHPMyAdmin
Include /etc/phpmyadmin/apache.conf

7. sudo /etc/init.d/apache2 restart

Check if you where right till now :
 http://127.0.0.1 ===>webpages
 http://127.0.0.1/phpmyadmin ====>database administration

Can you help with this problem?

Provide an answer of your own, or ask sudeshmv for more information if necessary.

To post a message you must log in.