Apache 2.4.17 in trusty-updates?

Asked by Max Wenzin on 2015-10-23

I'd like to install Apache 2.4.17 on Ubunty Trusty.

I can see that it is (not yet) available in trusty-updates. Nor is it available in any other Ubuntu repository, as can be seen here: http://packages.ubuntu.com/search?keywords=apache2&searchon=names&suite=all&section=all

Will it be? When?

I am looking forward to using http/2.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu apache2 Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2015-10-23
Last query:
2015-10-23
Last reply:
2015-10-23
Best Manfred Hampl (m-hampl) said : #1

There seems to be a misunderstanding on Ubuntu's release policy.
In normal cases there is no version update on packages in older Ubuntu releases, just bug fixes.

You cannot expect that apache 2.4.17 will ever be made available in the standard repositories for Ubuntu trusty.
It will probably be part of Ubuntu 16.04 or 16.10.

Or maybe somebody tries packaging this version in a PPA for older Ubuntu releases. There are plenty of PPAs with different versions of apache, see https://launchpad.net/ubuntu/+ppas?name_filter=apache2

Max Wenzin (max-wenzin) said : #2

Thanks!
I was not aware of that release policy.

Max Wenzin (max-wenzin) said : #3

Thanks Manfred Hampl, that solved my question.