Fresh 14.04, Apache not boradcasting to my public IP

Asked by David on 2015-06-06

I am a web developer and I want to give severing a try. I'm a beginner-intermediate when it comes to linux.

I set up a (L)AMP stack on windows through a software called "WAMP". After forwarding my local IP, and a few clicks later, I had a website broadcasting via my public IP.

Now I want to do it the fun way, so bought myself an old $25 C2Duo computer. Installed a fresh copy of 14.04 ubuntu server, selecting OpenSSH in the installation and installing apache2 via command line after I had logged in - "sudo apt-get install apache2".

That's the ONLY thing I have done to this computer. I have forwarded the port on the router.

I can browse the start up page from localhost, and by visiting the server's local IP from another computer, but I can not browse the site via my public IP address.

Are there more settings I need to change? I had the exact same problem on my test ubuntu server.
Thanks

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu apache2 Edit question
Assignee:
No assignee Edit question
Last query:
2015-06-06
Last reply:
2015-06-06
David (alshdavid) said : #1

http://i.imgur.com/RxgNHyq.png
^
ifconfig vs my port forward setting.
Repeating the exact same thing in windows works no problem

The server is accesible on the local network from other computers on the network, just not from internet connections

Did you setup port forwarding on your router to send the traffic on to the server system?

Also, you can use no-ip (free) or buy a domain and point the A record to your WAN IP and you can then use the name to access the server just like you do with the rest of the website you use.

David (alshdavid) said : #4

Yeah, I intend to buy a domain after I get the whole thing set up.

The router is set up to forward all traffic from port 80 to the correct IP address.
The response I get from the browser when trying to connect to my public IP is "connection refused"

Does Ubuntu have some firewall settings i need to configure before I can put my website on the internet

Yes but the default is to allow all traffic. Have you tried rebooting the router

You may need to tell apache to accept requests from outside the LAN. I believe there is a confirmation in the service for this.

David (alshdavid) said : #6

Thanks for the response. Just tried rebooting the router, no different.

Any idea how I could do that?

Can you help with this problem?

Provide an answer of your own, or ask David for more information if necessary.

To post a message you must log in.