Precise (12.04) apache2-prefork-dev dependency problem on Launchpad

Asked by OpenCPU on 2013-10-15

I am trying to make a deb package [1] for an apache2 module which should build on Ubuntu 12.04 and up. The package had a build dependency on: apache2-dev (>= 2.4) | apache2-prefork-dev (>= 2.0.52-1). This is on order to make it work with both the 2.2 and 2.4 series of Apache2.

Things work great when building locally, and when trying to build on Launchpad things work great for Quantal, Raring and Saucy as well. However in Launchpad I get the following error:

apache2-dev(inst =*=PROVIDED=*= ! >= wanted 2.4)|apache2-prefork-dev(missing)

See the full build log [2]. Why is it saying apache2-prefork-dev is missing? It should be there?

[1] https://github.com/jeroenooms/rapache/tree/controlfile/debian
[2] https://launchpad.net/~opencpu/+archive/opencpu-dev/+build/5106065

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu apache2 Edit question
Assignee:
No assignee Edit question
Last query:
2013-10-15
Last reply:
2013-10-16
OpenCPU (opencpu) said : #1

I realize what the problem is now. Precise also has a package called apache2-dev, but this is something different from the identically named package that was introduced in Saucy: http://packages.ubuntu.com/search?keywords=apache2-dev.

This is where Launchpad goes wrong. It is installing apache2-dev instead of apache2-prefork-dev, but doesn't seem to be smart enough to see that the version of apache2-dev in Precise does not meet the requirements. It then fails the build (instead of trying the proper alternative of apache2-prefork-dev)

Manfred Hampl (m-hampl) said : #2

Maybe you can reverse the dependencies
instead of
apache2-dev (>= 2.4) | apache2-prefork-dev (>= 2.0.52-1)
try
apache2-prefork-dev (>= 2.0.52-1) | apache2-dev (>= 2.4)
(just a guess)

Can you help with this problem?

Provide an answer of your own, or ask OpenCPU for more information if necessary.

To post a message you must log in.