Where's the source repo for precise-updates/precise-security?

Asked by Grzegorz Nosek on 2013-04-29

I need to apply an in-house patch to apache2 (nothing secret but not really update material for an LTS, so I'm not even trying). For that I want to set up an autobuilder tracking new releases, patching and rebuilding them. So, my question is: where can I find the repo used to build updated packages? I mean e.g. https://launchpad.net/ubuntu/precise/+source/apache2/2.2.22-1ubuntu1.3 as of now; the lp:ubuntu/precise/apache2 branch only seems to contain the release version, without any updates.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu apache2 Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2013-04-30
Last query:
2013-04-30
Last reply:
2013-04-30
Manfred Hampl (m-hampl) said : #1

https://code.launchpad.net/ubuntu/precise/+source/apache2 indicates that it should be lp:ubuntu/precise-proposed/apache2

You have to understand the release process:
SRU updates usually are provided in the <name>-proposed repository, and if testing shows success, the packages are copied to <name>-updates (and in case of security fixes to <name>-security)
see also https://wiki.ubuntu.com/StableReleaseUpdates

Sadly, lp:ubuntu/precise-proposed/apache2 contains some outdated version (2.2.22-1ubuntu1.1 as of apparently latest rev77).

I think I do understand the process, I just can't find the repo out of which 2.2.22-1ubuntu1.3 was built.

Best Manfred Hampl (m-hampl) said : #3

According to https://launchpad.net/ubuntu/precise/+source/apache2/2.2.22-1ubuntu1.3

"2.2.22-1ubuntu1.3 PUBLISHED: Precise pocket Security in component main and section web
Published on 2013-03-18 Copied from ubuntu precise in Private PPA for Ubuntu Security Team by Marc Deslauriers"

So apparently this version was created in a PPA and then manually copied over to the official repositories.
It seems to me that the information for automatic version tracking is not available.

Thanks Manfred Hampl, that solved my question.