How to update apache to 2.2.23 on ubuntu 12.04 LTS

Asked by Salil on 2012-11-04

Hi,

We had done a PCI scan on one of our servers running Ubuntu 12.04 LTS with apache 2.2.22.The scan reported a vulnerability in apache 2.2.22 (Apache HTTP Server Zero-Length Directory Name in LD_LIBRARY_PATH Vulnerability).The report states to updgrade the version to the latest stable release of either 2.2.23 or 2.2.24.How do I upgrade to the 2.2.23 to fix the vulnerability or is there a patch available that can fix this and if yes can you let me know how that can be patched.

Regards,
Salil Phatak
India

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu apache2 Edit question
Assignee:
No assignee Edit question
Last query:
2012-11-04
Last reply:
2012-11-04

https://launchpad.net/~ptn107/+archive/apache

PPA for 2.4.2 there. Is that ok? You can search the other PPAs with this link:

https://launchpad.net/ubuntu/+ppas?name_filter=apache2

Can you help with this problem?

Provide an answer of your own, or ask Salil for more information if necessary.

To post a message you must log in.