can not connect to internet 8.10

Asked by bjorn on 2008-11-08

Dear Ubuntu,
When upgrading to 8.10, I have problems connecting to the Internet.
I have aMSN configured to start at start-up. I did not have any problems using 8.04 but after upgrade to 8.10 I do not connect.
If I remove aMSN from starting at start-up I have no problem.
Starting aMSN after connected, no problem.

Bjorn

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu amsn Edit question
Assignee:
No assignee Edit question
Solved by:
bjorn
Solved:
2008-11-09
Last query:
2008-11-09
Last reply:
2008-11-08
Charles Profitt (cprofitt) said : #1

I do not use aMSN, so I am just guessing... but it sounds as though aMSN is trying to startup before network manager and thus causing a hang. Perhaps change the order of aMSN starting up?

bjorn (bjornlofgren) said : #2

Thanks,
If you mean to start up aMSN after boot-up and manually start aMSN.
That is what I do for now until I guess we get a fix.
Bjorn

lör 2008-11-08 klockan 18:47 +0000 skrev PrivateVoid:
> Your question #50615 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/50615
>
> Status: Open => Needs information
>
> PrivateVoid requested for more information:
> I do not use aMSN, so I am just guessing... but it sounds as though aMSN
> is trying to startup before network manager and thus causing a hang.
> Perhaps change the order of aMSN starting up?
>

AFarris01 (afarris01) said : #3

Hmm... seems that there's something with aMSN thats causing the issue?

try starting aMSN with a custom startup script, like so:

1. Open up you're home folder
2. Right click in any empty space, select "Create Document > Empty Document"
3. Lets name the file something simple... like: .start_aMSN
(note: the name is not really important, so long as its something you'll remember. the "." at the start of the name will make it an automatically hidden file, for the sake of neat-ness in your home folder.)
4. as soon as you click off the name dialogue, it will most likely jump to the bottom of you're file list, this is ok. just go to it, and double-click it to open it in a text editor.
5. copy/paste this into the file, and click "Save":

#!/bin/bash
sleep 20 &&
amsn &

(This basically says wait 20 seconds (sleep 20 &&), then start amsn in the background (amsn &))

6. After you save, close the text editor, then right click on the ".start_aMSN" file, and click "properties"
7. In the properties dialog box, click the permissions tab
8. underneath the listings for "Owner" and "Group" you should see a bunch of checkboxes, labeled 'read', 'write', and 'execute.' Check all the boxes next to the 'execute' options, and close the properties box.
9. Now, go to "System > Preferences > Sessions" and another dialogue box should come up
10. Click the "Add" button, and in the new dialog box that opens, you should see "Name", "Command", and "Comment." Under 'Name' and 'comment', you can put whatever you want, though i'd suggest something somewhat descriptive, such as "custom aMSN start script", or such the like. anyway...
11. in the "Command" box, type in "/home/<your username>/.start_aMSN" without the quotes, then "OK."

Now, restart the computer and that should be it!

all this does is give aMSN a delayed start, which should give the computer enough time to establish a net connection. if it still doesn't work, i'd suggest changing the "20" in the script to a larger number, and trying again.

Hope that helps!
Andrew

Charles Profitt (cprofitt) said : #4

Guy:

Sounds like it should work from what he described...

bjorn (bjornlofgren) said : #5

I will try later and I take you word for it.

Bjorn