amsn opening hotmail

Asked by zzzxxx on 2008-02-23

hello, on my secondary computer using amsn, it doesnt seem to want to pull up hotmail, when i click on open inbox, it says that it cant open "mozilla $url", so i changed it to "firefox $url", now it opens firefox but it gives me some cgi-bin website (http://www.cgi-bin.com/)

how can i fix this?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu amsn Edit question
Assignee:
No assignee Edit question
Solved by:
Helton Dória
Solved:
2008-03-26
Last query:
2008-03-26
Last reply:
2008-03-25
Helton Dória (helton-doria) said : #1

Hi Brian,

Which version of ubuntu and amsn are you using? Your machine is behind a proxy or something like that?

Cheers,

Helton

ubuntu= 7.10
amsn= 0.97

my computer is behind a router that I have uniquely setup to be near transperent, its never stopped a valid connection from my computer before.

Helton Dória (helton-doria) said : #3

Hi Brian,

Which other settings did you change (other than preferred browser)? Did you changed the "Mailer" field at "preferences -> others" tab? Did you change anything at "preferences -> connection" tab?

Cheers,

Helton

I didn't change any other settings...
and this was like that when I installed it onto that computer, so I know I didn't make the problem...:P

Helton Dória (helton-doria) said : #5

Brian,

I tried to reproduce the behavior of your system in 3 other systems (two machines with Ubuntu 7.10 and one with Ubuntu 8.04) and I was unable to reproduce the error. One of the system with Ubuntu 7.10 was behind a router and the other two were behind a proxy. When you try to access the hotmail site directly, you stop on the same cgi-bin?

Helton

No, when I access it directly (http://www.hotmail.com/) it lets me login as normal

this only happens when I click open inbox, or 3 new messages, ect...

----------------------------------------------------------------------------------------------
on a further note, where can I get my upgrade to the beta of ubuntu 8.04?

Thank you,
Brian Michalski

I did some testing just now, this problem only affects one msn email account, and not another one that i just created

the problem must be in the preferences of that account (my primary one)

Helton Dória (helton-doria) said : #8

Hi Brian,

I agree with you. You should compare the two accounts seeking for differences in configuration that lead to the cause of the problem.

Helton

psssst... where the config file? :P

I know its somewhere in /home/XYZ/.amsn
but what file(s) is it?

Helton Dória (helton-doria) said : #10

Brian,

It appears to be the config.xml file, but I found two of them. The one that appears to match my config is that that lies directly in the .amsn directory, but the other is in a subdirectory especific for my msn account. So I think you will need to check on both just to make sure.

I hope it helps

Helton

I reviewed both but found nothing in there that might cause a problem except the actual web browser start-up command which works fine
(except sending me to the wrong site!)

so I tried deleting the config file, and then restarting amsn and logging on (creating a new, fresh config)

so I did more experimenting...
i decided to install konqueror and use that as the browser variable ("konqueror $url")

this caused it to go to:
http://cgi-bin/HoTMaiL
of course it didnt load saying no hostname specified

normally if you type what ever into firefox, then it searches for the closest thing to it, (http://www.cgi-bin.com)

so why does aMsn want to send me there?... :S

could this be a bug?

Helton Dória (helton-doria) said : #13

If your hotmail account is in the form <email address hidden>, yes, this problem may be a bug. I found a discussion in the AMSN forum that describe a bug exactly like yours that affects MSN live accounts. These bug was corrected in the last releases. Please, check in the file /usr/share/amsn/hotmail.tcl if this string appears in the frist line "::Version::setSubversionId {$Id: hotmail.tcl 9104 2007-11-30 22:07:25Z kakaroto $}".

If the file does not have that line, you should update your AMSN to a new version. The backported version of AMSN (from Hardy to Gutsy) has the correction applied to it.

Helton Dória (helton-doria) said : #14

By the way, the address for the discussion at the AMSN forum is http://www.amsn-project.net/forums/viewtopic.php?t=4317&postdays=0&postorder=asc&start=0

[]'s,

Helton

ok, stupid question, how? :P

(bug filled as well)

Best Helton Dória (helton-doria) said : #17

No problem :)

1 - uninstall your aMSN;
2 - Click on System -> Administrator -> Software Sources;
3 - In the opened window, go Updates Tab and mark the option unsupported updates (gutsy-backports);
4 - Close the window;
5 - Open a terminal window and type:
sudo apt-get update
6 - Type sudo apt-get install amsn.

Thanks Helton Dória, that solved my question.

Thank You So Much!!! :)