Playing TTA files

Asked by jokerhero

Amarok is unable to play .tta files after installing all the known codecs. It is supposedly supported under ffmpeg and ffmeg -formats shows tta Decoder support. MP3's play fine so do mp4, wma, and most everything I have thrown at it, but TTA just will not play. Any suggestions?

Question information

English Edit question
Ubuntu amarok Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Doug McMahon (mc3man) said :

If you wish to do a comparison then go here and dl the luckynight.tta sample

it plays fine here in amarok 1.4 (karmic), provided by libxine1-ffmpeg

What amarok release are you using?

Also look in your home folder for .xine/catalog.cache

If it's there, then try deleting the file, then restart amarok and try again

If it's not there (very likely with amarok 2.X) then install the xine-ui player and then try amarok on a .tta

Revision history for this message
jokerhero (jokerhero9) said :

Thank you for the reply,

The sample you linked me to works fine in Amarok, but does not in mplayer not that that matters to me at all as Amarok is so much better, however the tta files I have that play fine in Windows media player are not working with amarok.

I am currently using Version 2.2.0 on KDE 4.3.2 in Ubuntu 9.10 with the latest updates and yes libxine1-ffmpeg is installed.
Also when trying to convert it from tta to mps with ffmpeg, I get an error "could not find codec parameters". Searching google, I can not seem to get a straight forward answer. I thought maybe the files were corrupt, hence why I tried in windows. These were encoded with ttaenc.

I'd be happy to send a copy of a file if I could, but I am in Iraq with a very slow internet connection, but am willing to try anything.

Revision history for this message
Doug McMahon (mc3man) said :

Well if you can play that sample then there still may be something about those .tta's you have
(plus mplayer and ffmpeg should handle the sample one at least, though the default repo mplayer and ffmpeg are less than ideal

Why don't you try this
If you don't have ttaenc on your install then get the latest version for linux here

After extracting then put ttaenc in a dir in your path - I use a ~/bin I created but /usr/local/bin will do fine.

Then decode to .wav (and do whatever you wish with the .wav) or then re-encode back to .tta and see if it now plays any better
In the unpacked folder you'll see a readme for the commands - very easy, to eliminate needing paths in commands do this in a terminal

mkdir test && cd test

Then move one of your problem files into the test folder (in home

to decode
ttaenc whatever.tta

to then encode back
ttaenc -e whatever.wav -o whatever-1.tta

(if you have continuing issues maybe come over here, register and post in the Multimedia & Video forum, you should be squared away very quickly *it's a bit of a pita doing stuff here - no code or quote boxes ect.

Revision history for this message
Doug McMahon (mc3man) said :

sorry the to decode line should be
ttaenc -d whatever.tta

Also hate not being able to edit a post
Obviously replace whatever with the actual file name, if there are spaces in the name than use ' around it
ttaenc -d 'spaces in name.tta'

Revision history for this message
jokerhero (jokerhero9) said :

Ok, after installing ttaenc and trying to decode the files, I gave up on it and went to windows and converted them then brought them back to my collection. The files must have gotten corrupted somwhere along the lines, but Amarok is working as it should. Thank you for your help, as Amarok does play the tta files that I made with ttaenc and the tta file from the sample noted above.