Amarok 100% unusuable in Karmic

Asked by Markus72 on 2009-10-29

There is a really bad bug (see https://bugs.kde.org/show_bug.cgi?id=211775) in amarok 2.2.0 which is already fixed in 2.2.1.
Currently Amarok is completely unusuable for me and other (see related bugs).

Is there any chance to get an update in Karmic which includes the bug fix?

Really - it's totally broken. This is really really bad. Amarok sure is one killer-app, which should work in Karmic, right? ;-)

Please help - I love 9.10, but without my music I'm sad.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu amarok Edit question
Assignee:
No assignee Edit question
Solved by:
Markus72
Solved:
2009-10-31
Last query:
2009-10-31
Last reply:
2009-10-30
Joe (jgsylvesterjr) said : #1

In Karmic 9.10, you can go to Applications->Ubuntu Software Center. Open Ubunto Software Center and search for "amarok". The version to be downloaded says it is version 2.2.2.0 . I am not an expert, but I would remove your existing Amarok version via System->cSynaptic Program Manager and then install the latest version by using Ubuntu Software Center. There may be other expert advice.

Markus72 (mark-i) said : #2

Hi Joe, it says "2:2.2.0" (the first is a colon) - that version is in fact 2.2.0...

Joe (jgsylvesterjr) said : #3

Markus,
I guess I misread/misunderstood your problem. I went to the Amarok web site, but their latest version to download is 2.2.0. I would assume that when they release a new version, Ubuntu/Kubuntu would pick it up automatically since it appears in the respository. The Amarok web page refers to this link https://help.ubuntu.com/community/Repositories/Kubuntu to step by step instructions on how to add Amarok to the repository. Sorry I can't be of more help. I have only used Amarok a few times under Ubuntu, and I have not experienced any troubles. - at least on my system Amarok is usable, unlike yours. Maybe others will have suggestions. If Amarok is the default music player in Kubuntu, then you should pick up updates as they are released.
Joe

Markus72 (mark-i) said : #4

Joe,
I just found out that Amarok 2.2.1 is to be released in two weeks.
Hope this goes to the repositories right away...
Markus

I had the same problem, but I resolved installing the kubuntu-restricted-extras

I saw that this package contains many "usefull things" and everything works fine now.

the apt-get command
sudo apt-get install kubuntu-restricted-extras

tks

Markus72 (mark-i) said : #6

Hi Eduardo,

I've got that package installed from the beginning - so no solution for me...

Markus

Joe (jgsylvesterjr) said : #7

Markus,
When I initially installed Amarok in Ubuntu 9.10, no sound would play, even though it was evident a track was playing. From Question #67045 -

Installing the following packages worked for me:

ubuntu-restricted-extras
libxine1-ffmpeg
phonon-backend-xine
phonon-backend-gstreamer

I had to re-boot for the sound to start.
You should at least verify that those packages are installed.
Joe