Amarok not playing MP3. RythmBox does!

Asked by thaim

I have read some of the threads regarding Amarok not playing MP3. Though they were always
suggesting to install the codecs. As far as I can see, I have installed all codecs that should be
needed. I can play any type of DIVX and movies. I can Play MP3s with RythmBox and some other.
Only Amarok does not work since all 2.0-2.1 Versions. Why?
When I drop an mp3 in the playlist, nothing happens except that the song now is placed there. When I
now double click, I can see a flickering, but nothing more happens. Hafter hitting play for a while, I get
a message, that too many errors have been in the playlist. What is going wrong. Why does the new Amarok
not play any of my mp3s anymore ? :(

I am currentlly running Version 2.1 on Ubuntu 9.04.

Hope someone can help me here.


Question information

English Edit question
Ubuntu amarok Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
shalabh (shalabh7777) said :

Just try reinstalling Amarok.
May be some conflict issues which can be resolved on reinstalling.

Revision history for this message
thaim (public-thesofa) said :

No, this is unfortunatly not the point. I reinstalled Amarok several times,
and I have this Issue on three seperate mashines :-/

Revision history for this message
Matthew Lange (matthewlange) said :

Thanks for your question!

I assume you're using Kubuntu.

Try installing the ffmpeg driver:
  sudo apt-get install libxine1-ffmpeg

Optionally, you could try installing the Kubuntu restricted (aka non-GPL) extras. It comes with all kinds of things like Macromedia Flash, Sun's Java, and all kinds of drivers for things like MP3, etc.
  sudo apt-get install kubuntu-restricted-extras

Hope that helps!

Revision history for this message
Matthew Lange (matthewlange) said :
Revision history for this message
Dave Basener (dbasener) said :

Matthew - thanks for the answer re: installing libxine1-ffmpeg. I had exactly the same problem (amarok just raced through each file at about 100X with no sound whatsoever) and had tried a number of other solutions. I did the apt-get line and then started amarok, and it worked.

Revision history for this message
cokecan42 (cokecan42) said :

My Amarok was doing the same thing I tried it and it fixed it !!!!!

                                                        Thanks Cokecan42

PS You are a Brain

Revision history for this message
David Salinas Cortés (david-mty75) said :

The same thing happened to me. And that fixed it. Thanks!!


Can you help with this problem?

Provide an answer of your own, or ask thaim for more information if necessary.

To post a message you must log in.