Audio output unavailable; the device is busy.

Asked by Penguincsc on 2007-06-15

HI,

I am running 1.4.5-0ubuntu7 on Ubuntu 7.04.

Sometimes, after playing OGG file(s), when the next song on the playlist is supposed to start, I get the error in the summary line, and it just cycles through the whole playlist and stops.

I wasn't able to find a reason (like playing a specific file).

Any ideas?

Thanks!

Amichai.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu amarok Edit question
Assignee:
No assignee Edit question
Last query:
2007-06-15
Last reply:
2008-07-27
Justin Payne (neolithium82) said : #1

Have you installed all the proper codecs as listed here?
http://ubuntuguide.org/wiki/Ubuntu:Feisty#How_to_install_Multimedia_Codecs

Occasionally when one is missing it can cause problems. As well, have you tried running your media player from a terminal (ie, use the command: xmmms ) in terminal and run through the process that gets you the error. There may be some information that comes through in the window that can be copied and pasted to help narrow down the problem.

Regards,
Justin

Hanusz leszek (leszek-skynet) said : #2

Hello,

It is probable that another program used the soundcard and blocked access to it.
to know which program hold the soundcard, please follow these steps when your problem happen:

Open the system monitor: System->Administration->System Monitor
Open in the menu: Monitor->Search for open files
In the text box, enter: /dev/snd/* then click on Find

Please report the processes found here.

Christoph Langner (chrissss) said : #3

Do you use e.g. VMware or Teamspeak? Those applications still use the outdated OSS sound system. A application using oss blocks the sound card so that no other application can play sound.

Mehul J. Rajput (mehulrajput) said : #4

I too get this error frequently. I am having ogg files in the playlist.

I search for /dev/snd/*. It does not display anything.

If I logoff and relogin it fixes the issue.

emreakbas (emreakbas) said : #5

I have the same situation in recent days. I ran xmms from console and get this error:

ALSA lib pcm.c:2106:(snd_pcm_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so

sebastian-s (sebastian-s) said : #6

I had the same symptome.

I closed amarok and looked at /dev/snd/* as decribed above.
besides mixer_applet2 and firefox was nothing running.

I tried totem and VLC both gave me no sound at all. Next I closed firefox, sound again on all programs.

The thing is, I am sure I had firefox AND Amarok running together.
But I neither do I know what "firefox action" could cause this, nor do I know how I could get to the bottom of this. But I guess it is some media content, flash, some sort of adds, a firefox addon...

PS: I have a "Conexant High Definition Audio" in my machine which needed some persuation to work.

Joe Soap (duvenhage) said : #7

Hi,

A simple workaround (not a solution ...) for the above is to end firefox. Your sound should be back and if you retsart firefox, the sound won't (shouldn't ...) go away.

HTH.

Oli (oli) said : #8

Same issue here. Firefox/Flash hog the device and it's seriously annoying. I've tried altering the firefoxrc to use aoss/alsa but that doesn't seem to change a thing.

Harald Sitter (apachelogger) said : #9

This shouldn't happen with latest flash-plugin. Please try upgrading to Gutsy Gibbon or just upgrade your flash-plugin.

Oli (oli) said : #10

Harald: I'm on Gutsy with Flash Player 9.0 r48

Harald Sitter (apachelogger) said : #11

Hm, ok.
Try setting xine's audio output module to ALSA (in Amarok's engine configuration). This should ensure that Amarok always uses ALSA, hence it's software mixing features.

Sabeeh (sabeeh-yunus-gmail) said : #12

I have the same prob... is there any configuration in Amarok to select a default device, in my case, C-Media PCI CMI8738-MC6 audio card?
i fiddled with the "ARTs" app but it also didnt seem to work..
PLeeez someone!

Hy, a had the same problem when I update my UBUNTU 7.10 to 8.04. Harald Sitter solve my problem: read to him. "Try setting xine's audio output module to ALSA (in Amarok's engine configuration). This should ensure that Amarok always uses ALSA, hence it's software mixing features"

apmacniven (apmacniven) said : #14

Harald Sitter's solution does work.
Thanks man =]

Can you help with this problem?

Provide an answer of your own, or ask Penguincsc for more information if necessary.

To post a message you must log in.