Suspend computer even when amarok is playing songs

Asked by TL on 2009-07-28

How do I tell Amarok2/KDE4 to suspend to ram even if it is playing songs?
ie I'd like to just be able to walk away from the PC without having to first stop amarok and after so many minutes the computer should suspend to ram according my settings
I think currently amarok disables the suspend feature if it's playing

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu amarok Edit question
Assignee:
No assignee Edit question
Last query:
2009-07-28
Last reply:
2009-07-28
Vihar (vmankov) said : #1

I'm under Gnome.
The KDE should be of the same interface logics.
So under Gnome the default player is Totem Movie Player. Under KDE this is Amarok, is it? If so I suppose you try in Amarok as I find it an Totem:
Edit-->Preferences-->Display and tick there "Allow the screensaver to avtivate even when an audio-only is playing". Or find the similar way there in Amarok.
Hope it helps.

TL (latev) said : #2

Alas things don't seem to be that easy in Amarok - the settings and the configuration options in general in Amarok are pretty basic and there's little to be configured there. I suspect most of the settings Amarok derives from external sources, the problem is finding which setting comes from where.
For example under the General tab in the settings dialog there's just 3 checkboxes - that's it! Under playback - just two!
Go figure...

PS> I don't think I have problems with the screensaver not activating - it's the suspend to RAM not happening that I'm trying to resolve

Vihar (vmankov) said : #3

As I had a problem with my 9.04 suspending instead of "sleep" I searched in Launchpad for the frase "amarok suspend". It seems "suspend" is buggy:
https://launchpad.net/+search?field.text=amarok+suspend&field.actions.search=Search

So take care.

Can you help with this problem?

Provide an answer of your own, or ask TL for more information if necessary.

To post a message you must log in.