How do I get Amarok 1.04 for Ubuntu 9.04

Asked by dbjock

I just upgraded to Ubuntu 9 (Jaunty), and it is marvelous though Amarok has gone in a completely opposite direction that what I wanted. Unless I am really missing something, I sure missed being able to create a playlist by building queries in their simple interface. I place in the comments field of my music keywords sort of like 'tags'. Having this in the file allows me to create playlists from (dare say winamp) and amarok using queries. The query interface is simple yet powerful so I can build a query where comments contains the keywords, or even not contain. This extends further using genre, score, rating and on and on. When my collection grew the playlists would be dynamically updated since it was just the query.

So with that said, how do I install the prior version of Amarok (1.04.10 I think) that was available on Ubuntu 8.10) on Jaunty?

Question information

English Edit question
Ubuntu amarok Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Montel Edwards (montel) said :

I have looked all over and can not find it.
I will post it up though if I do.

Revision history for this message
dbjock (junkyardjojo) said :

I found a repository with 1.4.10 version and installed. Now it is working..
Amarok 1.4 in Jaunty (Ubuntu 9.04)

Very good write up, though it is best if you have a backup copy of the .kde/share/apps/amarok directory before you upgraded Ubuntu. If so then you are completely in luck in restoring 99% of amarok 1.4

After I followed the directions at I removed the .kde/share/apps/amarok and restored from a backup. Started up amarok (which btw it's collection is a MySql server) worked perfectly.

I did come across an error about not having a public key and therefore could not validate the package. I followed "Add the key for the PPA" with the following output:
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg ls -l--keyring /etc/apt/trusted.gpg .recv-keys .keyserver 0×1d7e9dd033e89ba781e32a24b9f1c432ae74ae63
usage: gpg [options] [filename]

Well.. Amarok is working great.

Revision history for this message
dirk (dirkmeissner72) said :

Yes,amarok working great.I use this : for Ubuntu Karmic !