Amarok doesn't play

Asked by Tony Jose on 2010-05-30

first of all, i'm totally new with the Ubuntu. i have installed Amarok
soon after the ubuntu installed and ma problem is, Amarok ans Rhythom
box don't play any kinda audio track [indeed, i only have these two] but
i get it open and load files..... can some one help me please....? ma
email id <email address hidden>

VLC player plays everything at the same time. :((
My installed Ubuntu version is 10.04.
System conf : Core 2 duo 2.93, 2GB ram, mother board is Intel DG31PR, 1TB HD...
Apart from that, i have checked all ma sound settings and its perfect from ma system side.

as a result of ma question Mr.Dany has asked me to install Restricted extras and i have installed it. and still ma Amarok doesn't play and i got a message which says it is crashed nd bug. still what do i do now?

and the happy news is, Rhythm box starts playing now....

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu amarok Edit question
Assignee:
No assignee Edit question
Solved by:
Tony Jose
Solved:
2010-05-30
Last query:
2010-05-30
Last reply:
2010-05-30

Amarok and KDE use a slightly different sound backend to gnome which uses gstreamer, this is why there is kubuntu-restricted-extras as well as ubuntu-restricted-extras.

I suggest you install the kubuntu-restricted-extras, it may make it work ok.

Tony Jose (haitony8) said : #2

"Problem is solved" finally i could figure out the prob. i was getting a message "The audio play back device HDA Intel doesn't work" so i installed all Restricted extras and GNOME ALSA mixer and Amarok stteings into default and the following command. Now i got it right and sing along with ma fvryt tracks...... Amarok simply rocks.... contact me for ny help regarding this <email address hidden>. Following is the command i used.
 sudo apt-get install libxine1-ffmpeg libxine1-all-plugins

I have been a Ubuntu user since 7.04 and been using Amarok the whole time. I had tried several times to upgrade along with Amarok, past 1.4.10, but my audio would NEVER play in the newer version. In fact, XINE always crapped out on me & I had to start using Yauap Engine.

Once my cover art sync broke and also support for the newest iPod Nano was broken in 1.4.10, I caved. My audio STILL wouldn't play in 2.2.0, it would just start at one second and then jump to the very end of the song & then jump to various songs in a playlist, doing the same things. DAMMIT!

I browsed these previous questions & found a suggestion to try this:

sudo apt-get install libxine1-ffmpeg libxine1-all-plugins

THAT WORKED PERFECTLY. Has that been the issue all along? Why wouldn't Amarok grab these by default?

No matter, IT WORKED.

-Misteralexander
(Alex)

Probably because its a KDE app which uses a different sound backed, you could log a bug to get it resolved and make it more automagick

Hopefully this thread will help others though :) so great share

Soo Small (small-soo) said : #5

@misteralexander, thanks for that information. I now have a functioning Amarok. :)