I am installing PHP5 on UBUNTU. Terminal gives error of am-utils

Asked by Norm Tredo on 2018-01-12

The following are terminal entries I made to begin, and stopped due to errors with am-utils. I think that I should be able to install the PHP5 this way, but I am worried about am-utils and why I'm getting the error. I see two problems to address: cannot find master map & yp cat not found. How do I fix this? Thanks, Norm Tredo <email address hidden>

norm@Android:~$ sudo apt-get install php5 libapache2-mod-php5 php5-mcrypt
[sudo] password for norm:
Reading package lists... Done
Building dependency tree
Reading state information... Done
php5-mcrypt is already the newest version.
libapache2-mod-php5 is already the newest version.
php5 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
Setting up am-utils (6.2+rc20110530-3.2ubuntu1) ...
/etc/init.d/am-utils: 1: /etc/init.d/am-utils: ypcat: not found
/etc/init.d/am-utils: cannot find master map
invoke-rc.d: initscript am-utils, action "start" failed.
dpkg: error processing package am-utils (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 am-utils
E: Sub-process /usr/bin/dpkg returned an error code (1)
norm@Android:~$ sudo nano /etc/apache2/mods-enabled/dir.conf
norm@Android:~$ apt-cache search php5-
php5-cgi - server-side, HTML-embedded scripting language (CGI binary)
php5-cli - command-line interpreter for the php5 scripting language
php5-common - Common files for packages built from the php5 source
php5-curl - CURL module for php5
php5-dbg - Debug symbols for PHP5
php5-dev - Files for PHP5 module development
php5-gd - GD module for php5
php5-gmp - GMP module for php5
php5-json - JSON module for php5
php5-ldap - LDAP module for php5
php5-mysql - MySQL module for php5
php5-odbc - ODBC module for php5
php5-pgsql - PostgreSQL module for php5
php5-pspell - pspell module for php5
php5-readline - Readline module for php5
php5-recode - recode module for php5
php5-snmp - SNMP module for php5
php5-sqlite - SQLite module for php5
php5-tidy - tidy module for php5
php5-xmlrpc - XML-RPC module for php5
php5-xsl - XSL module for php5
libphp5-embed - HTML-embedded scripting language (Embedded SAPI library)
php5-adodb - Extension optimising the ADOdb database abstraction library
php5-apcu - APC User Cache for PHP 5
php5-enchant - Enchant module for php5
php5-exactimage - fast image manipulation library (PHP bindings)
php5-fpm - server-side, HTML-embedded scripting language (FPM-CGI binary)
php5-gdcm - Grassroots DICOM PHP5 bindings
php5-gearman - PHP wrapper to libgearman
php5-geoip - GeoIP module for php5
php5-gnupg - wrapper around the gpgme library
php5-imagick - ImageMagick module for php5
php5-imap - IMAP module for php5
php5-interbase - interbase/firebird module for php5
php5-intl - internationalisation module for php5
php5-lasso - Library for Liberty Alliance and SAML protocols - PHP 5 bindings
php5-librdf - PHP5 language bindings for the Redland RDF library
php5-mapscript - php5-cgi module for MapServer
php5-mcrypt - MCrypt module for php5
php5-memcache - memcache extension module for PHP5
php5-memcached - memcached extension module for PHP5, uses libmemcached
php5-midgard2 - Midgard2 Content Repository - PHP5 language bindings and module
php5-ming - Ming module for php5
php5-mongo - MongoDB database driver
php5-msgpack - PHP extension for interfacing with MessagePack
php5-mysqlnd - MySQL module for php5 (Native Driver)
php5-mysqlnd-ms - MySQL replication and load balancing module for PHP
php5-oauth - OAuth 1.0 consumer and provider extension
php5-pinba - Pinba module for PHP 5
php5-ps - ps module for PHP 5
php5-radius - PECL radius module for PHP 5
php5-redis - PHP extension for interfacing with Redis
php5-remctl - PECL module for Kerberos-authenticated command execution
php5-rrd - PHP bindings to rrd tool system
php5-sasl - Cyrus SASL Extension
php5-stomp - Streaming Text Oriented Messaging Protocol (STOMP) client module for PHP 5
php5-svn - PHP Bindings for the Subversion Revision control system
php5-sybase - Sybase / MS SQL Server module for php5
php5-tokyo-tyrant - PHP interface to Tokyo Cabinet's network interface, Tokyo Tyrant
php5-vtkgdcm - Grassroots DICOM VTK PHP bindings
php5-xcache - Fast, stable PHP opcode cacher
php5-xdebug - Xdebug Module for PHP 5
php5-xhprof - Hierarchical Profiler for PHP5
norm@Android:~$ sudo apt-get install php5-cgi
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
  php-pear
The following NEW packages will be installed:
  php5-cgi
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 4,265 kB of archives.
After this operation, 18.3 MB of additional disk space will be used.
Get:1 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main php5-cgi amd64 5.5.9+dfsg-1ubuntu4.22 [4,265 kB]
Fetched 4,265 kB in 0s (5,048 kB/s)
apt-listdifferences: fetching source packages
Ignoring already existing file: /var/cache/apt/sources/php5_5.5.9+dfsg-1ubuntu4.22.dsc
Ignoring already existing file: /var/cache/apt/sources/php5_5.5.9+dfsg.orig.tar.xz
Ignoring already existing file: /var/cache/apt/sources/php5_5.5.9+dfsg-1ubuntu4.22.debian.tar.gz
Fetched 0 B in 0s (0 B/s)
apt-listdifferences: skipping differences for src:php5 - no prior source available
Selecting previously unselected package php5-cgi.
(Reading database ... 2257309 files and directories currently installed.)
Preparing to unpack .../php5-cgi_5.5.9+dfsg-1ubuntu4.22_amd64.deb ...
Unpacking php5-cgi (5.5.9+dfsg-1ubuntu4.22) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Setting up am-utils (6.2+rc20110530-3.2ubuntu1) ...
/etc/init.d/am-utils: 1: /etc/init.d/am-utils: ypcat: not found
/etc/init.d/am-utils: cannot find master map
invoke-rc.d: initscript am-utils, action "start" failed.
dpkg: error processing package am-utils (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up php5-cgi (5.5.9+dfsg-1ubuntu4.22) ...
update-alternatives: using /usr/bin/php5-cgi to provide /usr/bin/php-cgi (php-cgi) in auto mode
update-alternatives: using /usr/lib/cgi-bin/php5 to provide /usr/lib/cgi-bin/php (php-cgi-bin) in auto mode

Creating config file /etc/php5/cgi/php.ini with new version
php5_invoke: Enable module json for cgi SAPI
php5_invoke: Enable module curl for cgi SAPI
php5_invoke: Enable module gd for cgi SAPI
php5_invoke: Enable module opcache for cgi SAPI
php5_invoke: Enable module mysqli for cgi SAPI
php5_invoke: Enable module readline for cgi SAPI
php5_invoke: Enable module xmlrpc for cgi SAPI
php5_invoke: Enable module pdo_mysql for cgi SAPI
php5_invoke: Enable module pdo for cgi SAPI
php5_invoke: Enable module mysql for cgi SAPI
php5_invoke: Enable module intl for cgi SAPI
php5_invoke: Enable module ldap for cgi SAPI
php5_invoke: Enable module pspell for cgi SAPI
Errors were encountered while processing:
 am-utils
E: Sub-process /usr/bin/dpkg returned an error code (1)
norm@Android:~$ sudo apt-get install php5-cli
Reading package lists... Done
Building dependency tree
Reading state information... Done
php5-cli is already the newest version.
php5-cli set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
Setting up am-utils (6.2+rc20110530-3.2ubuntu1) ...
/etc/init.d/am-utils: 1: /etc/init.d/am-utils: ypcat: not found
/etc/init.d/am-utils: cannot find master map
invoke-rc.d: initscript am-utils, action "start" failed.
dpkg: error processing package am-utils (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 am-utils
E: Sub-process /usr/bin/dpkg returned an error code (1)
norm@Android:~$ sudo apt-get install php5-common
Reading package lists... Done
Building dependency tree
Reading state information... Done
php5-common is already the newest version.
php5-common set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
Setting up am-utils (6.2+rc20110530-3.2ubuntu1) ...
/etc/init.d/am-utils: 1: /etc/init.d/am-utils: ypcat: not found
/etc/init.d/am-utils: cannot find master map
invoke-rc.d: initscript am-utils, action "start" failed.
dpkg: error processing package am-utils (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 am-utils
E: Sub-process /usr/bin/dpkg returned an error code (1)
norm@Android:~$ sudo apt-get install php5-curl
Reading package lists... Done
Building dependency tree
Reading state information... Done
php5-curl is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
Setting up am-utils (6.2+rc20110530-3.2ubuntu1) ...
/etc/init.d/am-utils: 1: /etc/init.d/am-utils: ypcat: not found
/etc/init.d/am-utils: cannot find master map
invoke-rc.d: initscript am-utils, action "start" failed.
dpkg: error processing package am-utils (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 am-utils
E: Sub-process /usr/bin/dpkg returned an error code (1)

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu am-utils Edit question
Assignee:
No assignee Edit question
Last query:
2018-01-13
Last reply:
2018-01-14
Manfred Hampl (m-hampl) said : #1

The problem that you see has nothing to do with php, but is caused by a broken installation of am-utils.

Do you need this package? If not, then you should remove it, and your package management system will work again without showing errors.

If you do need that package, then you have to care for an error-free installation. Maybe the solution is an installation of the nis or yp-tools packages.

Norm Tredo (tntre) said : #2

Thanks for addressing this problem. I'm stuck at this point. I tried to
replace the am-utils two times without luck. The ypcat and master map are
also contributing to this problem, which I haven't had any luck in
resolving the issue with them, either. I am beginning to think that I
should uninstall everything and begin over by scratch. If you were
experiencing my predicament, what course of action would you take to
resolve these issues? 😖

On Sat, Jan 13, 2018 at 11:32 AM, Manfred Hampl <
<email address hidden>> wrote:

> Your question #663019 on am-utils in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/am-utils/+question/663019
>
> Status: Open => Answered
>
> Manfred Hampl proposed the following answer:
> The problem that you see has nothing to do with php, but is caused by a
> broken installation of am-utils.
>
> Do you need this package? If not, then you should remove it, and your
> package management system will work again without showing errors.
>
> If you do need that package, then you have to care for an error-free
> installation. Maybe the solution is an installation of the nis or yp-
> tools packages.
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+source/am-utils/+
> question/663019/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/am-utils/+question/663019
>
> You received this question notification because you asked the question.
>

Manfred Hampl (m-hampl) said : #3

You have to know whether you need am-utils.

If you do need it, then I would try installing the apparently missing ypcat program (symptom: "/etc/init.d/am-utils: 1: /etc/init.d/am-utils: ypcat: not found") with a command like
sudo apt-get install nis

If you think that you do not need the am-utils package, I would try removing it with the command
sudo dpkg --purge am-utils

Can you help with this problem?

Provide an answer of your own, or ask Norm Tredo for more information if necessary.

To post a message you must log in.