Ubuntu

Surround sound

Asked by pepolez on 2005-10-02

I'm trying to get surround sound working on my Ubuntu Breezy (5.10) install. Currently, I have the front speakers working, but have been unable to hear sound through the rear speakers, nor locate the switch in the volume controls necessary to switch the rear speaker output from line in to rear speaker out while using the ALSA or OSS mixers.

I'm using RealTek ALC655 onboard sound on a MSI KM4M motherboard. Motherboard has a VIA KM400 north bridge and a VIA VT8235 south bridge. The motherboard has three rear jacks: line out/front, line in/rear and mic/center.

My objective here is to be able to use the rear speakers as surround sound speakers (as a 2nd channel where the recorded media supports it).

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu alsamixergui Edit question
Assignee:
No assignee Edit question
Last query:
2005-10-02
Last reply:
2009-04-14
Olafur Arason (olafra) said : #1

Try going to Applications->Sound & Video->Volume Control
and in that going to Preferences and enabling the needed Channel

Andrea Veri (av) said : #2

im having the same problem with two of my surround speakers, ii tried a lot of solutions, i re-compilated the kernel , alsa driver but nothing. I added this problem to the alsa bugs section.

Marco Cimmino (cimmo) said : #3

yes the problem that there is no front-duplication options!
Also in dapper if you want to have sound from rear speakers for two-channel audio (like mp3) you have to manually modify alsa config file.

Should be great for Edgy!

pepolez-

If this answered your question, please consider closing the ticket as answered by one of the commenters that supplied the needed information.

It looks like you'll have to wait until the Edgy release of Ubuntu for better surround sound support.

Thanks

Jim Jones

Lukas (zorin-gmx) said : #5

I'm using a nforce2 board and i've got an option to duplicate the frontspeakers to the rear ones. The name is "Duplicate Front" maybe your soundcard got this option.

Marco Cimmino (cimmo) said : #6

nope, probably my driver have to be more mature.
I have a creative sound blaster live 24 bit

It looks like you'll have to wait for Edgy possibly.

As such, please consider closing this ticket and perhaps logging a bug (https://launchpad.net/distros/ubuntu/+bugs)

You can find useful tips on managing your support requests here:

https://wiki.ubuntu.com/SupportRequests

Thanks

Jim Jones

James (chiisu81) said : #8

Feisty has been released and this has still not been resolved. There is no "duplicate front" option that I can see for my M-Audio Revolution 7.1 This question was never answered to begin with, and shouldn't have been labeled as such.

Marco Cimmino (cimmo) said : #9

As far as I know this is a specific driver in alsa issue.
I have changed my soundcard from Creative Sound Blaster 24 bit that have poor driver support due to lack of time/resources/soundcard details from Creative to a Realtek chipset and now I have duplicate sound also in the rear.

I know it's not a good way but probably the faster thing is to move to a better supported soundcard :(

Aman (maverick340) said : #11

Gutsy Gibbon is releasing in a months time and there is still no solution to the notorious Surround Sound problem. Ubuntu cannot call it a desktop solution if it cant allow the usage of 5.1/7/1 surround sound. I have tried all tweaks and methods but nothing works. I am using a NViDIA nforce chipset(MCP51) which has the hda-intel driver as told on the alsa page. Contrary to some belief intel8x0 is the inappropriate driver for it. There is no help :(

James (chiisu81) said : #12

This issue has been fixed for me with Hardy, now I have a "Duplicate Front" option by default.

Linux Lover (obake) said : #13

Here is a guide on how to enable Surround Sound on Ubuntu Hardy. I believe this tutorial also applies to later versions:

http://www.automaticable.com/2008-05-28/how-to-enable-surround-sound-on-ubuntu-hardy/

Can you help with this problem?

Provide an answer of your own, or ask pepolez for more information if necessary.

To post a message you must log in.