libasound2:i386 package dependency problem

Asked by Attila Pados on 2013-01-22

this is precice, 12.04

libasound2:amd64 depends on libc6 (>=2.14) while
libasound2:i386 depends on libc6(>=2.7)

there is no libc6 package with version 2.7, such numbers can be seen only in obsolate packages,
both amd64 and i386 has the version 2.15-0ubuntu10, which matches the amd64 arch,
but not the i386 arch

this results in sever pacakge dependency issues, generally when i try to install libasound2:i386 then apt-get wants to uninstall everything which depends on libasound2:amd64, including browsers, eclipse etc

is there workaround for this, or this is normal?
I can't tell you how i got to this situation, because i did a lot of experimentation with packages to solve a screen issue, something may get broken during that, now i am trying to recover the package structure

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu alsa-lib Edit question
Assignee:
No assignee Edit question
Solved by:
Attila Pados
Solved:
2013-01-23
Last query:
2013-01-23
Last reply:
2013-01-22

What is the output:

apt-cache policy libasound2:amd64 libasound2:i386; lsb_release -a; uname -a

Thanks

Attila Pados (attila-pados) said : #2

the actual answer for this question remained in cover, so i don't know if 2.7 is a good version or not, but i could resolve the dependency issue by:
apt-mark auto *
and then go to the update manager, setup all sources to be working, and ask for updates

it installed a lot of packages, including those that had downgraded version, with the latest version
i think the dependency issue was created by a package's amd64 and i386 arch having different version

my linux is hungarian, so some of the response would not be readable for all