No sound on Acer Aspire 3680 since upgrading from Ubuntu 9.04 to Ubuntu 9.10

Asked by tonni yiddos on 2009-11-28

I upgraded from Ubuntu 9.04 to 9.10 about 5 days ago and since then I have nor heard any sound from my Acer Aspire 3680. I had not played any audio till today so I could not notice it. I plugged-in an external speaker and still no sound. Please help!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Solved by:
tonni yiddos
Solved:
2009-11-28
Last query:
2009-11-28
Last reply:
2009-11-28
Omer Akram (om26er) said : #1

copied from the IRC
If you're having problems with sound, first ensure ALSA is selected, by double clicking on the volume control, then File -> Change Device (ALSA Mixer). If that fails, see https://help.ubuntu.com/community/Sound - https://help.ubuntu.com/community/SoundTroubleshooting - http://alsa.opensrc.org/DmixPlugin

Please send us the output from step 3 and step 4 from this procedure:

https://help.ubuntu.com/community/SoundTroubleshootingProcedure

tonni yiddos (onyido-tonni) said : #3

"We compile and install alsa-lib :

cd ../alsa-lib*
sudo ./configure
sudo make
sudo make install" - This process showed an error but I went ahead and put-in "You will need to add those symbolics links (only if you got the error) and restart the installation from the last “sudo ./configure” :

sudo ln -s libpanelw.so.5 /usr/lib/libpanelw.so
sudo ln -s libformw.so.5 /usr/lib/libformw.so
sudo ln -s libmenuw.so.5 /usr/lib/libmenuw.so
sudo ln -s libncursesw.so.5 /lib/libncursesw.so". I finished the installation and restarted my laptop and guess what - The sound is back and even louder than before! Thanks a million!

tonni yiddos (onyido-tonni) said : #4

Problem solved. Thanks!