strange "click" on speakers

Asked by Pedro Bittencourt on 2009-10-30

I've recently installed Ubuntu 9.10 in my notebook, a Gateway (Intel Dual-Core 1.6GHz, 1GB RAM). Everything works fine, but there is something wrong with the audio device. Every time I start some application that makes sound (like listen to a music, watch a video, start a conversation at Empathy, even the login/logout sounds) my speakers makes a "click". It seems for me that the speakers, when inactive, are turned off, or in stand-by. When an application makes a sound, the speakers turn on, and makes the awkward "click".

Could anybody help me with this? I haven't found this problem anywhere.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Solved by:
Colin Ian King
Solved:
2009-11-01
Last query:
2009-11-01
Last reply:
2009-10-31
Colin Ian King (colin-king) said : #1

This is most probably the audio power saving mode kicking in and causing clicks/pops when the audio hardware is transitioning to a low power mode.

To disable the power saving mode using snd-hda-intel edit /etc/modprobe.d/modprobe.conf (e.g. use sudo gedit to edit this file) and add the following line:

options snd-hda-intel power_save=0

reboot and see if this solves the problem

Best Colin Ian King (colin-king) said : #2

Add the line to alsa-base.conf You may find that "options snd-hda-intel power_save" is already present in alsa-base, but it's set =10. Set it =0 instead. That worked for me.

thanks a lot! i've modified the modprobe.conf and the problem disappeared. that worked for me.
really, thank you.