Cracking sound

Asked by Yeti on 2009-10-30

I upgraded to 9.10 beta from internet, and now when I installed full 9.10 release I have big problem! There is cracking sound from my speakers! It cracks randomly, cracks every 5-6 seconds! It cracks from my notebook speaker and from plugged in speakers. I didn't have this problem with 9.04 release... Please help me to solve this problem, I have HP530 notebook. It cracks even when I mute sound in Ubuntu, cracks when I disable internal audio hardware... Really don't know what to do...

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Solved by:
Alan Goldblatt
Solved:
2009-10-31
Last query:
2009-10-31
Last reply:
2009-10-31
Colin Ian King (colin-king) said : #1

This is most probably the audio power saving mode kicking in and causing clicks/pops when the audio hardware is transitioning to a low power mode.

To disable the power saving mode using snd-hda-intel edit /etc/modprobe.d/modprobe.conf (e.g. use sudo gedit to edit this file) and add the following line:

options snd-hda-intel power_save=0

reboot and see if this solves the problem

Yeti (videnko) said : #2

I have no such file in that folder... This is all in it:

/etc/modprobe.d/alsa-base.conf
/etc/modprobe.d/blacklist.conf
/etc/modprobe.d/blacklist-ath_pci.conf
/etc/modprobe.d/blacklist-firewire.conf
/etc/modprobe.d/blacklist-framebuffer.conf
/etc/modprobe.d/blacklist-modem.conf
/etc/modprobe.d/blacklist-oss.conf
/etc/modprobe.d/blacklist-watchdog.conf
/etc/modprobe.d/libpisock9.conf

@Yeti: Add the line to alsa-base.conf You may find that "options snd-hda-intel power_save" is already present in alsa-base, but it's set =10. Set it =0 instead. That worked for me.

Yeti (videnko) said : #4

I think that 1st option solved my problem. There wasn't file named modprobe.conf but from terminal, with sudo it was created and I added 'options snd-hda-intel power_save=0' to file.
But just in case I have done and 2nd solution, found the line and changet it from 10 to 0!

Thank You very much Colin King and Alan Goldblatt!

Yeti (videnko) said : #5

Thanks Alan Goldblatt, that solved my question.

vernerd (vernerd-reg) said : #6

I had the same problem with my acer aspire 5920. Thanks Alan for the solution.