OmniVision USB monitor webcam works but its microphone does not

Asked by Val on 2009-07-19

I have a Dell SP2208WFP monitor with built-in webcam and microphone that both work fine under Windows XP. Under Ubuntu 9.04, the webcam works (I can see my video in Ekiga softphone), but the webcam microphone does not.

The webcam microphone is always switched off in the Volume Control. When I turn it on, nothing happens and as soon as I reopen the Volume Control window, the webcam mic shows as switched off again.

alsamixer shows the Capture level for the webcam mic at 75 level, which is normal. I can increase or decrease the capture level, but it does not seem to have any effect on the mic.

When I try recording something using the webcam mic, I get errors:

val@ubuntu:~$ arecord -f cd -D hw:1,0 -d 20 test.wav
Recording WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
arecord: set_params:939: Broken configuration for this PCM: no configurations available

When I try using this microphone is my input device in Skype 2.0.0.72, I get "Problem with Audio Capture".

Here is some additional information about my system configuration:

val@ubuntu:~$ cat /proc/asound/cards
 0 [Audigy2 ]: Audigy2 - Audigy 2 [SB0350b]
                      Audigy 2 [SB0350b] (rev.4, serial:0x20061102) at 0xdcc0, irq 19
 1 [SP2208WFP ]: USB-Audio - Monitor Webcam (SP2208WFP)
                      Mic-OmniVision Technologies, Inc.538-2640-07.08.09.6 Monitor Webcam (SP2208WFP)

val@ubuntu:~$ cat /proc/asound/card1/stream0
Mic-OmniVision Technologies, Inc.538-2640-07.08.09.6 Monitor Webcam (SP2208WFP) : USB Audio

Capture:
  Status: Stop
  Interface 3
    Altset 1
    Format: 0x2
    Channels: 2
    Endpoint: 4 IN (SYNC)
    Rates: 48000, 44100, 32000, 24000, 22050, 16000, 12000, 11025, 8000

val@ubuntu:~$ arecord --list-devices
**** List of CAPTURE Hardware Devices ****
card 0: Audigy2 [Audigy 2 [SB0350b]], device 0: emu10k1 [ADC Capture/Standard PCM Playback]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Audigy2 [Audigy 2 [SB0350b]], device 1: emu10k1 mic [Mic Capture]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Audigy2 [Audigy 2 [SB0350b]], device 2: emu10k1 efx [Multichannel Capture/PT Playback]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Audigy2 [Audigy 2 [SB0350b]], device 4: p16v [p16v]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: SP2208WFP [Monitor Webcam (SP2208WFP)], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

val@ubuntu:~$ lsusb --verbose (I have included only the relevant parts of output!)
...
Bus 001 Device 007: ID 05a9:2643 OmniVision Technologies, Inc.
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 2.00
  bDeviceClass 239 Miscellaneous Device
  bDeviceSubClass 2 ?
  bDeviceProtocol 1 Interface Association
  bMaxPacketSize0 64
  idVendor 0x05a9 OmniVision Technologies, Inc.
  idProduct 0x2643
  bcdDevice 1.00
  iManufacturer 1 Mic-OmniVision Technologies, Inc.538-2640-07.08.09.6
  iProduct 2 Monitor Webcam (SP2208WFP)
  iSerial 0
  bNumConfigurations 1
...
  Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 1051
    bNumInterfaces 4
    bConfigurationValue 1
    iConfiguration 0
    bmAttributes 0x80
      (Bus Powered)
    MaxPower 500mA
    Interface Association:
      bLength 8
      bDescriptorType 11
      bFirstInterface 2
      bInterfaceCount 2
      bFunctionClass 1 Audio
      bFunctionSubClass 1 Control Device
      bFunctionProtocol 0
      iFunction 0
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 2
      bAlternateSetting 0
      bNumEndpoints 0
      bInterfaceClass 1 Audio
      bInterfaceSubClass 1 Control Device
      bInterfaceProtocol 0
      iInterface 0
      AudioControl Interface Descriptor:
        bLength 9
        bDescriptorType 36
        bDescriptorSubtype 1 (HEADER)
        bcdADC 1.00
        wTotalLength 43
        bInCollection 1
        baInterfaceNr( 0) 3
      AudioControl Interface Descriptor:
        bLength 12
        bDescriptorType 36
        bDescriptorSubtype 2 (INPUT_TERMINAL)
        bTerminalID 1
        wTerminalType 0x0205 Microphone Array
        bAssocTerminal 0
        bNrChannels 2
        wChannelConfig 0x0000
        iChannelNames 0
        iTerminal 0
      AudioControl Interface Descriptor:
        bLength 9
        bDescriptorType 36
        bDescriptorSubtype 3 (OUTPUT_TERMINAL)
        bTerminalID 2
        wTerminalType 0x0101 USB Streaming
        bAssocTerminal 0
        bSourceID 3
        iTerminal 0
      AudioControl Interface Descriptor:
        bLength 13
        bDescriptorType 36
        bDescriptorSubtype 6 (FEATURE_UNIT)
        bUnitID 3
        bSourceID 1
        bControlSize 2
        bmaControls( 0) 0x43
        bmaControls( 0) 0x02
          Mute
          Volume
          Automatic Gain
          Loudness
        bmaControls( 1) 0x00
        bmaControls( 1) 0x00
        bmaControls( 2) 0x00
        bmaControls( 2) 0x00
        iFeature 0

I have googled extensively in search of a solution to this problem and found quite a few conversations on this subject, however none of the proposed solutions helped me. Here is a partial list of resources and suggestions I tried without success so far:

ALSA module configuration:
  http://alsa-project.org/main/index.php/Matrix:Module-usb-audio
Setting up uvcvideo drivers:
  http://ubuntuforums.org/showthread.php?t=684153&page=3
Tweaking up alsa-base.conf settings:
  http://ubuntuforums.org/showthread.php?t=1126713
[Alsa-user] microphone setup on Dell Monitor Webcam (SP2208WFP) (same problem, no solution):
  http://<email address hidden>/msg24338.html
Configuring USB microphones on Linux:
  http://www.audacityteam.org/wiki/index.php?title=USB_mic_on_Linux

Now, here is a part from /var/log/syslog that looks highly suspicious since line three below directly refers to card1, which is my webcam usb microphone capture card:
Jul 19 11:46:03 ubuntu pulseaudio[5003]: alsa-util.c: Cannot find fallback mixer control "PCM" or mixer control is no combination of switch/volume.
Jul 19 11:46:03 ubuntu pulseaudio[5003]: alsa-util.c: Cannot find fallback mixer control "Mic" or mixer control is no combination of switch/volume.
Jul 19 11:46:04 ubuntu pulseaudio[5003]: alsa-util.c: Failed to set hardware parameters on plug:hw:1: Invalid argument

Any ideas what hardware parameters might be causing the problem? It does very much look like something is either missing or incorrect in my system configuration!

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Last query:
2010-04-14
Last reply:
2009-08-05
Tom (tom6) said : #1

Perhaps one of the other volume levels is too low, or more likely the camera's one is somehow set as muted, and this may mean you'll need to wobble the pcm level up and down because that seems to be wonky on quite a few systems at the moment - i think it's a bug that's being worked on.

Also i was wondering if you have already worked through the Medibuntu worksheet
https://help.ubuntu.com/community/Medibuntu

and the 2 troubleshooting guides, hopefully something near the start of either of these might help

https://wiki.ubuntu.com/DebuggingSoundProblems

https://help.ubuntu.com/community/SoundTroubleshooting

Good luck and regards from
Tom :)

Val (vk1266) said : #2

Thank you for your advice Tom! I checked my volume controls again and I confirm that the volume level on the webcam microphone is set to 77% as it was before. Also, the mic is not muted.

I went over the two troubleshooting guides you recommended and found out that I had tried pretty much every tip and advice in them already before, with no success. Going over those tips and trying them again now, just to double check, did not help, unfortunately.

Using the alsa-info.sh script, I uploaded my system information to the alsa-project site. It is available at http://www.alsa-project.org/db/?f=d2090c0ba2fd9878bd2f293261a35591dd3db111.

When I test sound capture with my webcam mic using Sound Preferences (System -> Preferences -> Sound), I get the following error message:
gconfaudiosrc ! audioconvert ! audioresample ! gconfaudiosink profile=chat: Could not get/set settings from/on resource.

This error message seems to point to the same problem with hardware settings as in /var/log/syslog (see my earlier post).

Launchpad Janitor (janitor) said : #3

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Tom (tom6) said : #4

Hi :)

Have you been able to test the new Ubuntu 10.04 before it gets officially released?
http://www.ubuntulinux.org/testing/lucid/beta1
Trying it as a LiveCd or as an extra dual/multi-boot would be ideal. Developers and everyone are keen to try to iron out any problems before 10.04 gets officially released so you might find faster & more effective answers to your bug reports which would make 10.04 work better on your system for you

Thanks and regards from
Tom :)

Val (vk1266) said : #5

Thank you -- I followed your tip and downloaded AMD64 (64-bit) Ubuntu 10.04 Beta 1 (as of 4-Apr-2010), burned the ISO image onto a CD, restarted the computer, booted into the LiveCD and...

Halleluja!!! My USB microphone is now working perfectly fine. This solves one of the most annoying problems for me since Ubuntu 6! This means I can now use Skype without having to boot into Windows!!!

THANK YOU Ubuntu 10 team for finally fixing this problem. Suddently, Ubuntu has much greater value for me. I use Skype more often than telephone, and since I was unable to use Skype with previous versions of Ubuntu I had to boot into Windows to use Skype.

If there any any additional diagnostics you want me to run on my system, please let me know and I will be happy to do it.

Not everything was perfect with the LiveCD though. The boot procedure hangs with no mouse cursor and no prompts of any sort, completely unresponsive to keyboard, on my dual-monitor system. Unplugging the second monitor solved the problem for me and I was able to boot after that.

Tom (tom6) said : #6

Hi :)

Superb !! I'm glad to hear about one problem being fixed there. Please could you go up to the top panel/taskbar and click on

System - Administration - System Testing

and send in a report? Also it would be great if you could send in separate bug-reports about each of the problems you had. I guess it might be good to post a "bug-report" about the skype thing to let them know it's working on 10.04 now :)

Thanks, good luck and regards from
Tom :)

Val (vk1266) said : #7

Hi Tom,

I ran System Testing but could not submit the system testing report, getting the "XML Parsing Error: not well-formed" error message. A quick check of Launchpad has revealed a known issue with Checkbox:

"(checkbox) "System Testing" application will not submit to Launchpad"
https://bugs.launchpad.net/ubuntu/+source/checkbox/+bug/531010

I am getting the exact same error message as in that bug report. Since I am running off of a LiveCD, I am somewhat limited with my options. I am going to try applying checkbox patches while on a LiveCD and re-running and submitting the report again.

Also... I am getting sporadic system freezes with both mouse and keyboard becoming completely unresponsive. I did not have that with Karmic, and I guess this is probably a "beta issue". It's hard to tell at this point what causes the freezes. I'll keep watching...

Many thanks,
Val

Tom (tom6) said : #8

Hi :)

Posting in separate bug-reports about those problems is more important than completing the checkbox issue. Alerting people to certain hardware not working is more important than confirming that other stuff does work.

If you are determined then it might be possible to install to a 15Gb free space on your hard-drive, if you have any free space? Personally i would not go that far with this yet. I would only do that after the official release so that i could dual-boot between new release and current release that works well for me right now.

Thanks for working at this :)
Many regards from
Tom :)

Tom (tom6) said : #9

Hi :)

Have you been able to try the new Ubuntu 10.04 before it gets officially released?
http://www.ubuntulinux.org/testing/lucid/beta2
Trying it as a LiveCd or as an extra dual/multi-boot would be ideal. Developers and everyone are keen to try to iron out any problems before 10.04 gets officially released so you might find faster & more effective answers to your bug reports which would make 10.04 work better on your system for you

Thanks and regards from
Tom :)

Val (vk1266) said : #10

Hi Tom,

I got some bad news. The microphone problem was fixed in Ubuntu 10.04 Beta 1, but it is broken again in Beta 2. Booting from Beta 2 Live CD, I can see my audio hardware devices correctly detected and listed in the "Audio Preferences". However, in the "Output" tab I only get the "Dummy Audio" device. In the "Input" tab, I do not have any devices at all. As a result, there is no audio output and no audio input.

Even worse, Beta 2 sporadically hangs making bug reporting from within Ubuntu an exercise of futility. At this point, I have given up trying to report bugs from within Ubuntu using Ubuntu's bug reporting tools, and switched to a Windows system for adding comments here. I have added a bug report on booting from a Live CD on a dual-monitor system: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/561975

I had managed to collect syslog and dmesg outputs on a Beta 2 system however before the system became unresponsive. If this information is important, I will be happy to upload both files. Please suggest where I should upload them if this information is important.

Tom (tom6) said : #11

Hi :)

Ideally start a new bug-report, preferably from a LiveCd session of the beta1 (?) and then send in the files about the beta2 not working. You might find it easier to just start a bug report using Windows and then send in the attachments from there? Each bug-report really needs to deal with just 1 issue and it looks as though the microphone problem is very fixable and easier to post in about?

This link lets you post a bug-report without collecting info about your system but can be used from inside Windows
https://bugs.launchpad.net/ubuntu/+source/linux/+filebug

It might be good to post a bug-report about the bug-report-system not working as it is clearly something that needs to be sorted out!

Thanks for the report backs into here but it might be more effective if you could also start new questions about some of these things. Bug-reports are probably more important than questions for the next 4 weeks tho!

Many thanks and regards from
Tom :)

Val (vk1266) said : #12

Hi Tom,

It turns out that removing 'splash' parameter from the boot options and adding 'noapic' parameter fixes pretty much every issue I have encountered so far with 10.04 Beta 1 and Beta 2. The system boots normally with dual monitors and appears stable. The audio is working properly. I have not experienced any sporadic freezes so far.

Yes it did take me a few hours of experimenting, but I am happy to conclude that both betas work fine on my system at this point - IF, AND ONLY IF the boot options are reconfigured from the default options. Booting to Live CD with the default options has brought to me nothing but frustration. This is not right and this kind of problem will undoubtedly turn away the many folks who experience the same problem and who do not have the time and the patience to find a workable solution. I will be happy to submit my hardware information to the kernel developers and tell them about my issues and the found solutions. However, I am not sure if the usual bug reporting process applies here. 'noapic' is usually used with older or buggy hardware and I may simply have one or the other. Should I use 'ubuntu-bug kernel' to tell them about the splash option and the noapic option in two separate reports?

Should I proceed with submission of System Testing report if my system only boots when 'splash' parameter is not present and works fine only when 'noapic' parameter is present?

Thank you!
Val

Tom (tom6) said : #13

Hi :)

Yes, posting the System Testing thing in through it's automated system is always a good plan imo. I think if "ubuntu-bug kernel" looks like the right place to post the bug-reports then go ahead. There will be a lot of people working at fast triaging before it arrives at any teams desk so it should get to the right place and be flagged up quite quickly. Thanks for testing the beta's on non-standard hardware! :)) Especially thanks for getting to a good answer & for the painstaking troubleshooting you have done with this.

When you choose those boot parameters/options do you see the difference to the boot-string white text thing? I assume that is what would need to be added in to grubs lines for a full install. I still haven'#t worked out how to edit grub2 yet either.

So, thanks for all that and sorry i can't really help much there!
Good luck and regards from
Tom :)

Can you help with this problem?

Provide an answer of your own, or ask Val for more information if necessary.

To post a message you must log in.