Ubuntu

Mic and jack-sensing on ALC889A (Acer Aspire 6935G)

Asked by Karthik Ramgopal on 2009-05-15

I have an aspire 6935G with a Realtek ALC889 codec (Intel ICH9 HD Audio). My laptop contains 3 analog out jacks (mic+line-out+line-in) and 2 built in front speakers+1 TUBA subwoofer+1 internal mic.

As of now the subwoofer and sound (via laptop speakers) work only when I use hda-verb manually:

./hda-verb /dev/snd/hwC0D0 0×15 SET_EAPD_BTLENABLE 2

The headphone output works by increasing the volume of surround. 'Front' is used to control the laptop speaker's volume. When the headphone is inserted the laptop speakers continue to function (ie. No jack sensing). 'Front' needs to be manually muted to disable laptop speakers.

Another funny thing is that the headphone switch in the mixer turns the subwoofer on(when checked) and off. I think it is a pinout mapping problem.

None of the mics (Internal as well as external) work.

I am using the Realtek Linux Driver 5.11 (Based on ALSA 1.0.19) with Ubuntu 9.04 and hda-verb 0.3

I have tried different drivers (stock alsa 1.0.19, alsa 1.0.20 and even the latest alsa-driver snapshot). No driver seems to resolve the issue. I tried to make sense of patch_realtek.c in alsa-driver but could not achieve much progress.

Some things I have seen:

hda-verb /dev/snd/hwC0D0 0x15 SET_PIN_WIDGET_CONTROL 0x00 (mutes line-out)
hda-verb /dev/snd/hwC0D0 0x15 SET_PIN_WIDGET_CONTROL 0x40 (unmutes line-out)
hda-verb /dev/snd/hwC0D0 0x15 SET_PIN_WIDGET_CONTROL 0xc0 (makes line-out louder.. no effect on laptop speakers)
hda-verb /dev/snd/hwC0D0 0x0c SET_AMP_GAIN_MUTE 0x7080 (mutes all channels)
hda-verb /dev/snd/hwC0D0 0x0c SET_AMP_GAIN_MUTE 0x7000 (unmutes all)

In patch_realtek.c the headphone control is via 0x14 and the laptop speakers are controlled via 0x15. But here I see no use of 0x14 and all happens at node 0x15.

Any ideas to get proper jack-sensing and internal mic working?

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Last query:
2009-05-15
Last reply:
2009-05-30

I found a wealth of info on this post by a user of a similar (6920G) laptop. Incidentally his problem is also yet unsolved.

http://mailman.alsa-project.org/pipermail/alsa-devel/2008-October/011295.html

Launchpad Janitor (janitor) said : #2

This question was expired because it remained in the 'Open' state without activity for the last 15 days.