dummy output only nvidia rtx 2070 super

Asked by David D Wachtveitl on 2021-06-06

Hello,

I upgraded my GPU and my audio stopped working. I am using the nvidia driver 465.31, alsa recognizes my device and it is activated, but aplay -l shows no soundcards. Device is connected via Display Port.

Sound cards recognized by ALSA, and activated:
00:1f.3 Audio device [0403]: Intel Corporation 100 Series/C230 Series Chipset Family HD Audio Controller [8086:a170] (rev 31)
01:00.1 Audio device [0403]: NVIDIA Corporation TU104 HD Audio Controller [10de:10f8] (rev a1)

aplay: device_list:274: no soundcards found...

I started out on 20.04, upgraded to see if that would help

Linux Watchme 5.8.0-55-generic #62-Ubuntu SMP Tue Jun 1 08:21:18 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

Tried all the steps from the WIKI for alsa and pulse audio but still only get the dummy output in system settings. Hardware verified working with boot to windows.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Solved by:
David D Wachtveitl
Solved:
Last query:
Last reply:
Revision history for this message
David D Wachtveitl (dwachtve) said :
#1
Revision history for this message
David D Wachtveitl (dwachtve) said :
#2

After reading a few other people issues, I discovered running modprobe snd_hda_intel will place the audio back into the settings, but there is still no audio. However I do now have devices from aplay -l

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: CA0132 Analog [CA0132 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: CA0132 Digital [CA0132 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 11: HDMI 5 [HDMI 5]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 12: HDMI 6 [HDMI 6]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Revision history for this message
David D Wachtveitl (dwachtve) said :
#3
Revision history for this message
David D Wachtveitl (dwachtve) said :
#4

Hello,

Actually after doing the modprobe my sound is actually working, it is only the test button that doesn't work. Unfortunately this doesn't persist after a reboot and adding to /etc/modules also did not resolve. But having sound again, is close enough, I will figure the other part out.

Revision history for this message
Manfred Hampl (m-hampl) said :
#5

Check whether snd_hda_intel is blacklisted in any of the configuration files and remove the entry in case that you find one.

grep -i snd_hda_intel /etc/modprobe.d/*

Revision history for this message
David D Wachtveitl (dwachtve) said :
#6

Hello Manfred,

Unfortunately no it isn't in the blacklist files. I added the command to rc.local and enabled it for now as a work around. The sound test also still doesn't work for some strange reason, it did previously.

Revision history for this message
David D Wachtveitl (dwachtve) said :
#7

Hello Manfred,

Hmm, I did find it however with dashes instead of underscores:

oss4-base_noALSA.conf:blacklist snd-hda-intel

Revision history for this message
David D Wachtveitl (dwachtve) said :
#8

Hello Manfred,

Removing the entry from above mentioned file (and rc.local) and rebooting seems to be fine. Sound still working and correct output still chosen. Still no working test button, but I really don't care much about that issue.

Thank you for your guidance and support, greatly appreciated!!