No Audio on Ubuntu 20.04.2 Parallels VM on arm64 MacAir M1

Asked by George Hughes on 2021-04-16

Below dashed line is the Step 4 Diagnostic Output from SoundTroubleshooting Page Ubuntu.

I have a Windows10 (on ARM) VM on the same machine, which has no problem recording/playing sound. from the full range of MacAir options. So, it seems to me that the problem lies on the Ubuntu side.

While the output below seems to indicate that ALSA is set up, I only ran the STEP 4 in response to instruction in case NO ALSA Version number shows up.

I simply want to get the problem resolved... ....thanks for whatever help you might be able to provide.

GH

-------------------------------------------------------------------------------------------------
16 April, 1730h STEP 4
-------------------------------------------------------------------------------------------------

cat: /dev/sndstat: No such file or directory
Bus 003 Device 004: ID 203a:fff9 Parallels FaceTime HD Camera
Bus 003 Device 003: ID 203a:fffb Parallels Virtual Keyboard
Bus 003 Device 002: ID 203a:fffc Parallels Virtual Mouse
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 003: ID 203a:fffa Parallels Virtual Printer (EPSON WF-4740 Series)
Bus 002 Device 002: ID 203a:fffa Parallels Virtual Printer (Print to PDF (Mac Desktop))
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
/usr/sbin/alsactl
Specified filename /dev/dsp does not exist.
dpkg-query: no path found matching pattern *bin/slmodemd*
[ 0.000000] NUMA: No NUMA configuration found
[ 0.000000] psci: PSCIv1.0 detected in firmware.
[ 0.057589] Registered cp15_barrier emulation handler
[ 0.057591] setend instruction emulation is not supported on this system
[ 0.058410] audit: initializing netlink subsys (disabled)
[ 0.058478] audit: type=2000 audit(0.056:1): state=initialized audit_enabled=0 res=1
[ 0.058557] hw-breakpoint: found 6 breakpoint and 4 watchpoint registers.
[ 0.192024] libphy: Fixed MDIO Bus: probed
[ 0.200948] ima: No TPM chip found, activating TPM-bypass!
[ 0.200959] ima: No architecture policies found
[ 0.222837] Checked W+X mappings: passed, no W+X pages found
[ 0.254067] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 5.04
[ 0.254159] hub 1-0:1.0: USB hub found
[ 0.254320] usb usb3: New USB device found, idVendor=1d6b, idProduct=0003, bcdDevice= 5.04
[ 0.254416] hub 3-0:1.0: USB hub found
[ 0.257935] ahci 2140000.ahci: 2140000.ahci supply ahci not found, using dummy regulator
[ 0.257945] ahci 2140000.ahci: 2140000.ahci supply phy not found, using dummy regulator
[ 0.257949] ahci 2140000.ahci: 2140000.ahci supply target not found, using dummy regulator
[ 0.272592] usb usb2: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 5.04
[ 0.272687] hub 2-0:1.0: USB hub found
[ 0.621016] usb 3-1: New USB device found, idVendor=203a, idProduct=fffc, bcdDevice= 1.00
[ 0.772705] usb 3-2: New USB device found, idVendor=203a, idProduct=fffb, bcdDevice= 1.00
[ 0.921596] usb 3-3: New USB device found, idVendor=203a, idProduct=fff9, bcdDevice= 1.00
[ 2.751499] systemd[1]: Created slice system-modprobe.slice.
[ 2.752013] systemd[1]: Listening on Journal Audit Socket.
[ 2.769916] systemd[1]: <email address hidden>: Succeeded.
[ 2.781649] lp: driver loaded but no devices found
[ 3.062865] uvcvideo: Found UVC 1.00 device FaceTime HD Camera (203a:fff9)
[ 3.423026] audit: type=1400 audit(1618607837.716:2): apparmor="STATUS" operation="profile_load" profile="unconfined" name="libreoffice-xpdfimport" pid=526 comm="apparmor_parser"
[ 3.424812] audit: type=1400 audit(1618607837.720:3): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=524 comm="apparmor_parser"
[ 3.424814] audit: type=1400 audit(1618607837.720:4): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/NetworkManager/nm-dhcp-helper" pid=524 comm="apparmor_parser"
[ 3.424814] audit: type=1400 audit(1618607837.720:5): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=524 comm="apparmor_parser"
[ 3.424815] audit: type=1400 audit(1618607837.720:6): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/{,usr/}sbin/dhclient" pid=524 comm="apparmor_parser"
[ 3.424984] audit: type=1400 audit(1618607837.720:7): apparmor="STATUS" operation="profile_load" profile="unconfined" name="lsb_release" pid=529 comm="apparmor_parser"
[ 3.425744] audit: type=1400 audit(1618607837.720:8): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/cups/backend/cups-pdf" pid=528 comm="apparmor_parser"
[ 3.425745] audit: type=1400 audit(1618607837.720:9): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/cupsd" pid=528 comm="apparmor_parser"
[ 3.425746] audit: type=1400 audit(1618607837.720:10): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/cupsd//third_party" pid=528 comm="apparmor_parser"
[ 4.543910] usb 2-1: New USB device found, idVendor=203a, idProduct=fffa, bcdDevice= 1.00
[ 9.463720] usb 2-2: New USB device found, idVendor=203a, idProduct=fffa, bcdDevice= 1.00
  cron.service loaded active running Regular background program processing daemon
  udisks2.service loaded active running Disk Manager
  system-modprobe.slice loaded active active system-modprobe.slice
  systemd-journald-audit.socket loaded active running Journal Audit Socket
  fstrim.timer loaded active waiting Discard unused blocks once a week
sudo: /etc/init.d/sl-modem-daemon: command not found
 Release Date: Mar 25 2021
 Manufacturer: Parallels
 Product Name: Parallels ARM Virtual Machine
 Serial Number: Parallels-XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX
 Manufacturer: Parallels
 Product Name: Parallels ARM Virtual Platform
 Serial Number: None
 Manufacturer: Apple
 Serial Number: None
usblp 32768 0
usbhid 73728 0
hid 147456 2 usbhid,hid_generic
1 sink(s) available.
  * index: 0
 name: <auto_null>
 driver: <module-null-sink.c>
 flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
 state: IDLE
 suspend cause: (none)
 priority: 1000
 volume: front-left: 57545 / 88% / -3.39 dB, front-right: 55865 / 85% / -4.16 dB
         balance -0.03
 base volume: 65536 / 100% / 0.00 dB
 volume steps: 65537
 muted: no
 current latency: 38.48 ms
 max request: 6 KiB
 max rewind: 6 KiB
 monitor source: 0
 sample spec: s16le 2ch 44100Hz
 channel map: front-left,front-right
              Stereo
 used by: 0
 linked by: 1
 configured latency: 40.00 ms; range is 0.50 .. 2000.00 ms
 module: 13
 properties:
  device.description = "Dummy Output"
  device.class = "abstract"
  device.icon_name = "audio-card"
aplay: device_list:274: no soundcards found...
Unloading ALSA sound driver modules: (none loaded).
Loading ALSA sound driver modules: (none to reload).
ubuntu-support-status: command not found
1780 packages installed, of which:
1646 receive package updates with LTS until 4/2025
 134 could receive security updates with ESM Apps until 4/2030

Enable Extended Security Maintenance (ESM Apps) to get 0 security
updates (so far) and enable coverage of 134 packages.

This machine is not attached to an Ubuntu Advantage subscription.
See https://ubuntu.com/advantage
  *-usb:2
       description: Video
       product: FaceTime HD Camera
       vendor: Parallels
       physical id: 3
       bus info: usb@3:3
       version: 1.00
       serial: EAB7A68FEC2B4487AADFD8A91C1CB782
       capabilities: usb-3.10
       configuration: driver=uvcvideo speed=5000Mbit/s

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
George Hughes (fastrkr) said : #1

NOTE:

parallels@ubuntu-linux-20-04-desktop:~$ alsamixer
cannot open mixer: No such file or directory

Similarly pavucontrol opens a more or less empty UI.

GH

Bernard Stafford (bernard010) said : #2

Try installing GNOME ALSA Mixer form the Ubuntu Software Center, It is a snap package.
After it is installed make sure to unmute all of the mute checkmark boxes. This is a GUI Mixer.

Can you help with this problem?

Provide an answer of your own, or ask George Hughes for more information if necessary.

To post a message you must log in.