my sound doesn't work

Asked by Behzad Azarhoushang on 2021-04-13

--2021-04-13 13:08:46-- http://www.alsa-project.org/alsa-info.sh
Resolving www.alsa-project.org (www.alsa-project.org)... 207.180.221.201
Connecting to www.alsa-project.org (www.alsa-project.org)|207.180.221.201|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://www.alsa-project.org/alsa-info.sh [following]
--2021-04-13 13:08:47-- https://www.alsa-project.org/alsa-info.sh
Connecting to www.alsa-project.org (www.alsa-project.org)|207.180.221.201|:443... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://git.alsa-project.org/?p=alsa-utils.git;a=blob_plain;f=alsa-info/alsa-info.sh [following]
--2021-04-13 13:08:47-- https://git.alsa-project.org/?p=alsa-utils.git;a=blob_plain;f=alsa-info/alsa-info.sh
Resolving git.alsa-project.org (git.alsa-project.org)... 207.180.221.201
Connecting to git.alsa-project.org (git.alsa-project.org)|207.180.221.201|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [application/x-sh]
Saving to: ‘alsa-info.sh’

alsa-info.sh [ <=> ] 28,13K --.-KB/s in 0s

2021-04-13 13:08:47 (65,8 MB/s) - ‘alsa-info.sh’ saved [28807]

ALSA Information Script v 0.5.0
--------------------------------

This script visits the following commands/files to collect diagnostic
information about your ALSA installation and sound related hardware.

  dmesg
  lspci
  aplay
  amixer
  alsactl
  rpm, dpkg
  /proc/asound/
  /sys/class/sound/
  ~/.asoundrc (etc.)

See './alsa-info.sh --help' for command line options.

./alsa-info.sh: line 661: tree: command not found
alsactl: save_state:1595: No soundcards found...
cat: /tmp/alsa-info.ueBpyZzLhE/alsactl.tmp: No such file or directory
Automatically upload ALSA information to www.alsa-project.org? [y/N] : y
Uploading information to www.alsa-project.org ... Done!

Your ALSA information is located at http://alsa-project.org/db/?f=fc371023ca60e721a926443afe0ae65bee604840
Please inform the person helping you.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Last query:
2021-04-13
Last reply:
2021-05-01

!!################################
!!ALSA Information Script v 0.5.0
!!################################

!!Script ran on: Tue Apr 13 11:08:48 UTC 2021

!!Linux Distribution
!!------------------

Ubuntu 20.04.2 LTS \n \l DISTRIB_ID=Ubuntu DISTRIB_DESCRIPTION="Ubuntu 20.04.2 LTS" NAME="Ubuntu" ID=ubuntu ID_LIKE=debian PRETTY_NAME="Ubuntu 20.04.2 LTS" HOME_URL="https://www.ubuntu.com/" SUPPORT_URL="https://help.ubuntu.com/" BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/" PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy" UBUNTU_CODENAME=focal

!!DMI Information
!!---------------

Manufacturer: Acer
Product Name: Swift SF714-51T
Product Version: V1.19
Firmware Version: V1.19
System SKU: 0000000000000000
Board Vendor: KBL
Board Name: Ale_KL

!!ACPI Device Status Information
!!---------------

/sys/bus/acpi/devices/10251137:00/status 15
/sys/bus/acpi/devices/10251229:00/status 15
/sys/bus/acpi/devices/ACPI000C:00/status 15
/sys/bus/acpi/devices/FTCS1000:00/status 15
/sys/bus/acpi/devices/INT0E0C:00/status 15
/sys/bus/acpi/devices/INT33A1:00/status 15
/sys/bus/acpi/devices/INT3400:00/status 15
/sys/bus/acpi/devices/INT3403:00/status 15
/sys/bus/acpi/devices/INT3403:01/status 15
/sys/bus/acpi/devices/INT3403:02/status 15
/sys/bus/acpi/devices/INT3F0D:00/status 15
/sys/bus/acpi/devices/LNXPOWER:00/status 1
/sys/bus/acpi/devices/MSFT0101:00/status 15
/sys/bus/acpi/devices/PNP0103:00/status 15
/sys/bus/acpi/devices/PNP0C02:00/status 3
/sys/bus/acpi/devices/PNP0C02:04/status 3
/sys/bus/acpi/devices/PNP0C0A:00/status 31
/sys/bus/acpi/devices/PNP0C0F:00/status 9
/sys/bus/acpi/devices/PNP0C0F:01/status 9
/sys/bus/acpi/devices/PNP0C0F:02/status 9
/sys/bus/acpi/devices/PNP0C0F:03/status 9
/sys/bus/acpi/devices/PNP0C0F:04/status 9
/sys/bus/acpi/devices/PNP0C0F:05/status 9
/sys/bus/acpi/devices/PNP0C0F:06/status 9
/sys/bus/acpi/devices/PNP0C0F:07/status 9
/sys/bus/acpi/devices/USBC000:00/status 15
/sys/bus/acpi/devices/device:17/status 15
/sys/bus/acpi/devices/device:71/status 11

!!Kernel Information
!!------------------

Kernel release: 5.8.0-49-generic
Operating System: GNU/Linux
Architecture: x86_64
Processor: x86_64
SMP Enabled: Yes

!!ALSA Version
!!------------

Driver version: k5.8.0-49-generic
Library version: 1.2.2
Utilities version: 1.2.2

!!Loaded ALSA modules
!!-------------------

!!Sound Servers on this system
!!----------------------------

Pulseaudio:
      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes

!!Soundcards recognised by ALSA
!!-----------------------------

--- no soundcards ---

!!PCI Soundcards installed in the system
!!--------------------------------------

00:1f.3 Multimedia audio controller [0401]: Intel Corporation Sunrise Point-LP HD Audio [8086:9d71] (rev 21)
 Subsystem: Acer Incorporated [ALI] Sunrise Point-LP HD Audio [1025:1245]

!!Modprobe options (Sound related)
!!--------------------------------

snd_pcsp: index=-2
snd_usb_audio: index=-2
snd_atiixp_modem: index=-2
snd_intel8x0m: index=-2
snd_via82xx_modem: index=-2
snd_atiixp_modem: index=-2
snd_intel8x0m: index=-2
snd_via82xx_modem: index=-2
snd_usb_audio: index=-2
snd_usb_caiaq: index=-2
snd_usb_ua101: index=-2
snd_usb_us122l: index=-2
snd_usb_usx2y: index=-2
snd_cmipci: mpu_port=0x330 fm_port=0x388
snd_pcsp: index=-2
snd_usb_audio: index=-2

!!Loaded sound module options
!!---------------------------

!!Sysfs card info
!!---------------

!!Card: /sys/class/sound/card*
Driver:
Tree:

!!ALSA Device nodes
!!-----------------

crw-rw---- 1 root audio 116, 1 Apr 13 13:07 /dev/snd/seq
crw-rw---- 1 root audio 116, 33 Apr 13 13:07 /dev/snd/timer

!!Aplay/Arecord output
!!--------------------

APLAY

aplay: device_list:274: no soundcards found...

ARECORD

arecord: device_list:274: no soundcards found...

!!Amixer output
!!-------------

!!Alsactl output
!!--------------

--startcollapse--
--endcollapse--

!!All Loaded Modules
!!------------------

acer_wireless
acer_wmi
acpi_pad
acpi_thermal_rel
aesni_intel
af_alg
algif_hash
algif_skcipher
autofs4
bluetooth
bnep
btbcm
btintel
btrtl
btusb
ccm
cec
cfg80211
cmac
coretemp
crc32_pclmul
crct10dif_pclmul
cryptd
crypto_simd
drm
drm_kms_helper
ecc
ecdh_generic
efi_pstore
fb_sys_fops
ghash_clmulni_intel
glue_helper
hid
hid_generic
hid_multitouch
i2c_algo_bit
i2c_hid
i2c_i801
i2c_smbus
i915
idma64
input_leds
int3400_thermal
int3403_thermal
int340x_thermal_zone
intel_cstate
intel_lpss
intel_lpss_pci
intel_pch_thermal
intel_powerclamp
intel_rapl_common
intel_rapl_msr
intel_soc_dts_iosf
intel_wmi_thunderbolt
intel_xhci_usb_role_switch
ip_tables
iwlmvm
iwlwifi
joydev
kvm
kvm_intel
libarc4
lp
mac80211
mac_hid
mc
mei
mei_hdcp
mei_me
nls_iso8859_1
nvme
nvme_core
parport
parport_pc
ppdev
processor_thermal_device
rapl
rc_cec
rc_core
rfcomm
roles
sch_fq_codel
serio_raw
snd
snd_hda_codec
snd_hda_core
snd_hda_intel
snd_hwdep
snd_intel_dspcfg
snd_pcm
snd_rawmidi
snd_seq
snd_seq_device
snd_seq_midi
snd_seq_midi_event
snd_timer
soundcore
sparse_keymap
syscopyarea
sysfillrect
sysimgblt
typec
typec_ucsi
ucsi_acpi
usbhid
uvcvideo
video
videobuf2_common
videobuf2_memops
videobuf2_v4l2
videobuf2_vmalloc
videodev
virt_dma
wmi
wmi_bmof
x86_pkg_temp_thermal
x_tables
xhci_pci
xhci_pci_renesas

!!ALSA/HDA dmesg
!!--------------

[ 0.181497] ACPI: Added _OSI(Linux-Dell-Video)
[ 0.181499] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
[ 0.181500] ACPI: Added _OSI(Linux-HPI-Hybrid-Graphics)
--
[ 3.912483] Bluetooth: SCO socket layer initialized
[ 3.923755] snd_hda_intel 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
[ 3.923763] snd_hda_intel 0000:00:1f.3: Digital mics found on Skylake platform, using SST driver
[ 3.945903] usbcore: registered new interface driver btusb
--
[ 4.704755] WARNING: CPU: 3 PID: 189 at kernel/kmod.c:137 __request_module 0x22d/0x3b0
[ 4.704756] Modules linked in: uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 videobuf2_common videodev mc usbhid intel_xhci_usb_role_switch roles btusb btrtl btbcm btintel snd_hda_intel bluetooth snd_intel_dspcfg mei_hdcp ecdh_generic ecc intel_rapl_msr snd_hda_codec snd_hda_core snd_hwdep x86_pkg_temp_thermal intel_powerclamp coretemp kvm_intel snd_pcm kvm crct10dif_pclmul iwlmvm ghash_clmulni_intel aesni_intel snd_seq_midi mac80211 joydev crypto_simd snd_seq_midi_event cryptd glue_helper libarc4 rapl snd_rawmidi i915 snd_seq snd_seq_device snd_timer intel_cstate iwlwifi intel_wmi_thunderbolt drm_kms_helper input_leds serio_raw cec hid_multitouch cfg80211 acer_wmi snd rc_core efi_pstore wmi_bmof i2c_algo_bit fb_sys_fops sparse_keymap processor_thermal_device mei_me syscopyarea sysfillrect mei sysimgblt soundcore intel_rapl_common ucsi_acpi intel_soc_dts_iosf typec_ucsi typec intel_pch_thermal acer_wireless acpi_pad int3400_thermal acpi_thermal_rel mac_hid int3403_thermal
[ 4.704804] int340x_thermal_zone sch_fq_codel parport_pc ppdev lp parport drm ip_tables x_tables autofs4 hid_generic crc32_pclmul i2c_i801 intel_lpss_pci i2c_smbus nvme intel_lpss i2c_hid idma64 xhci_pci nvme_core xhci_pci_renesas virt_dma hid wmi video
--
[ 14.221728] kauditd_printk_skb: 43 callbacks suppressed
[ 14.221731] audit: type=1400 audit(1618312080.847:55): apparmor="DENIED" operation="open" profile="snap.pulseaudio.pulseaudio" name="/etc/pulse/daemon.conf" pid=1329 comm="pulseaudio" requested_mask="r" denied_mask="r" fsuid=0 ouid=0
[ 14.257933] audit: type=1400 audit(1618312080.883:56): apparmor="DENIED" operation="open" profile="snap.pulseaudio.pulseaudio" name="/sys/devices/virtual/dmi/id/board_vendor" pid=1329 comm="pulseaudio" requested_mask="r" denied_mask="r" fsuid=0 ouid=0
[ 24.123222] rfkill: input handler enabled

!!Packages installed
!!--------------------

ii alsa-oss 1.1.8-1 amd64 ALSA wrapper for OSS applications
ii alsa-tools 1.1.7-1ubuntu1 amd64 Console based ALSA utilities for specific hardware
ii alsa-tools-gui 1.1.7-1ubuntu1 amd64 GUI based ALSA utilities for specific hardware
ii alsa-topology-conf 1.2.2-1 all ALSA topology configuration files
ii alsa-ucm-conf 1.2.2-1ubuntu0.6 all ALSA Use Case Manager configuration files
ii alsa-utils 1.2.2-1ubuntu2 amd64 Utilities for configuring and using ALSA

How are you outputting sound?
Have you check the volume levels?
Do you get sound in headphones?

Bernard Stafford (bernard010) said : #3

"No soundcards found..."
Try installing Pulse Audio Volume Control : sudo apt-get install pavucontrol
In the Sound Tab configuration Select the profile for the soundcard.
Check Ubuntu sound card settings, In the system settings. Make sure the speakers are not muted.
Try and play music.

GreenLeaf (drmac) said : #4

Thanks for the response.
Sound outputted - usually via headphones
Check volume - done, on Sound Setting (Output bar changes indicating sound but nothing heard), pavucontrol, and alsamixer, all volume set high.
alsamixer shows the following: Card: HDA Intel PCH, and Chip: Realtek ALC1220

No sound on head phones or speaker ( plugs into same audio socket, on front and back)
No sound card added to my system, simply rely on motherboard & CPU

I play music (Rythmbox) and use you-tube (Firefox) for testing, nether now work and previously did.

Thanks, any other suggestions?

Can you help with this problem?

Provide an answer of your own, or ask Behzad Azarhoushang for more information if necessary.

To post a message you must log in.