soundTS

Asked by Mobarak Algahtany on 2021-03-29

!!################################
!!ALSA Information Script v 0.5.0
!!################################

!!Script ran on: Mon Mar 29 23:41:49 UTC 2021

!!Linux Distribution
!!------------------

Ubuntu 20.04.2 LTS \n \l DISTRIB_ID=Ubuntu DISTRIB_DESCRIPTION="Ubuntu 20.04.2 LTS" NAME="Ubuntu" ID=ubuntu ID_LIKE=debian PRETTY_NAME="Ubuntu 20.04.2 LTS" HOME_URL="https://www.ubuntu.com/" SUPPORT_URL="https://help.ubuntu.com/" BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/" PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy" UBUNTU_CODENAME=focal

!!DMI Information
!!---------------

Manufacturer: Microsoft Corporation
Product Name: Virtual Machine
Product Version: Hyper-V UEFI Release v4.0
Firmware Version: Hyper-V UEFI Release v4.0
System SKU: None
Board Vendor: Microsoft Corporation
Board Name: Virtual Machine

!!ACPI Device Status Information
!!---------------

/sys/bus/acpi/devices/ACPI0007:00/status 15
/sys/bus/acpi/devices/ACPI0007:01/status 15
/sys/bus/acpi/devices/ACPI0007:02/status 15
/sys/bus/acpi/devices/ACPI0007:03/status 15
/sys/bus/acpi/devices/ACPI0007:04/status 15
/sys/bus/acpi/devices/ACPI0007:05/status 15
/sys/bus/acpi/devices/VMBUS:00/status 15

!!Kernel Information
!!------------------

Kernel release: 5.8.0-48-generic
Operating System: GNU/Linux
Architecture: x86_64
Processor: x86_64
SMP Enabled: Yes

!!ALSA Version
!!------------

Driver version:
Library version: 1.2.2
Utilities version: 1.2.2

!!Loaded ALSA modules
!!-------------------

!!Sound Servers on this system
!!----------------------------

Pulseaudio:
      Installed - Yes (/bin/pulseaudio)
      Running - Yes

!!Soundcards recognised by ALSA
!!-----------------------------

!!PCI Soundcards installed in the system
!!--------------------------------------

!!Modprobe options (Sound related)
!!--------------------------------

snd_pcsp: index=-2
snd_usb_audio: index=-2
snd_atiixp_modem: index=-2
snd_intel8x0m: index=-2
snd_via82xx_modem: index=-2
snd_atiixp_modem: index=-2
snd_intel8x0m: index=-2
snd_via82xx_modem: index=-2
snd_usb_audio: index=-2
snd_usb_caiaq: index=-2
snd_usb_ua101: index=-2
snd_usb_us122l: index=-2
snd_usb_usx2y: index=-2
snd_cmipci: mpu_port=0x330 fm_port=0x388
snd_pcsp: index=-2
snd_usb_audio: index=-2

!!Loaded sound module options
!!---------------------------

!!Sysfs card info
!!---------------

!!Card: /sys/class/sound/card*
Driver:
Tree:

!!ALSA Device nodes
!!-----------------

crw-rw---- 1 root audio 116, 1 Mar 30 02:40 /dev/snd/seq
crw-rw---- 1 root audio 116, 33 Mar 30 02:40 /dev/snd/timer

!!Aplay/Arecord output
!!--------------------

APLAY

aplay: device_list:274: no soundcards found...

ARECORD

arecord: device_list:274: no soundcards found...

!!Amixer output
!!-------------

!!Alsactl output
!!--------------

--startcollapse--
--endcollapse--

!!All Loaded Modules
!!------------------

aesni_intel
autofs4
crc32_pclmul
crct10dif_pclmul
cryptd
crypto_simd
drm
efi_pstore
ghash_clmulni_intel
glue_helper
hid
hid_generic
hid_hyperv
hv_balloon
hv_netvsc
hv_sock
hv_storvsc
hv_utils
hv_vmbus
hyperv_fb
hyperv_keyboard
intel_rapl_common
intel_rapl_msr
ip_tables
joydev
lp
mac_hid
nls_iso8859_1
parport
parport_pc
ppdev
rapl
sch_fq_codel
scsi_transport_fc
serio_raw
vsock
x_tables

!!ALSA/HDA dmesg
!!--------------

[ 0.053550] ACPI: Added _OSI(Linux-Dell-Video)
[ 0.053551] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
[ 0.053551] ACPI: Added _OSI(Linux-HPI-Hybrid-Graphics)

!!Packages installed
!!--------------------

ii alsa-topology-conf 1.2.2-1 all ALSA topology configuration files
ii alsa-ucm-conf 1.2.2-1ubuntu0.5 all ALSA Use Case Manager configuration files
ii alsa-utils 1.2.2-1ubuntu2 amd64 Utilities for configuring and using ALSA

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Last query:
2021-03-29
Last reply:
2021-03-30
Manfred Hampl (m-hampl) said : #1

You might be missing the linux-modules-extra-5.8.0-48-generic package

What is the output of the command

dpkg -l | grep ' linux-'

!!ALSA Version
!!------------

Driver version:
Library version: 1.2.2
Utilities version: 1.2.2

!!Loaded ALSA modules

No alsa driver version

Can you help with this problem?

Provide an answer of your own, or ask Mobarak Algahtany for more information if necessary.

To post a message you must log in.