No sound after 20.04.1 install

Asked by Claude Laroche on 2020-10-10

Hi. I’m new comer in Unbuntu (First post)
No sound after Ubuntu 20.04.01 LTS installation
Material context:
 mini-PC CPU: Intel Core i7-7700T @2.9 GHz
Chipset : Intel H170
Windows 10 Pro 64 bit
Ubuntu 20.04.1 LTS freshly installed in a VMware Workstation 15 Player virtual machine.

Tried this:

1. clod@ubuntu:~$ lspci | grep -i audio
02:02.0 Multimedia audio controller: Ensoniq ES1371/ES1373 / Creative Labs CT2518 (rev 02)

2. clod@ubuntu:~$ cat /proc/asound/pcm
00-00: ES1371/1 : ES1371 DAC2/ADC : playback 1 : capture 1
00-01: ES1371/2 : ES1371 DAC1 : playback 1

3. Alsamixer result:
Carte: Ensoniq AudioPCI
Puce: Cirrus Logic CS4297A rev 3

4. sudo nano /etc/modprobe.d/alsa-base.conf
added line: options snd-hda-intel model=CS4297A rev 3

5. sudo alsa force-reload

6. Result:
Terminating processes: 12073
12073 40142
40142 42111
42111 44080
44080 (with SIGKILL:) 46184
46184 (failed: processes still using sound devices: 48284(pulseaudio)).
/sbin/alsa: Warning: Processes using sound devices: 48284(pulseaudio).
Unloading ALSA sound driver modules: snd-seq-midi snd-seq-midi-event snd-seq snd-ens1371 snd-ac97-codec snd-pcm snd-rawmidi snd-seq-device snd-timer (failed: modules still loaded: snd-ens1371 snd-ac97-codec snd-pcm snd-rawmidi snd-seq-device snd-timer).
Loading ALSA sound driver modules: snd-seq-midi snd-seq-midi-event snd-seq snd-ens1371 snd-ac97-codec snd-pcm snd-rawmidi snd-seq-device snd-timer.

Now I'm lost in all the similar posts ...

Thanks for granting me some tips.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Solved by:
Claude Laroche
Solved:
2020-10-12
Last query:
2020-10-12
Last reply:
2020-10-11
Bernard Stafford (bernard010) said : #1

In the upper right corner of the screen is a speaker icon click on it and turn up the volume. Go to Show applications at the bottom left on the Dock (bunch of dots in a square) Click -> Settings -> Click Scroll down settings to: Sound -> Click System Volume move slide bar and increase volume. Output Select whether your speakers have Built-in Amplifier or No Amplifier. Configuration -> Select from the drop up box your speaker configuration. Test Speakers - click on Test icon -> Click the test speaker icons. This will rule out all of the general settings.
Thanks

Daniel Letzeisen (dtl131) said : #2

"I added line: options snd-hda-intel model=CS4297A rev 3"

You should delete that. It is an invalid model keyword and the card VMWare emulates does not use snd-hda-intel anyway (it uses snd-ens1371).

Make sure volumes are turned up and unmuted when running alsamixer with command:
alsamixer

Low/muted volume seems to be the cause in "no sound in VMWare" google results.

Claude Laroche (clodlar) said : #3

Thanks bernard010 & dtl131

Powered up ALL volumes. No change

Deleted the added line "options snd-hda-intel model=CS4297A rev 3"
I added this line because alsamixer gave me this chip name

Now, as for my initial boot, I receive this msg:
Error opening sound device 0 :
A device ID has been used that is out of range for your system
sound will be disconnected

In sound settings, the only output is: analog – ES1371/1373/Creative Labs CT2518(Audio PCI 64V/128/5200/ Creative CT4810/CT5803/CT5806 [Sound Blaster PCI]

Claude Laroche (clodlar) said : #4

Eureka!

Found a way to play the sound. (Through the VMware menu) Oops.
Menu Player --> Removable devices --> Sound card --> check box connect (only place which is not grayed)
I guess I've been misoriented by the initial LINUX error message when connecting the VM machine.

For now on, I'll have to repeat this process untill I find a way to save this setting in VM

It's another topic I guess.

Any VM-Linux dud in the house?

Thanks.