no pulse audio sound after upgrade to ubuntu 20.04

Asked by Gene on 2020-10-05

ran the following:
 wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && chmod +x ./alsa-info.sh && ./alsa-info.sh
--2020-10-05 15:26:03-- http://www.alsa-project.org/alsa-info.sh
Resolving www.alsa-project.org (www.alsa-project.org)... 207.180.221.201
Connecting to www.alsa-project.org (www.alsa-project.org)|207.180.221.201|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://www.alsa-project.org/alsa-info.sh [following]
--2020-10-05 15:26:04-- https://www.alsa-project.org/alsa-info.sh
Connecting to www.alsa-project.org (www.alsa-project.org)|207.180.221.201|:443... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://git.alsa-project.org/?p=alsa-utils.git;a=blob_plain;f=alsa-info/alsa-info.sh [following]
--2020-10-05 15:26:04-- https://git.alsa-project.org/?p=alsa-utils.git;a=blob_plain;f=alsa-info/alsa-info.sh
Resolving git.alsa-project.org (git.alsa-project.org)... 207.180.221.201
Connecting to git.alsa-project.org (git.alsa-project.org)|207.180.221.201|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [application/x-sh]
Saving to: ‘alsa-info.sh’

alsa-info.sh [ <=> ] 26.10K --.-KB/s in 0.001s

2020-10-05 15:26:05 (33.9 MB/s) - ‘alsa-info.sh’ saved [26730]

ALSA Information Script v 0.4.65
--------------------------------

This script visits the following commands/files to collect diagnostic
information about your ALSA installation and sound related hardware.

  dmesg
  lspci
  aplay
  amixer
  alsactl
  rpm, dpkg
  /proc/asound/
  /sys/class/sound/
  ~/.asoundrc (etc.)

See './alsa-info.sh --help' for command line options.

Automatically upload ALSA information to www.alsa-project.org? [y/N] : y
Uploading information to www.alsa-project.org ... Done!

Your ALSA information is located at http://alsa-project.org/db/?f=0b15bb7bf3631549026c8b43166d4f39d549f2f1

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Solved by:
Gene
Solved:
2020-10-06
Last query:
2020-10-06
Last reply:
2020-10-06
Gene (gbelet) said : #1

Well, just discovered that if I switch my display from 4096x2160 to 3840x2160 sound is restored. I am going to check my linux mint install on the same machine and see if I am experiencing this.

Gene (gbelet) said : #2

Linux Mint 20 (with Ubuntu 20.04) has no issue with 4096x2160.

Manfred Hampl (m-hampl) said : #3

Manfred Hampl suggests this article as an answer to your question:
FAQ #3041: “No support for Linux Mint”.

Gene (gbelet) said : #4

Hi Manfred. My issue is not with Linux Mint 20 - Linux Mint works fine. The issue is with the 20.04 Ubuntu Upgrade from Ubuntu 18.04. Thank you for your response.

If you check the configuration for sound (run the same script) then you will be able to see where the difference is.

Gene (gbelet) said : #6

The difference is the presence of the following under "Node 0x02 [Audio Output] wcaps 0x6611: 8-Channels Digital:":

Device: name="HDMI 1", type="HDMI", device=7

That line is not present in Linux Mint

I understand why that line originally existed - I used to use HDMI 1 port until I discovered that I can use DP 1.2 port and with an adapter get HDMI 2. Shouldn't Ubuntu 20.04 at least modify that during discovery during upgrade? Linux Mint install recognized the type of HDMI and configured without that line.

Well apparently I will need to modify manually. Where is that done since the pulseaudio file is not configurable? client.conf does not have that line.

(I also notice that if I toggle resolution between 4096x2061 and 3840x2160 the sound will begin to work in 4096x2160.

Gene (gbelet) said : #7

Okay. After some more digging I am finding ways to configure PulseAudio. For example:
https://unix.stackexchange.com/questions/111428/how-do-i-configure-pulseaudio-for-7-1-surround-sound-over-hdmi

I am closing this now. Thank you to those who contributed!