Microphone only picks up noise

Asked by Philip Evans on 2020-07-25

Hi,

I have recently installed Ubuntu 20.04 on my dell latitude 3410.

Unfortunately the sound card has given me a bit of trouble. The speakers are working through both internal speakers and headphones. However the internal mic doesn't seem to pickup anything but white noise. I have followed many suggestions before ending here, at step 3 of https://help.ubuntu.com/community/SoundTroubleshootingProcedure.

I tried changing my alsa base config (/etc/modprobe.d/alsa-base.conf) to each of these three settings:

- options snd-hda-intel model=laptop-amic
- options snd-hda-intel model=laptop-dmic
- option snd-hda-intel model=auto

Before this I had no input device detected, but it didn't fix the white noise issue. I also tried dropping the right side gain for the internal mic using the alsa-mixer, which dropped audio pickup including the white noise. I installed hdaJackRetask, but didn't have much success when trialling and testing new pin task configurations.

Here is my alsa config output - http://alsa-project.org/db/?f=5d37370525eb116a00da5ebcf958a4aad23b43e2

If you have any suggestions for me it would be greatly appreciated.

Cheers

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Last query:
2020-07-25
Last reply:
2020-08-09
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.