sound card does not work.

Asked by ABM Siddiqur Rahman on 2019-05-01

I run the following script and I got the following result.
wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && chmod +x ./alsa-info.sh && ./alsa-info.sh

--2019-05-01 23:32:56-- http://www.alsa-project.org/alsa-info.sh
Resolving www.alsa-project.org (www.alsa-project.org)... 207.180.221.201
Connecting to www.alsa-project.org (www.alsa-project.org)|207.180.221.201|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://www.alsa-project.org/alsa-info.sh [following]
--2019-05-01 23:32:57-- https://www.alsa-project.org/alsa-info.sh
Connecting to www.alsa-project.org (www.alsa-project.org)|207.180.221.201|:443... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://git.alsa-project.org/?p=alsa-utils.git;a=blob_plain;f=alsa-info/alsa-info.sh [following]
--2019-05-01 23:32:57-- https://git.alsa-project.org/?p=alsa-utils.git;a=blob_plain;f=alsa-info/alsa-info.sh
Resolving git.alsa-project.org (git.alsa-project.org)... 207.180.221.201
Connecting to git.alsa-project.org (git.alsa-project.org)|207.180.221.201|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [application/x-sh]
Saving to: ‘alsa-info.sh’

alsa-info.sh [ <=> ] 28,09K --.-KB/s in 0,06s

2019-05-01 23:32:58 (475 KB/s) - ‘alsa-info.sh’ saved [28768]

ALSA Information Script v 0.4.64
--------------------------------

This script visits the following commands/files to collect diagnostic
information about your ALSA installation and sound related hardware.

  dmesg
  lspci
  lsmod
  aplay
  amixer
  alsactl
  /proc/asound/
  /sys/class/sound/
  ~/.asoundrc (etc.)

See './alsa-info.sh --help' for command line options.

cat: /proc/asound/version: No such file or directory
cat: /proc/asound/cards: No such file or directory
cat: /proc/asound/modules: No such file or directory
ls: cannot access '/dev/snd/*': No such file or directory
grep: /proc/asound/cards: No such file or directory
alsactl: save_state:1595: No soundcards found...
cat: /tmp/alsa-info.YzxC46tciW/alsactl.tmp: No such file or directory
Automatically upload ALSA information to www.alsa-project.org? [y/N] : y
Uploading information to www.alsa-project.org ... Done!

Your ALSA information is located at http://alsa-project.org/db/?f=554c9f3e3070487145f1cdb7f7c25d731f95fd33

Please inform the person helping you.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Solved by:
ABM Siddiqur Rahman
Solved:
2019-05-03
Last query:
2019-05-03
Last reply:
2019-05-02

!!################################
!!ALSA Information Script v 0.4.64
!!################################

!!Script ran on: Wed May 1 21:32:58 UTC 2019

!!Linux Distribution
!!------------------

Ubuntu 18.04.2 LTS \n \l DISTRIB_ID=Ubuntu DISTRIB_DESCRIPTION="Ubuntu 18.04.2 LTS" NAME="Ubuntu" ID=ubuntu ID_LIKE=debian PRETTY_NAME="Ubuntu 18.04.2 LTS" HOME_URL="https://www.ubuntu.com/" SUPPORT_URL="https://help.ubuntu.com/" BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/" PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy" UBUNTU_CODENAME=bionic

!!DMI Information
!!---------------

Manufacturer: HP
Product Name: HP Pavilion Laptop 15-cs0xxx
Product Version: Type1ProductConfigId
Firmware Version: F.06
Board Vendor: HP
Board Name: 84BF

!!ACPI Device Status Information
!!---------------

/sys/bus/acpi/devices/ACPI0003:00/status 15
/sys/bus/acpi/devices/ACPI000C:00/status 15
/sys/bus/acpi/devices/ETD073E:00/status 15
/sys/bus/acpi/devices/HPQ6001:00/status 15
/sys/bus/acpi/devices/HPQ6007:00/status 15
/sys/bus/acpi/devices/HPQ8001:00/status 15
/sys/bus/acpi/devices/INT33A1:00/status 15
/sys/bus/acpi/devices/INT3400:00/status 15
/sys/bus/acpi/devices/INT3403:00/status 15
/sys/bus/acpi/devices/INT3403:01/status 15
/sys/bus/acpi/devices/INT340E:00/status 15
/sys/bus/acpi/devices/LNXPOWER:00/status 1
/sys/bus/acpi/devices/LNXVIDEO:01/status 15
/sys/bus/acpi/devices/MSFT0101:00/status 15
/sys/bus/acpi/devices/PNP0103:00/status 15
/sys/bus/acpi/devices/PNP0C02:00/status 3
/sys/bus/acpi/devices/PNP0C02:04/status 3
/sys/bus/acpi/devices/PNP0C09:00/status 15
/sys/bus/acpi/devices/PNP0C0A:00/status 31
/sys/bus/acpi/devices/PNP0C0C:00/status 15
/sys/bus/acpi/devices/PNP0C0F:00/status 9
/sys/bus/acpi/devices/PNP0C0F:01/status 9
/sys/bus/acpi/devices/PNP0C0F:02/status 9
/sys/bus/acpi/devices/PNP0C0F:03/status 9
/sys/bus/acpi/devices/PNP0C0F:04/status 9
/sys/bus/acpi/devices/PNP0C0F:05/status 9
/sys/bus/acpi/devices/PNP0C0F:06/status 9
/sys/bus/acpi/devices/PNP0C0F:07/status 9
/sys/bus/acpi/devices/device:17/status 15
/sys/bus/acpi/devices/device:21/status 15
/sys/bus/acpi/devices/device:22/status 15
/sys/bus/acpi/devices/device:25/status 15
/sys/bus/acpi/devices/device:26/status 15
/sys/bus/acpi/devices/device:29/status 15
/sys/bus/acpi/devices/device:2a/status 15
/sys/bus/acpi/devices/device:76/status 11

!!Kernel Information
!!------------------

Kernel release: 4.15.0-48-generic
Operating System: GNU/Linux
Architecture: x86_64
Processor: x86_64
SMP Enabled: Yes

!!ALSA Version
!!------------

Driver version:
Library version: 1.1.3
Utilities version: 1.1.3

!!Loaded ALSA modules
!!-------------------

!!Sound Servers on this system
!!----------------------------

Pulseaudio:
      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes

!!Soundcards recognised by ALSA
!!-----------------------------

!!PCI Soundcards installed in the system
!!--------------------------------------

00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)

!!Advanced information - PCI Vendor/Device/Subsystem ID's
!!-------------------------------------------------------

00:1f.3 0403: 8086:9d71 (rev 21) (prog-if 80)
 Subsystem: 103c:84bf

!!Modprobe options (Sound related)
!!--------------------------------

snd_pcsp: index=-2
snd_usb_audio: index=-2
snd_atiixp_modem: index=-2
snd_intel8x0m: index=-2
snd_via82xx_modem: index=-2
snd_atiixp_modem: index=-2
snd_intel8x0m: index=-2
snd_via82xx_modem: index=-2
snd_usb_audio: index=-2
snd_usb_caiaq: index=-2
snd_usb_ua101: index=-2
snd_usb_us122l: index=-2
snd_usb_usx2y: index=-2
snd_cmipci: mpu_port=0x330 fm_port=0x388
snd_pcsp: index=-2
snd_usb_audio: index=-2
snd_hda_intel: model=auto

!!Loaded sound module options
!!---------------------------

!!ALSA Device nodes
!!-----------------

!!Aplay/Arecord output
!!--------------------

APLAY

aplay: device_list:270: no soundcards found...

ARECORD

arecord: device_list:270: no soundcards found...

!!Amixer output
!!-------------

!!Alsactl output
!!--------------

--startcollapse--
--endcollapse--

!!All Loaded Modules
!!------------------

Module
btrfs
zstd_compress
xor
raid6_pq
ufs
qnx4
hfsplus
hfs
minix
ntfs
msdos
jfs
xfs
libcrc32c
rfcomm
nfs
lockd
grace
sunrpc
fscache
cmac
bnep
intel_rapl
x86_pkg_temp_thermal
intel_powerclamp
coretemp
wmi_bmof
kvm
hp_wmi
sparse_keymap
irqbypass
crct10dif_pclmul
crc32_pclmul
ghash_clmulni_intel
8821ce
pcbc
wl
aesni_intel
uvcvideo
aes_x86_64
crypto_simd
glue_helper
videobuf2_vmalloc
cryptd
videobuf2_memops
cfg80211
btusb
videobuf2_v4l2
btrtl
btbcm
btintel
videobuf2_core
intel_cstate
intel_rapl_perf
bluetooth
videodev
mei_me
serio_raw
joydev
input_leds
media
ecdh_generic
shpchp
processor_thermal_device
mei
intel_pch_thermal
intel_soc_dts_iosf
int3403_thermal
int340x_thermal_zone
nvidia_uvm
hp_accel
lis3lv02d
wmi
input_polldev
int3400_thermal
acpi_thermal_rel
hp_wireless
mac_hid
acpi_pad
sch_fq_codel
parport_pc
ppdev
lp
parport
ip_tables
x_tables
autofs4
nvidia_drm
nvidia_modeset
i915
nvidia
i2c_algo_bit
drm_kms_helper
syscopyarea
sysfillrect
sysimgblt
fb_sys_fops
psmouse
nvme
drm
r8169
ahci
nvme_core
ipmi_devintf
mii
ipmi_msghandler
libahci
video
hid_generic
usbhid
hid

!!ALSA/HDA dmesg
!!--------------

[ 0.048921] ACPI: Added _OSI(Linux-Dell-Video)
[ 0.048921] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
[ 0.048921] ACPI: Added _OSI(Linux-HPI-Hybrid-Graphics)
--
[ 3.820317] input: ST LIS3LV02DL Accelerometer as /devices/platform/lis3lv02d/input/input11
[ 3.820441] snd_hda_core: Unknown symbol snd_pcm_add_chmap_ctls (err 0)
[ 3.821395] media: Linux media interface: v0.10
[ 3.822078] snd_hda_core: Unknown symbol snd_sgbuf_get_chunk_size (err 0)
[ 3.822152] snd_hda_core: Unknown symbol snd_pcm_format_width (err 0)
[ 3.823372] mei_me 0000:00:16.0: enabling device (0004 -> 0006)

Do you get sound in headphones?

ABM Siddiqur Rahman (siddiqur) said : #3

no, headphones also not work.
 it was working before. I was trying to install Realtek sound card driver to get better sound and now there is no sound. I have seen this thread and follow all the steps but not get the sound.
https://answers.launchpad.net/ubuntu/+source/alsa-driver/+question/670449

ABM Siddiqur Rahman (siddiqur) said : #4

I have the following sound card, I tried 2 days and apply all the possible solution that I have found, but nothing works. I have the following sound card
00:1f.3 Audio device [0403]: Intel Corporation Sunrise Point-LP HD Audio [8086:9d71] (rev 21)
        Subsystem: Hewlett-Packard Company Sunrise Point-LP HD Audio [103c:84bf]
        Kernel modules: snd_hda_intel
00:1f.4 SMBus [0c05]: Intel Corporation Sunrise Point-LP SMBus [8086:9d23] (rev 21)

please help. I can't concentrate on my work, only for this.

Thanks.

ABM Siddiqur Rahman (siddiqur) said : #5

I also run the following script
cat /proc/asound/{version,cards,devices,hwdep,pcm,seq/clients}; ls -l /usr/share/pulseaudio/alsa-mixer/paths/; sudo rm /etc/asound.conf; sudo rm -r ~/.pulse ~/.asound* ;sudo rm ~/.pulse-cookie; sudo apt-get update; sudo apt-get install aptitude; sudo aptitude install paman gnome-alsamixer libasound2-plugins padevchooser libsdl1.2debian-pulseaudio; sudo lshw -short;ls -lart /dev/snd; find /lib/modules/`uname -r` | grep snd ;cat /dev/sndstat; lspci -nn; lsusb; sudo which alsactl; sudo fuser -v /dev/dsp /dev/snd/* ; dpkg -S bin/slmodemd; dmesg | egrep 'EMU|probe|emu|ALSA|alsa|ac97|udi|snd|ound|irmware'; sudo /etc/init.d/sl-modem-daemon status; sudo grep model /etc/modprobe.d/* ; sudo dmidecode|egrep 'anufact|roduct|erial|elease'; lsmod | egrep 'snd|usb|midi|udio'; pacmd list-sinks; aplay -l; sudo alsa force-reload; ubuntu-support-status ; sudo lshw -C sound

and I got this:

cat: /proc/asound/version: No such file or directory
cat: /proc/asound/cards: No such file or directory
cat: /proc/asound/devices: No such file or directory
cat: /proc/asound/hwdep: No such file or directory
cat: /proc/asound/pcm: No such file or directory
cat: /proc/asound/seq/clients: No such file or directory
total 172
-rw-r--r-- 1 root root 1415 gen 23 07:54 analog-input-aux.conf
-rw-r--r-- 1 root root 2056 gen 23 07:54 analog-input.conf
-rw-r--r-- 1 root root 5769 gen 23 07:54 analog-input.conf.common
-rw-r--r-- 1 root root 2185 gen 23 07:54 analog-input-dock-mic.conf
-rw-r--r-- 1 root root 1420 gen 23 07:54 analog-input-fm.conf
-rw-r--r-- 1 root root 2196 gen 23 07:54 analog-input-front-mic.conf
-rw-r--r-- 1 root root 2298 gen 23 07:54 analog-input-headphone-mic.conf
-rw-r--r-- 1 root root 2360 gen 23 07:54 analog-input-headset-mic.conf
-rw-r--r-- 1 root root 2797 gen 23 07:54 analog-input-internal-mic-always.conf
-rw-r--r-- 1 root root 3155 gen 23 07:54 analog-input-internal-mic.conf
-rw-r--r-- 1 root root 2569 gen 23 07:54 analog-input-linein.conf
-rw-r--r-- 1 root root 2758 gen 23 07:54 analog-input-mic.conf
-rw-r--r-- 1 root root 1330 gen 23 07:54 analog-input-mic.conf.common
-rw-r--r-- 1 root root 1457 gen 23 07:54 analog-input-mic-line.conf
-rw-r--r-- 1 root root 2185 gen 23 07:54 analog-input-rear-mic.conf
-rw-r--r-- 1 root root 1425 gen 23 07:54 analog-input-tvtuner.conf
-rw-r--r-- 1 root root 1385 gen 23 07:54 analog-input-video.conf
-rw-r--r-- 1 root root 1929 gen 23 07:54 analog-output.conf
-rw-r--r-- 1 root root 10609 gen 23 07:54 analog-output.conf.common
-rw-r--r-- 1 root root 2139 gen 23 07:54 analog-output-headphones-2.conf
-rw-r--r-- 1 root root 3147 gen 23 07:54 analog-output-headphones.conf
-rw-r--r-- 1 root root 4095 gen 23 07:54 analog-output-lineout.conf
-rw-r--r-- 1 root root 1993 gen 23 07:54 analog-output-mono.conf
-rw-r--r-- 1 root root 3725 gen 23 07:54 analog-output-speaker-always.conf
-rw-r--r-- 1 root root 4521 gen 23 07:54 analog-output-speaker.conf
-rw-r--r-- 1 root root 159 gen 23 07:54 hdmi-output-0.conf
-rw-r--r-- 1 root root 161 gen 23 07:54 hdmi-output-1.conf
-rw-r--r-- 1 root root 161 gen 23 07:54 hdmi-output-2.conf
-rw-r--r-- 1 root root 161 gen 23 07:54 hdmi-output-3.conf
-rw-r--r-- 1 root root 163 gen 23 07:54 hdmi-output-4.conf
-rw-r--r-- 1 root root 163 gen 23 07:54 hdmi-output-5.conf
-rw-r--r-- 1 root root 163 gen 23 07:54 hdmi-output-6.conf
-rw-r--r-- 1 root root 163 gen 23 07:54 hdmi-output-7.conf
-rw-r--r-- 1 root root 712 gen 23 07:54 iec958-stereo-output.conf
-rw-r--r-- 1 root root 1072 gen 23 07:54 steelseries-arctis-5-output-chat.conf
-rw-r--r-- 1 root root 1064 gen 23 07:54 steelseries-arctis-5-output-game.conf
-rw-r--r-- 1 root root 937 gen 23 07:54 steelseries-arctis-7-input.conf
-rw-r--r-- 1 root root 1209 gen 23 07:54 steelseries-arctis-7-output-mono.conf
-rw-r--r-- 1 root root 1299 gen 23 07:54 steelseries-arctis-7-output-stereo.conf
rm: cannot remove '/etc/asound.conf': No such file or directory
rm: cannot remove '/home/rahmans/.pulse': No such file or directory
rm: cannot remove '/home/rahmans/.asound*': No such file or directory
rm: cannot remove '/home/rahmans/.pulse-cookie': No such file or directory
Get:1 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]
Hit:2 http://ppa.launchpad.net/ondrej/php/ubuntu bionic InRelease
Hit:3 http://it.archive.ubuntu.com/ubuntu bionic InRelease
Hit:4 http://it.archive.ubuntu.com/ubuntu bionic-updates InRelease
Ign:5 https://repo.mongodb.org/apt/ubuntu bionic/mongodb-org/4.0 InRelease
Hit:6 https://dl.winehq.org/wine-builds/ubuntu bionic InRelease
Hit:7 http://ppa.launchpad.net/ubuntu-audio-dev/alsa-daily/ubuntu bionic InRelease
Hit:8 https://repo.mongodb.org/apt/ubuntu bionic/mongodb-org/4.0 Release
Get:9 http://it.archive.ubuntu.com/ubuntu bionic-backports InRelease [74,6 kB]
Hit:10 http://mariadb.mirror.liquidtelecom.com/repo/10.3/ubuntu bionic InRelease
Fetched 163 kB in 1s (174 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
aptitude is already the newest version (0.8.10-6ubuntu1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
No candidate version found for paman
Unable to apply some actions, aborting
H/W path Device Class Description
=================================================
                       system HP Pavilion Laptop 15-cs0xxx (4XW66EA#ABZ)
/0 bus 84BF
/0/0 memory 128KiB BIOS
/0/4 processor Intel(R) Core(TM) i7-8550U CPU @ 1.80GHz
/0/4/5 memory 256KiB L1 cache
/0/4/6 memory 1MiB L2 cache
/0/4/7 memory 8MiB L3 cache
/0/18 memory 8GiB System Memory
/0/18/0 memory 4GiB SODIMM DDR4 Synchronous Unbuffered (Unregistered) 2400 MHz (0,4 ns)
/0/18/1 memory 4GiB SODIMM DDR4 Synchronous Unbuffered (Unregistered) 2400 MHz (0,4 ns)
/0/100 bridge Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers
/0/100/2 display UHD Graphics 620
/0/100/4 generic Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem
/0/100/14 bus Sunrise Point-LP USB 3.0 xHCI Controller
/0/100/14/0 usb1 bus xHCI Host Controller
/0/100/14/0/1 input USB Receiver
/0/100/14/0/3 multimedia HP Wide Vision FHD Camera
/0/100/14/0/7 communication Bluetooth Radio
/0/100/14/1 usb2 bus xHCI Host Controller
/0/100/14.2 generic Sunrise Point-LP Thermal subsystem
/0/100/16 communication Sunrise Point-LP CSME HECI #1
/0/100/17 storage Sunrise Point-LP SATA Controller [AHCI mode]
/0/100/1c bridge Sunrise Point-LP PCI Express Root Port #1
/0/100/1c/0 display GP108M [GeForce MX150]
/0/100/1c.4 bridge Sunrise Point-LP PCI Express Root Port #5
/0/100/1c.4/0 wlo1 network RTL8821CE 802.11ac PCIe Wireless Network Adapter
/0/100/1c.5 bridge Sunrise Point-LP PCI Express Root Port #6
/0/100/1c.5/0 eno1 network RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
/0/100/1d bridge Sunrise Point-LP PCI Express Root Port #9
/0/100/1d/0 storage Toshiba America Info Systems
/0/100/1f bridge Intel(R) 100 Series Chipset Family LPC Controller/eSPI Controller - 9D4E
/0/100/1f.2 memory Memory controller
/0/100/1f.3 multimedia Sunrise Point-LP HD Audio
/0/100/1f.4 bus Sunrise Point-LP SMBus
/1 power HT03041
/2 power OEM Define 5
ls: cannot access '/dev/snd': No such file or directory
/lib/modules/4.15.0-48-generic/updates/dkms/snd-hda-codec-ca0110.ko
/lib/modules/4.15.0-48-generic/updates/dkms/snd-hda-codec-hdmi.ko
/lib/modules/4.15.0-48-generic/updates/dkms/snd-hda-codec.ko
/lib/modules/4.15.0-48-generic/updates/dkms/snd-hda-codec-generic.ko
/lib/modules/4.15.0-48-generic/updates/dkms/snd-hda-codec-ca0132.ko
/lib/modules/4.15.0-48-generic/updates/dkms/snd-hda-codec-cmedia.ko
/lib/modules/4.15.0-48-generic/updates/dkms/snd-hda-codec-cirrus.ko
/lib/modules/4.15.0-48-generic/updates/dkms/snd-hda-intel.ko
/lib/modules/4.15.0-48-generic/updates/dkms/snd-hda-codec-si3054.ko
/lib/modules/4.15.0-48-generic/updates/dkms/snd-hda-codec-conexant.ko
/lib/modules/4.15.0-48-generic/updates/dkms/snd-hda-codec-analog.ko
/lib/modules/4.15.0-48-generic/updates/dkms/snd-hda-ext-core.ko
/lib/modules/4.15.0-48-generic/updates/dkms/snd-hda-core.ko
/lib/modules/4.15.0-48-generic/updates/dkms/snd-hda-codec-realtek.ko
/lib/modules/4.15.0-48-generic/updates/dkms/snd-hda-codec-via.ko
/lib/modules/4.15.0-48-generic/updates/dkms/snd-hda-codec-idt.ko
cat: /dev/sndstat: No such file or directory
00:00.0 Host bridge [0600]: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers [8086:5914] (rev 08)
00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 620 [8086:5917] (rev 07)
00:04.0 Signal processing controller [1180]: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem [8086:1903] (rev 08)
00:14.0 USB controller [0c03]: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller [8086:9d2f] (rev 21)
00:14.2 Signal processing controller [1180]: Intel Corporation Sunrise Point-LP Thermal subsystem [8086:9d31] (rev 21)
00:16.0 Communication controller [0780]: Intel Corporation Sunrise Point-LP CSME HECI #1 [8086:9d3a] (rev 21)
00:17.0 SATA controller [0106]: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] [8086:9d03] (rev 21)
00:1c.0 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port #1 [8086:9d10] (rev f1)
00:1c.4 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 [8086:9d14] (rev f1)
00:1c.5 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port #6 [8086:9d15] (rev f1)
00:1d.0 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port #9 [8086:9d18] (rev f1)
00:1f.0 ISA bridge [0601]: Intel Corporation Intel(R) 100 Series Chipset Family LPC Controller/eSPI Controller - 9D4E [8086:9d4e] (rev 21)
00:1f.2 Memory controller [0580]: Intel Corporation Sunrise Point-LP PMC [8086:9d21] (rev 21)
00:1f.3 Audio device [0403]: Intel Corporation Sunrise Point-LP HD Audio [8086:9d71] (rev 21)
00:1f.4 SMBus [0c05]: Intel Corporation Sunrise Point-LP SMBus [8086:9d23] (rev 21)
01:00.0 3D controller [0302]: NVIDIA Corporation GP108M [GeForce MX150] [10de:1d10] (rev a1)
02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter [10ec:c821]
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
04:00.0 Non-Volatile memory controller [0108]: Toshiba America Info Systems Device [1179:0113] (rev 01)
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0bda:b00a Realtek Semiconductor Corp.
Bus 001 Device 003: ID 04f2:b634 Chicony Electronics Co., Ltd
Bus 001 Device 002: ID 046d:c52e Logitech, Inc. MK260 Wireless Combo Receiver
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
/usr/sbin/alsactl
Specified filename /dev/dsp does not exist.
Specified filename /dev/snd/* does not exist.
dpkg-query: no path found matching pattern *bin/slmodemd*
[ 0.000000] x86/fpu: Supporting XSAVE feature 0x008: 'MPX bounds registers'
[ 0.000000] found SMP MP-table at [mem 0x000fe1b0-0x000fe1bf] mapped at [ (ptrval)]
[ 0.000000] No NUMA configuration found
[ 0.028000] Spectre V2 : Enabling Restricted Speculation for firmware calls
[ 0.040477] audit: initializing netlink subsys (disabled)
[ 0.040477] audit: type=2000 audit(1556879775.040:1): state=initialized audit_enabled=0 res=1
[ 0.040829] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
[ 0.055253] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[ 0.342317] pnp: PnP ACPI: found 8 devices
[ 0.956061] [Firmware Bug]: Invalid critical threshold (0)
[ 1.057873] libphy: Fixed MDIO Bus: probed
[ 1.059615] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[ 1.059808] hub 1-0:1.0: USB hub found
[ 1.062125] usb usb2: New USB device found, idVendor=1d6b, idProduct=0003
[ 1.062309] hub 2-0:1.0: USB hub found
[ 1.159098] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 1.177548] x86/mm: Checked W+X mappings: passed, no W+X pages found.
[ 1.181843] x86/mm: Checked W+X mappings: passed, no W+X pages found.
[ 1.282960] [drm] Finished loading DMC firmware i915/kbl_dmc_ver1_01.bin (v1.1)
[ 1.303091] [Firmware Bug]: ACPI(PXSX) defines _DOD but not _DOS
[ 1.547059] usb 1-1: New USB device found, idVendor=046d, idProduct=c52e
[ 1.837847] psmouse serio1: elantech: assuming hardware version 4 (with firmware version 0x4d5f02)
[ 1.867726] usb 1-3: New USB device found, idVendor=04f2, idProduct=b634
[ 2.145326] usb 1-7: New USB device found, idVendor=0bda, idProduct=b00a
[ 3.059329] systemd[1]: Listening on Journal Audit Socket.
[ 3.080327] lp: driver loaded but no devices found
[ 3.188304] wmi_bus wmi_bus-PNP0C14:00: WQ data block query control method not found
[ 3.188306] wmi_bus wmi_bus-PNP0C14:00: WQ data block query control method not found
[ 3.188307] wmi_bus wmi_bus-PNP0C14:00: WQ data block query control method not found
[ 3.188309] wmi_bus wmi_bus-PNP0C14:00: WQ data block query control method not found
[ 3.190221] wmi_bus wmi_bus-PNP0C14:01: WQBC data block query control method not found
[ 3.190244] wmi_bus wmi_bus-PNP0C14:01: WQBJ data block query control method not found
[ 3.209292] lis3lv02d: 8 bits 3DC sensor found
[ 3.237150] snd_hda_core: Unknown symbol snd_pcm_add_chmap_ctls (err 0)
[ 3.238627] snd_hda_core: Unknown symbol snd_sgbuf_get_chunk_size (err 0)
[ 3.238727] snd_hda_core: Unknown symbol snd_pcm_format_width (err 0)
[ 3.261142] ACPI Warning: \_SB.PCI0.RP01.PXSX._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170831/nsarguments-100)
[ 3.295667] Bluetooth: hci0: rtl: assuming no firmware upload needed
[ 3.303271] uvcvideo: Found UVC 1.50 device HP Wide Vision FHD Camera (04f2:b634)
[ 3.309329] uvcvideo: Found UVC 1.50 device HP Wide Vision FHD Camera (04f2:b634)
[ 3.410886] intel_rapl: Found RAPL domain package
[ 3.410888] intel_rapl: Found RAPL domain core
[ 3.410889] intel_rapl: Found RAPL domain uncore
[ 3.410890] intel_rapl: Found RAPL domain dram
[ 3.691934] audit: type=1400 audit(1556879779.025:2): apparmor="STATUS" operation="profile_load" profile="unconfined" name="libreoffice-xpdfimport" pid=767 comm="apparmor_parser"
[ 3.691949] audit: type=1400 audit(1556879779.025:3): apparmor="STATUS" operation="profile_load" profile="unconfined" name="libreoffice-senddoc" pid=765 comm="apparmor_parser"
[ 3.692196] audit: type=1400 audit(1556879779.029:4): apparmor="STATUS" operation="profile_load" profile="unconfined" name="libreoffice-oopslash" pid=764 comm="apparmor_parser"
[ 3.692572] audit: type=1400 audit(1556879779.029:5): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/bin/man" pid=763 comm="apparmor_parser"
[ 3.692575] audit: type=1400 audit(1556879779.029:6): apparmor="STATUS" operation="profile_load" profile="unconfined" name="man_filter" pid=763 comm="apparmor_parser"
[ 3.692577] audit: type=1400 audit(1556879779.029:7): apparmor="STATUS" operation="profile_load" profile="unconfined" name="man_groff" pid=763 comm="apparmor_parser"
[ 3.693704] audit: type=1400 audit(1556879779.029:8): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/cups-browsed" pid=769 comm="apparmor_parser"
[ 3.695095] audit: type=1400 audit(1556879779.029:9): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/sbin/dhclient" pid=760 comm="apparmor_parser"
[ 3.695097] audit: type=1400 audit(1556879779.029:10): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=760 comm="apparmor_parser"
sudo: /etc/init.d/sl-modem-daemon: command not found
        Release Date: 11/02/2018
        Manufacturer: HP
        Product Name: HP Pavilion Laptop 15-cs0xxx
        Version: Type1ProductConfigId
        Serial Number: 5CD8523J08
        Manufacturer: HP
        Product Name: 84BF
        Serial Number: PHJUQ038JBP133
        Manufacturer: HP
        Serial Number: Chassis Serial Number
        Manufacturer: Intel(R) Corporation
        Serial Number: To Be Filled By O.E.M.
        Manufacturer: Samsung
        Serial Number: 94A1F8FE
        Manufacturer: Samsung
        Serial Number: 94A1F904
        Manufacturer: 333-54-5D-A
        Manufacture Date: ManufDate
        Serial Number: DummySerialNumber
        Manufacturer: OEM Define 2
        Serial Number: OEM Define 3
btusb 45056 0
btrtl 16384 1 btusb
btbcm 16384 1 btusb
btintel 16384 1 btusb
bluetooth 548864 43 btrtl,btintel,btbcm,bnep,btusb,rfcomm
usbhid 49152 0
hid 118784 2 usbhid,hid_generic
1 sink(s) available.
  * index: 0
        name: <auto_null>
        driver: <module-null-sink.c>
        flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
        state: SUSPENDED
        suspend cause: IDLE
        priority: 1000
        volume: front-left: 65536 / 100% / 0,00 dB, front-right: 65536 / 100% / 0,00 dB
                balance 0,00
        base volume: 65536 / 100% / 0,00 dB
        volume steps: 65537
        muted: no
        current latency: 0,00 ms
        max request: 344 KiB
        max rewind: 344 KiB
        monitor source: 0
        sample spec: s16le 2ch 44100Hz
        channel map: front-left,front-right
                     Stereo
        used by: 0
        linked by: 0
        configured latency: 0,00 ms; range is 0,50 .. 2000,00 ms
        module: 14
        properties:
                device.description = "Dummy Output"
                device.class = "abstract"
                device.icon_name = "audio-card"
aplay: device_list:270: no soundcards found...
Unloading ALSA sound driver modules: (none loaded).
Loading ALSA sound driver modules: (none to reload).
Support status summary of 'rahmans':

You have 1929 packages (66.2%) supported until aprile 2023 (Canonical - 5y)
You have 878 packages (30.1%) supported until aprile 2021 (Community - 3y)
You have 2 packages (0.1%) supported until aprile 2021 (Canonical - 3y)

You have 0 packages (0.0%) that can not/no-longer be downloaded
You have 107 packages (3.7%) that are unsupported

Run with --show-unsupported, --show-supported or --show-all to see more details
  *-usb:1
       description: Video
       product: HP Wide Vision FHD Camera
       vendor: Chicony Electronics Co.,Ltd.
       physical id: 3
       bus info: usb@1:3
       version: 0.12
       serial: 1
       capabilities: usb-2.01
       configuration: driver=uvcvideo maxpower=500mA speed=480Mbit/s
  *-multimedia UNCLAIMED
       description: Audio device
       product: Sunrise Point-LP HD Audio
       vendor: Intel Corporation
       physical id: 1f.3
       bus info: pci@0000:00:1f.3
       version: 21
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list
       configuration: latency=32
       resources: memory:b4328000-b432bfff memory:b4310000-b431ffff

ABM Siddiqur Rahman (siddiqur) said : #6

I fixed it. .....

I was trying to install Alsa and pulse audio both but my sound backend support Phonon GStreamer. when I try to install Realtek, I install alsa and while fixing the sound card I also install pulse. both are creating problems. I take out all the package of alsa and pulsa and Phonon GStreamer was already installed so now it works perfectly.

I