Suddenly no audio (dummy output only) on Ubuntu 16

Asked by Simone on 2018-11-20

This morning I came to work and my audio was gone on my machine. I run Ubuntu 16. Under the volume control I only have dummy-output. I followed the instructions here(https://help.ubuntu.com/community/SoundTroubleshootingProcedure), but could not fix the issue. I spent the day looking online for solution, but everything has failed. As a last resort I am looking for help here....

This is the output from alsa-info.sh

/usr/sbin/alsactl: save_state:1595: No soundcards found...
cat: /tmp/alsa-info.FzwPfgOpf5/alsactl.tmp: No such file or directory
upload=true&script=true&cardinfo=
!!################################
!!ALSA Information Script v 0.4.64
!!################################

!!Script ran on: Tue Nov 20 22:17:22 UTC 2018

!!Linux Distribution
!!------------------

Ubuntu 16.04.5 LTS \n \l DISTRIB_ID=Ubuntu DISTRIB_DESCRIPTION="Ubuntu 16.04.5 LTS" NAME="Ubuntu" ID=ubuntu ID_LIKE=debian PRETTY_NAME="Ubuntu 16.04.5 LTS" HOME_URL="http://www.ubuntu.com/" SUPPORT_URL="http://help.ubuntu.com/" BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/" UBUNTU_CODENAME=xenial

!!DMI Information
!!---------------

Manufacturer: Micro-Star International Co., Ltd.
Product Name: GS65 Stealth Thin 8RF
Product Version: REV:1.0
Firmware Version: E16Q2IMS.10D
Board Vendor: Micro-Star International Co., Ltd.
Board Name: MS-16Q2

!!ACPI Device Status Information
!!---------------

/sys/bus/acpi/devices/ACPI000C:00/status 15
/sys/bus/acpi/devices/ENE0110:00/status 15
/sys/bus/acpi/devices/INT33A1:00/status 15
/sys/bus/acpi/devices/INT340E:00/status 15
/sys/bus/acpi/devices/INT3F0D:00/status 15
/sys/bus/acpi/devices/LNXPOWER:00/status 1
/sys/bus/acpi/devices/LNXPOWER:01/status 15
/sys/bus/acpi/devices/LNXPOWER:02/status 1
/sys/bus/acpi/devices/LNXPOWER:03/status 1
/sys/bus/acpi/devices/LNXPOWER:04/status 1
/sys/bus/acpi/devices/LNXPOWER:05/status 1
/sys/bus/acpi/devices/MSFT0101:00/status 15
/sys/bus/acpi/devices/MSI0007:00/status 15
/sys/bus/acpi/devices/PNP0103:00/status 15
/sys/bus/acpi/devices/PNP0C02:02/status 3
/sys/bus/acpi/devices/PNP0C02:04/status 3
/sys/bus/acpi/devices/PNP0C02:05/status 3
/sys/bus/acpi/devices/PNP0C04:00/status 31
/sys/bus/acpi/devices/PNP0C0A:00/status 31
/sys/bus/acpi/devices/PNP0C0C:00/status 15
/sys/bus/acpi/devices/PNP0C0E:00/status 11
/sys/bus/acpi/devices/PNP0C0F:00/status 11
/sys/bus/acpi/devices/PNP0C0F:01/status 11
/sys/bus/acpi/devices/PNP0C0F:02/status 11
/sys/bus/acpi/devices/PNP0C0F:03/status 11
/sys/bus/acpi/devices/PNP0C0F:04/status 11
/sys/bus/acpi/devices/PNP0C0F:05/status 11
/sys/bus/acpi/devices/PNP0C0F:06/status 11
/sys/bus/acpi/devices/PNP0C0F:07/status 11
/sys/bus/acpi/devices/PRP00001:00/status 11
/sys/bus/acpi/devices/SYN150D:00/status 15

!!Kernel Information
!!------------------

Kernel release: 4.15.0-39-generic
Operating System: GNU/Linux
Architecture: x86_64
Processor: x86_64
SMP Enabled: Yes

!!ALSA Version
!!------------

Driver version: k4.15.0-39-generic
Library version: 1.1.0
Utilities version: 1.1.0

!!Loaded ALSA modules
!!-------------------

!!Sound Servers on this system
!!----------------------------

Pulseaudio:
      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes

!!Soundcards recognised by ALSA
!!-----------------------------

--- no soundcards ---

!!PCI Soundcards installed in the system
!!--------------------------------------

00:1f.3 Audio device: Intel Corporation Device a348 (rev 10)

!!Advanced information - PCI Vendor/Device/Subsystem ID's
!!-------------------------------------------------------

00:1f.3 0403: 8086:a348 (rev 10)
 DeviceName: Onboard - Sound

!!Modprobe options (Sound related)
!!--------------------------------

snd_pcsp: index=-2
snd_usb_audio: index=-2
snd_atiixp_modem: index=-2
snd_intel8x0m: index=-2
snd_via82xx_modem: index=-2
snd_atiixp_modem: index=-2
snd_intel8x0m: index=-2
snd_via82xx_modem: index=-2
snd_usb_audio: index=-2
snd_usb_caiaq: index=-2
snd_usb_ua101: index=-2
snd_usb_us122l: index=-2
snd_usb_usx2y: index=-2
snd_cmipci: mpu_port=0x330 fm_port=0x388
snd_pcsp: index=-2
snd_usb_audio: index=-2
snd_hda_intel: model=auto

!!Loaded sound module options
!!---------------------------

!!ALSA Device nodes
!!-----------------

crw-rw----+ 1 root audio 116, 1 Nov 20 17:16 /dev/snd/seq
crw-rw----+ 1 root audio 116, 33 Nov 20 17:16 /dev/snd/timer

!!Aplay/Arecord output
!!--------------------

APLAY

aplay: device_list:268: no soundcards found...

ARECORD

arecord: device_list:268: no soundcards found...

!!Amixer output
!!-------------

!!Alsactl output
!!--------------

--startcollapse--
--endcollapse--

!!All Loaded Modules
!!------------------

Module
snd_hda_intel
snd_hda_codec
snd_hda_core
snd_hwdep
snd_pcm
snd_seq_midi
snd_seq_midi_event
snd_rawmidi
snd_seq
snd_seq_device
snd_timer
snd
soundcore
rfcomm
ipt_MASQUERADE
nf_nat_masquerade_ipv4
nf_conntrack_netlink
nfnetlink
xfrm_user
xfrm_algo
iptable_nat
nf_nat_ipv4
br_netfilter
bridge
stp
llc
aufs
ccm
ip6t_REJECT
nf_reject_ipv6
nf_log_ipv6
xt_hl
ip6t_rt
bnep
nf_conntrack_ipv6
nf_defrag_ipv6
ipt_REJECT
nf_reject_ipv4
nf_log_ipv4
nf_log_common
xt_LOG
xt_recent
xt_limit
xt_tcpudp
xt_addrtype
wmi_bmof
intel_rapl
x86_pkg_temp_thermal
intel_powerclamp
coretemp
mxm_wmi
intel_wmi_thunderbolt
kvm_intel
msi_wmi
sparse_keymap
kvm
irqbypass
intel_cstate
arc4
iwlmvm
mac80211
intel_rapl_perf
uvcvideo
videobuf2_vmalloc
videobuf2_memops
videobuf2_v4l2
btusb
serio_raw
videobuf2_core
btrtl
iwlwifi
btbcm
videodev
btintel
input_leds
joydev
media
bluetooth
cfg80211
ecdh_generic
mei_me
i2c_i801
mei
shpchp
intel_pch_thermal
nf_conntrack_ipv4
nf_defrag_ipv4
xt_conntrack
acpi_pad
mac_hid
wmi
nvidia_uvm
ip6table_filter
ip6_tables
nf_conntrack_netbios_ns
nf_conntrack_broadcast
nf_nat_ftp
nf_nat
nf_conntrack_ftp
nf_conntrack
libcrc32c
iptable_filter
ip_tables
x_tables
parport_pc
ppdev
lp
parport
autofs4
algif_skcipher
af_alg
dm_crypt
hid_logitech_hidpp
hid_logitech_dj
hid_generic
usbhid
hid
i915
nvidia_drm
nvidia_modeset
crct10dif_pclmul
crc32_pclmul
ghash_clmulni_intel
nvidia
pcbc
i2c_algo_bit
drm_kms_helper
syscopyarea
aesni_intel
sysfillrect
aes_x86_64
sysimgblt
crypto_simd
nvme
fb_sys_fops
glue_helper
alx
cryptd
psmouse
mdio
nvme_core
drm
video

!!ALSA/HDA dmesg
!!--------------

[ 0.077793] ACPI: Added _OSI(Linux-Dell-Video)
[ 0.077793] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
[ 0.077793] ACPI: Added _OSI(Linux)
--
[ 29.979559] iwlwifi 0000:00:14.3: Detected Intel(R) Dual Band Wireless AC 9560, REV=0x318
[ 29.993153] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[ 29.998830] snd_hda_intel 0000:00:1f.3: Unknown capability 0
[ 30.035174] iwlwifi 0000:00:14.3: base HW address: 30:24:32:df:85:9f
[ 30.114601] snd_hda_intel 0000:00:1f.3: CORB reset timeout#1, CORBRP = 0
[ 30.115716] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
--
[ 30.115859] thermal thermal_zone2: failed to read out thermal zone (-61)
[ 30.116017] snd_hda_intel 0000:00:1f.3: no codecs found!
[ 31.236343] RAPL PMU: API unit is 2^-32 Joules, 5 fixed counters, 655360 ms ovfl timer
--
[ 97.688893] logitech-hidpp-device 0003:046D:1024.0013: HID++ 1.0 device connected.
[ 100.006052] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[ 100.012086] snd_hda_intel 0000:00:1f.3: Unknown capability 0
[ 100.120731] snd_hda_intel 0000:00:1f.3: CORB reset timeout#1, CORBRP = 0
[ 100.122279] snd_hda_intel 0000:00:1f.3: no codecs found!
[ 107.980404] wlo1: disconnect from AP 24:de:c6:a7:28:18 for new auth to 24:de:c6:a7:28:10

Any help would be greatly appreciated!!!!!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Solved by:
Simone
Solved:
2018-12-01
Last query:
2018-12-01
Last reply:
2018-11-21

You are using Ubuntu 16.04, not Ubuntu 16. Ubuntu 16 has never existed.

Do you get sound in headphones?

Lito (lito-eordes) said : #2

Same here with Ubuntu 18.04.1 and kernel 4.15.0-42-generic (lightdm and Unity).

Mainboard: ASUS Prime B360-PLUS
CPU: Intel Core i5-8600K

Error:

[lun nov 26 14:05:14 2018] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[lun nov 26 14:05:14 2018] snd_hda_intel 0000:00:1f.3: Unknown capability 0
[lun nov 26 14:05:14 2018] snd_hda_intel 0000:00:1f.3: CORB reset timeout#1, CORBRP = 0
[lun nov 26 14:05:14 2018] snd_hda_intel 0000:00:1f.3: no codecs found!

/etc/default/grub

GRUB_DISABLE_OS_PROBER=true
GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=1
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi=off --no-log"
GRUB_CMDLINE_LINUX=""

Tests with /etc/modprobe.d/intel.conf

options snd-hda-intel model=generic
options snd-hda-intel single_cmd=1
options snd-hda-intel probe_mask=1

$> inxi -Axx

Audio: Card-1 Intel Device a348 driver: snd_hda_intel bus-ID: 00:1f.3 chip-ID: 8086:a348
           Card-2 Logitech HD Pro Webcam C920 driver: USB Audio usb-ID: 001-004 chip-ID: 046d:082d
           Sound: Advanced Linux Sound Architecture v: k4.15.0-42-generic

Alsa Information debug (http://www.alsa-project.org/db/?f=ab989f4e5046b06ca768f9c6bde3e1375e5039a5)

!!################################
!!ALSA Information Script v 0.4.64
!!################################

!!Script ran on: Mon Nov 26 10:14:21 UTC 2018

!!Linux Distribution
!!------------------

Ubuntu 18.04.1 LTS \n \l DISTRIB_ID=Ubuntu DISTRIB_DESCRIPTION="Ubuntu 18.04.1 LTS" NAME="Ubuntu" ID=ubuntu ID_LIKE=debian PRETTY_NAME="Ubuntu 18.04.1 LTS" HOME_URL="https://www.ubuntu.com/" SUPPORT_URL="https://help.ubuntu.com/" BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/" PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy" UBUNTU_CODENAME=bionic

!!DMI Information
!!---------------

Manufacturer: System manufacturer
Product Name: System Product Name
Product Version: System Version
Firmware Version: 0904

!!Kernel Information
!!------------------

Kernel release: 4.15.0-42-generic
Operating System: GNU/Linux
Architecture: x86_64
Processor: x86_64
SMP Enabled: Yes

!!ALSA Version
!!------------

Driver version: k4.15.0-42-generic
Library version: 1.1.3
Utilities version: 1.1.3

!!Loaded ALSA modules
!!-------------------

snd_usb_audio

!!Sound Servers on this system
!!----------------------------

Pulseaudio:
      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes

!!Soundcards recognised by ALSA
!!-----------------------------

 1 [C170 ]: USB-Audio - Webcam C170
                      Webcam C170 at usb-0000:00:14.0-9, high speed

!!PCI Soundcards installed in the system
!!--------------------------------------

00:1f.3 Audio device: Intel Corporation Device a348 (rev 10)

!!Advanced information - PCI Vendor/Device/Subsystem ID's
!!-------------------------------------------------------

00:1f.3 0403: 8086:a348 (rev 10)
 Subsystem: 1043:86c7

!!Modprobe options (Sound related)
!!--------------------------------

snd_pcsp: index=-2
snd_usb_audio: index=-2
snd_atiixp_modem: index=-2
snd_intel8x0m: index=-2
snd_via82xx_modem: index=-2
snd_atiixp_modem: index=-2
snd_intel8x0m: index=-2
snd_via82xx_modem: index=-2
snd_usb_audio: index=-2
snd_usb_caiaq: index=-2
snd_usb_ua101: index=-2
snd_usb_us122l: index=-2
snd_usb_usx2y: index=-2
snd_cmipci: mpu_port=0x330 fm_port=0x388
snd_pcsp: index=-2
snd_usb_audio: index=-2

!!Loaded sound module options
!!---------------------------

!!Module: snd_usb_audio
 autoclock : Y
 device_setup : 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
 enable : Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y
 id : (null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)
 ignore_ctl_error : N
 index : -2,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
 pid : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
 quirk_alias : (null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)
 vid : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1

!!USB Mixer information
!!---------------------
--startcollapse--

USB Mixer: usb_id=0x046d082b, ctrlif=2, ctlerr=0
Card: Webcam C170 at usb-0000:00:14.0-9, high speed
--endcollapse--

!!ALSA Device nodes
!!-----------------

crw-rw---- 1 root audio 116, 2 Nov 26 10:34 /dev/snd/controlC1
crw-rw---- 1 root audio 116, 3 Nov 26 11:14 /dev/snd/pcmC1D0c
crw-rw---- 1 root audio 116, 1 Nov 26 10:34 /dev/snd/seq
crw-rw---- 1 root audio 116, 33 Nov 26 10:34 /dev/snd/timer

/dev/snd/by-id:
total 0
drwxr-xr-x 2 root root 60 Nov 26 10:34 .
drwxr-xr-x 4 root root 160 Nov 26 10:34 ..
lrwxrwxrwx 1 root root 12 Nov 26 10:34 usb-_Webcam_C170-02 -> ../controlC1

/dev/snd/by-path:
total 0
drwxr-xr-x 2 root root 60 Nov 26 10:34 .
drwxr-xr-x 4 root root 160 Nov 26 10:34 ..
lrwxrwxrwx 1 root root 12 Nov 26 10:34 pci-0000:00:14.0-usb-0:9:1.2 -> ../controlC1

!!Aplay/Arecord output
!!--------------------

APLAY

**** List of PLAYBACK Hardware Devices ****

ARECORD

**** List of CAPTURE Hardware Devices ****
card 1: C170 [Webcam C170], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

!!Amixer output
!!-------------

!!-------Mixer controls for card 1 [C170]

Card hw:1 'C170'/'Webcam C170 at usb-0000:00:14.0-9, high speed'
  Mixer name : 'USB Mixer'
  Components : 'USB046d:082b'
  Controls : 1
  Simple ctrls : 0

!!Alsactl output
!!--------------

--startcollapse--
state.C170 {
 control.1 {
  iface PCM
  name 'Capture Channel Map'
  value 0
  comment {
   access read
   type INTEGER
   count 1
   range '0 - 36'
  }
 }
}
--endcollapse--

!!All Loaded Modules
!!------------------

Module
pci_stub
vboxpci
vboxnetadp
vboxnetflt
vboxdrv
ir_rc6_decoder
rc_rc6_mce
ir_lirc_codec
lirc_dev
uvcvideo
videobuf2_vmalloc
videobuf2_memops
videobuf2_v4l2
videobuf2_core
snd_usb_audio
videodev
mceusb
rc_core
input_leds
media
snd_usbmidi_lib
snd_hda_intel
snd_hda_codec
snd_hda_core
snd_hwdep
snd_pcm
snd_seq_midi
snd_seq_midi_event
snd_rawmidi
snd_seq
snd_seq_device
snd_timer
intel_rapl
x86_pkg_temp_thermal
intel_powerclamp
coretemp
kvm
irqbypass
snd
crct10dif_pclmul
crc32_pclmul
ghash_clmulni_intel
pcbc
aesni_intel
aes_x86_64
crypto_simd
glue_helper
eeepc_wmi
cryptd
intel_cstate
asus_wmi
intel_rapl_perf
sparse_keymap
mei_me
wmi_bmof
soundcore
shpchp
mei
mac_hid
acpi_pad
sch_fq_codel
parport_pc
ppdev
lp
parport
ip_tables
x_tables
autofs4
raid10
raid456
async_raid6_recov
async_memcpy
async_pq
async_xor
async_tx
xor
raid6_pq
libcrc32c
raid1
raid0
multipath
linear
hid_generic
usbhid
hid
uas
usb_storage
i915
i2c_algo_bit
drm_kms_helper
syscopyarea
sysfillrect
sysimgblt
r8169
fb_sys_fops
mii
nvme
ahci
nvme_core
drm
libahci
wmi
video

!!ALSA/HDA dmesg
!!--------------

[ 0.040842] ACPI: Added _OSI(Linux-Dell-Video)
[ 0.040842] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
[ 0.045888] ACPI Error: [_SB_.PCI0.RP05.PXSX] Namespace lookup failure, AE_NOT_FOUND (20170831/dswload2-191)
--
[ 4.410650] intel_rapl: Found RAPL domain dram
[ 4.459111] snd_hda_core: loading out-of-tree module taints kernel.
[ 4.459142] snd_hda_core: module verification failed: signature and/or required key missing - tainting kernel
[ 4.463036] snd_hda_intel 0000:00:1f.3: Probing card using HDA DKMS, version 0.201808050301~ubuntu18.04.1
[ 4.463190] snd_hda_intel 0000:00:1f.3: Unknown capability 0
[ 4.467966] scsi 7:0:0:0: Direct-Access Generic- Compact Flash 1.00 PQ: 0 ANSI: 0 CCS
--
[ 4.540150] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: errors=remount-ro
[ 4.567006] snd_hda_intel 0000:00:1f.3: CORB reset timeout#1, CORBRP = 0
[ 4.567028] snd_hda_intel 0000:00:1f.3: no codecs found!
[ 4.653746] EXT4-fs (sdc1): mounted filesystem with ordered data mode. Opts: errors=remount-ro
--
[ 6.183056] Linux video capture interface: v2.00
[ 6.196316] usbcore: registered new interface driver snd-usb-audio
[ 6.198484] uvcvideo: Found UVC 1.00 device Webcam C170 (046d:082b)

Simone (airolds) said : #3

Hi @actionaprship, thank you for your reply. No I did not get sound on my headphones.