No sound on ubuntu 18.04 on lenovo ideapad 100s (11iby)

Asked by Giles Wakefield on 2018-08-03

I've just installed ubuntu 18.04 on a lenovo ideapad 100s (11iby). Everything works apart from the sound.

I'm a bit of a linux n00b, but I have 20 years experience as a software developer on windows, and have dabbled a bit with linux - including managing some linux-based firewall/VoIP boxes, and the command line doesn't scare me in the slightest. Obviously all of that is completely useless for this, but just trying to say I understand computers well, just not really the *nix world well... :)

I've tried to follow some of the steps here:
https://help.ubuntu.com/community/SoundTroubleshootingProcedure

The weird thing is, *some* of these steps appeared to work - that is, sound suddenly started working. Now I'm fairly sure that all I did was diagnostic stuff at first, so didn't really change anything. However, when I rebooted it went away again. I tried re-doing what I thought I'd done, but then it didn't help... further messing about with other steps then yielded the same result - suddenly came to life, but a reboot once again killed it.

The symptoms are simple: no sound, and absolutely no devices listed under Sound in settings. When it works, I have 5 devices listed here

this morning now, whilst writing this, it appears to have spontaneously come back to life again. All I've run today is the wget command to fetch the ALSA info, I don't believe I've tried to change anything. Could it be I just have to wait 5-10 minutes after boot or something? I'll reboot after I've posted this and post whether it's working.

The troubleshooting page doesn't appear to mention 18.04 much. That said, it did suggest in step 3 running a command to dump out a load of ALSA information and post a question here, so that is what I'm now doing. it says to copy the output report to this post, but the ALSA tool appears to now suggest uploading it for you and gives a link, so I'm adding that here - I assume this is ok?

http://www.alsa-project.org/db/?f=7dfc507283d3af0ff5be8b612a23a854baee4401

Any ideas? As I said above I'll reboot in a moment and wait half an hour or something and see what happens...

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Solved by:
Giles Wakefield
Solved:
2018-08-06
Last query:
2018-08-06
Last reply:
2018-08-03

Do you get sound in headphones?

Did you check sound levels in pavucontrol?

Hi.

Thanks for taking the time to respond.

I don't see ANY devices under Settings->Sounds->"Choose a device for sound output" when it's not working. When it decides to work (which doesn't seem to be consistently caused by anything) then I see 5 devices listed including HDMI, Analogue audio, and a couple of others.

I don't get any sound in headphones when it's not working on the laptop - I've not tried it when it IS working, though since the speakers are working at that point I assume they would.

pavucontrol when launched just gives an Error message (Which I've typed as I'm posting this reply on a different PC so may contain the odd typo):

"
Connection to PulseAudio failed. Automatic retry in 5s
In this case this is likely because PULSE_SERVER in the Environment/X11 Root Window Properties or default-server in client.conf is misconfigured.
This situation can also arrise when PulseAudio crashed and left stale details in the X11 Root Window. If this is the case, then PulseAudio should autospawn again, or if this is not configureed you should run start-pulseaudio-x11 manually.
"

I just tried to run "start-pulseaudio-x11" from terminal and I get:
"
Connection Failure: Connection Refused
pa_context_connect() failed: Connection Refused
"

"

As I stated in my first post it randomly started working for no apparent reason whilst I was writing the post. I rebooted it and sure enough it's not working again now.

I left it for about half an hour and still nothing, so I re-ran the wget command to get ALSA info, then also ran:
sudo alsa force-reload

And still nothing. This was all I did this morning before/during writing the post, so it seems to just be a bit random as to whether it works.

I could accept it working, or even working once I do a particular thing, but this weird random behaviour is baffling. :/

OK, since the last post, I simply locked the machine and closed the lid so it's gone into sleep mode. now, some 3 hours later, I just opened it up and logged back in and suddenly I have sound devices once more.

So I've now tested headphones, and these work - But I have to manually select the headphones as the audio output device (it doesn't detect and switch when I plug the headphones in. slightly inconvenient but not the end of the world.)

This is very strange.

It's frustrating because everything else is working ok - Wifi, touchpad, screen, keyboard... even the power management/battery status stuff is fine.

I'm assuming if I now reboot it the sound will go away again... I may try this in a bit, but for now I'll leave it in sleep mode and check again later.

OK, I *think* this is now worked around.... I can now reboot and it seems I have sound!

What appears to have been the problem is some sort of conflict between the standard audio and HDMI Audio. I have no answer as to why it sometimes worked, other than perhaps it depends on the order it managed to enumerate the hardware?

I saw some people suggesting to disable HDMI audio in BIOS, but I didn't have that option in my BIOS (it's VERY limited).

What I had to do it seems is the following:
Create a file under /etc/modprobe.d with the name blacklist_snd_hdmi_lpe_audio.conf containing a single line: blacklist snd_hdmi_lpe_audio

This came from here: https://github.com/plbossart/UCM/issues/13

The user there who suggested that, F5LVG (https://github.com/F5LVG) also stated to copy some additional files to /usr/share/alsa/ucm, but in my case they were already there.

As far as I understand it (which is not very far at all!) I've basically told the kernel to ignore the HDMI audio device, so it's now happily installing the drivers for the others, and after a couple of reboots it still seems fine.

So, I now have a fully working Ubuntu 18.04, as far as I can tell.