My sound stopped working on Dell Inspiron 15 running Ubuntu 16.04

Asked by Bhartendu Seth on 2018-06-26

I followed the instruction at https://help.ubuntu.com/community/SoundTroubleshootingProcedure and the generated output is given below:

bharat@bharat:~$ wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && chmod +x ./alsa-info.sh && ./alsa-info.sh
--2018-06-26 21:31:21-- http://www.alsa-project.org/alsa-info.sh
Resolving www.alsa-project.org (www.alsa-project.org)... 77.48.224.243
Connecting to www.alsa-project.org (www.alsa-project.org)|77.48.224.243|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://git.alsa-project.org/?p=alsa-utils.git;a=blob_plain;f=alsa-info/alsa-info.sh [following]
--2018-06-26 21:31:22-- http://git.alsa-project.org/?p=alsa-utils.git;a=blob_plain;f=alsa-info/alsa-info.sh
Resolving git.alsa-project.org (git.alsa-project.org)... 77.48.224.243
Connecting to git.alsa-project.org (git.alsa-project.org)|77.48.224.243|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [application/x-sh]
Saving to: ‘alsa-info.sh’

alsa-info.sh [ <=> ] 28.03K 39.2KB/s in 0.7s

2018-06-26 21:31:25 (39.2 KB/s) - ‘alsa-info.sh’ saved [28707]

ALSA Information Script v 0.4.64
--------------------------------

This script visits the following commands/files to collect diagnostic
information about your ALSA installation and sound related hardware.

  dmesg
  lspci
  lsmod
  aplay
  amixer
  alsactl
  /proc/asound/
  /sys/class/sound/
  ~/.asoundrc (etc.)

See './alsa-info.sh --help' for command line options.

/usr/sbin/alsactl: save_state:1595: No soundcards found...
cat: /tmp/alsa-info.qOi8m0KkLl/alsactl.tmp: No such file or directory
Automatically upload ALSA information to www.alsa-project.org? [y/N] : y
Uploading information to www.alsa-project.org ... Done!

Your ALSA information is located at http://www.alsa-project.org/db/?f=00dcb4c1a4733c88eb98530b8aa2dd81474e1a1d

Please inform the person helping you.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Solved by:
Bhartendu Seth
Solved:
2018-06-26
Last query:
2018-06-26
Last reply:
2018-06-26

!!################################
!!ALSA Information Script v 0.4.64
!!################################

!!Script ran on: Tue Jun 26 16:01:27 UTC 2018

!!Linux Distribution
!!------------------

Ubuntu 16.04.4 LTS \n \l DISTRIB_ID=Ubuntu DISTRIB_DESCRIPTION="Ubuntu 16.04.4 LTS" NAME="Ubuntu" ID=ubuntu ID_LIKE=debian PRETTY_NAME="Ubuntu 16.04.4 LTS" HOME_URL="http://www.ubuntu.com/" SUPPORT_URL="http://help.ubuntu.com/" BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/" UBUNTU_CODENAME=xenial

!!DMI Information
!!---------------

Manufacturer: Dell Inc.
Product Name: Inspiron 15-3567
Product Version:
Firmware Version: 01.07.00
Board Vendor: Dell Inc.
Board Name: 05269N

!!ACPI Device Status Information
!!---------------

/sys/bus/acpi/devices/ACPI0003:00/status 15
/sys/bus/acpi/devices/ACPI000C:00/status 15
/sys/bus/acpi/devices/DELL078B:00/status 15
/sys/bus/acpi/devices/DLLK078A:00/status 15
/sys/bus/acpi/devices/INT33A1:00/status 15
/sys/bus/acpi/devices/INT33D0:00/status 15
/sys/bus/acpi/devices/INT33D5:00/status 15
/sys/bus/acpi/devices/INT3400:00/status 15
/sys/bus/acpi/devices/INT340E:00/status 15
/sys/bus/acpi/devices/INT344B:00/status 15
/sys/bus/acpi/devices/INT3F0D:00/status 15
/sys/bus/acpi/devices/LNXPOWER:00/status 1
/sys/bus/acpi/devices/LNXPOWER:01/status 1
/sys/bus/acpi/devices/LNXPOWER:02/status 1
/sys/bus/acpi/devices/LNXPOWER:03/status 1
/sys/bus/acpi/devices/LNXPOWER:04/status 1
/sys/bus/acpi/devices/LNXPOWER:05/status 1
/sys/bus/acpi/devices/LNXPOWER:06/status 1
/sys/bus/acpi/devices/LNXPOWER:07/status 1
/sys/bus/acpi/devices/LNXPOWER:08/status 1
/sys/bus/acpi/devices/LNXPOWER:09/status 1
/sys/bus/acpi/devices/LNXPOWER:0a/status 1
/sys/bus/acpi/devices/LNXPOWER:0b/status 1
/sys/bus/acpi/devices/LNXPOWER:0c/status 1
/sys/bus/acpi/devices/LNXPOWER:0d/status 1
/sys/bus/acpi/devices/LNXPOWER:0e/status 1
/sys/bus/acpi/devices/LNXPOWER:0f/status 1
/sys/bus/acpi/devices/LNXPOWER:10/status 1
/sys/bus/acpi/devices/LNXPOWER:11/status 1
/sys/bus/acpi/devices/LNXPOWER:12/status 1
/sys/bus/acpi/devices/LNXPOWER:13/status 1
/sys/bus/acpi/devices/MSFT0101:00/status 15
/sys/bus/acpi/devices/PNP0103:00/status 15
/sys/bus/acpi/devices/PNP0C02:03/status 3
/sys/bus/acpi/devices/PNP0C02:05/status 3
/sys/bus/acpi/devices/PNP0C02:06/status 15
/sys/bus/acpi/devices/PNP0C09:00/status 15
/sys/bus/acpi/devices/PNP0C0A:00/status 31
/sys/bus/acpi/devices/PNP0C0F:00/status 9
/sys/bus/acpi/devices/PNP0C0F:01/status 9
/sys/bus/acpi/devices/PNP0C0F:02/status 9
/sys/bus/acpi/devices/PNP0C0F:03/status 9
/sys/bus/acpi/devices/PNP0C0F:04/status 9
/sys/bus/acpi/devices/PNP0C0F:05/status 9
/sys/bus/acpi/devices/PNP0C0F:06/status 9
/sys/bus/acpi/devices/PNP0C0F:07/status 9
/sys/bus/acpi/devices/device:09/status 15
/sys/bus/acpi/devices/device:59/status 15
/sys/bus/acpi/devices/device:6f/status 11

!!Kernel Information
!!------------------

Kernel release: 4.4.0-128-generic
Operating System: GNU/Linux
Architecture: x86_64
Processor: x86_64
SMP Enabled: Yes

!!ALSA Version
!!------------

Driver version: k4.4.0-128-generic
Library version: 1.1.0
Utilities version: 1.1.0

!!Loaded ALSA modules
!!-------------------

!!Sound Servers on this system
!!----------------------------

Pulseaudio:
      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes

!!Soundcards recognised by ALSA
!!-----------------------------

--- no soundcards ---

!!PCI Soundcards installed in the system
!!--------------------------------------

00:1f.3 Audio device: Intel Corporation Device 9d71 (rev 21)

!!Advanced information - PCI Vendor/Device/Subsystem ID's
!!-------------------------------------------------------

00:1f.3 0403: 8086:9d71 (rev 21)
 Subsystem: 1028:078b

!!Modprobe options (Sound related)
!!--------------------------------

snd_pcsp: index=-2
snd_usb_audio: index=-2
snd_atiixp_modem: index=-2
snd_intel8x0m: index=-2
snd_via82xx_modem: index=-2
snd_atiixp_modem: index=-2
snd_intel8x0m: index=-2
snd_via82xx_modem: index=-2
snd_usb_audio: index=-2
snd_usb_caiaq: index=-2
snd_usb_ua101: index=-2
snd_usb_us122l: index=-2
snd_usb_usx2y: index=-2
snd_cmipci: mpu_port=0x330 fm_port=0x388
snd_pcsp: index=-2
snd_usb_audio: index=-2

!!Loaded sound module options
!!---------------------------

!!ALSA Device nodes
!!-----------------

crw-rw---- 1 root audio 116, 1 Jun 26 21:27 /dev/snd/seq
crw-rw---- 1 root audio 116, 33 Jun 26 21:27 /dev/snd/timer

!!Aplay/Arecord output
!!--------------------

APLAY

aplay: device_list:268: no soundcards found...

ARECORD

arecord: device_list:268: no soundcards found...

!!Amixer output
!!-------------

!!Alsactl output
!!--------------

--startcollapse--
--endcollapse--

!!All Loaded Modules
!!------------------

Module
rfcomm
ctr
ccm
bnep
drbg
ansi_cprng
dm_crypt
rtsx_usb_ms
memstick
hid_rmi
i2c_designware_platform
i2c_designware_core
arc4
dell_wmi
iwlmvm
mac80211
dell_laptop
intel_rapl
dcdbas
x86_pkg_temp_thermal
dell_smm_hwmon
uvcvideo
intel_powerclamp
videobuf2_vmalloc
videobuf2_memops
coretemp
kvm_intel
snd_hda_intel
videobuf2_v4l2
iwlwifi
kvm
videobuf2_core
snd_hda_codec
v4l2_common
irqbypass
videodev
media
snd_hda_core
crct10dif_pclmul
btusb
snd_hwdep
crc32_pclmul
btrtl
btbcm
ghash_clmulni_intel
input_leds
joydev
btintel
aesni_intel
snd_pcm
cfg80211
snd_seq_midi
snd_seq_midi_event
snd_rawmidi
snd_seq
bluetooth
aes_x86_64
lrw
gf128mul
snd_seq_device
glue_helper
snd_timer
ablk_helper
cryptd
snd
serio_raw
soundcore
mei_me
mei
processor_thermal_device
int3400_thermal
int340x_thermal_zone
intel_soc_dts_iosf
acpi_thermal_rel
idma64
virt_dma
intel_hid
intel_lpss_pci
shpchp
acpi_pad
tpm_crb
sparse_keymap
intel_lpss
mac_hid
parport_pc
ppdev
lp
parport
autofs4
rtsx_usb_sdmmc
rtsx_usb
hid_generic
usbhid
i915_bpo
psmouse
intel_ips
i2c_algo_bit
drm_kms_helper
r8169
mii
syscopyarea
ahci
sysfillrect
libahci
sysimgblt
fb_sys_fops
drm
wmi
i2c_hid
hid
pinctrl_sunrisepoint
pinctrl_intel
video
fjes

!!ALSA/HDA dmesg
!!--------------

[ 15.096313] Copyright(c) 2003- 2015 Intel Corporation
[ 15.123518] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915_bpo])
[ 15.216203] iwlwifi 0000:01:00.0: Direct firmware load for iwlwifi-7265D-19.ucode failed with error -2
--
[ 15.337956] iwlwifi 0000:01:00.0: loaded firmware version 17.352738.0 op_mode iwlmvm
[ 15.396158] snd_hda_intel 0000:00:1f.3: CORB reset timeout#1, CORBRP = 0
[ 15.397672] snd_hda_intel 0000:00:1f.3: no codecs found!
[ 15.626760] iwlwifi 0000:01:00.0: Detected Intel(R) Dual Band Wireless AC 3165, REV=0x210

Have you tried pavucontrol

You can install it with:

sudo apt-get install pavucontrol

See if that helps

Bhartendu Seth (sethbharat) said : #3

Thanks for the quick response. I rebooted and voila, the sound is working fine. So I don't need to try pavucontrol, I suppose.

Thanks a ton for putting detailed instructions on wiki and this forum.