Sound randomly stops working after reboot (16.04)

Asked by Al Mir on 2018-06-20

Under Ubuntu 16.04, the sound had stopped working, seemingly without reason. I followed the troubleshooting steps from and reinstalled ALSA and pulse-audio, deleted some old files apparently related to OSS, and got the sound to work again.

I rebooted the computer a few times and the sound kept working (tested on Youtube through Firefox and Rythmox). Now suddenly after another reboot and nothing special done, the sound disappeared again.

The graphic "Sound" tab only shows a dummy output, alsamixer gives me a "Can't open, no such file or directory" error. The sound device is integrated to the desktop's motherboard, and used with simple jack speakers.

The commands from the troubleshooting guide's step 4 gives me this :

The script from gives me this :

What can I possibly do from that point ?

Question information

English Edit question
Ubuntu alsa-driver Edit question
No assignee Edit question
Solved by:
Al Mir
Last query:
Last reply:
Al Mir (angry-cub) said : #1

So after further testing, I think it might have been a hardware issue : I plugged a "jack into USB" adaptor and the it worked instantly. Considering this, and the fact that the sound-card stopped working for no apparent reason, I guess hardware issue is the most likely cause, even though I've never heard of such an example.