No audio from Ubuntu 16.04 with intel realtek sound card (laptop asus x555u)

Asked by Hugo on 2017-12-02

This was not always happening, and may have occured after unplugging an HDMI cable but I do not remember exactly when It happened. I have tried various things, so I am not surprised if my sound drivers configuration is a bit of a mess.

Following the SoundTroubleShootingProcedure (https://help.ubuntu.com/community/SoundTroubleshootingProcedure) now on step 3 it advises me to share the output of the alsa diagnostic command.

The alsa diagnostic results: http://www.alsa-project.org/db/?f=1fa6476ad01d162d772fad0a1ca9a10700bfa2de

The alsa driver version is: k4.4.0-101-generic

I appreciate any assistance with getting my sound up and running again, regards.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Rijckenberg
Solved:
2017-12-08
Last query:
2017-12-08
Last reply:
2017-12-07
Hugo (mireman) said : #1

Things I have tried include, installing/restarting pavucontrol.

Killing pulseaudio, removing its files at ~/.config/pulse/* and ~/.pulse*

Raising all volume levels, in the alsamixer.

Do you get sound in headphones?

Thanks

Hugo (mireman) said : #3

Just tried headphones, no sound comes through them either.

Please first try this solution (setting model option auto in the /etc/modprobe.d/alsa-base.conf file):

https://elementaryos.stackexchange.com/questions/8738/asus-x555ub-realtek-alc256-no-sound

An alternative would be to test Ubuntu 17.10 in a LiveUSB session in order to check if audio works out-of-the-box in Ubuntu 17.10...

If you are dual-booting with Windows, make sure to fully shut down in Windows instead of rebooting or hibernating your Windows session.

Hugo (mireman) said : #5

Thanks Mark Rijckenberg, that solved my question.

Hugo (mireman) said : #6

Thank you very much Mark, I should have found that solution, but I suppose I was barking up the wrong tree with the search keywords I had used before. Thank you as well actionparsnip for your suggestion.

To be clear Mark's link, to the stackexchange.com solution, was what fixed my problem. The code that I ran from that link I am placing below:

sudo apt-get update && sudo apt-get upgrade

echo options snd-hda-intel model=auto | sudo tee -a /etc/modprobe.d/alsa-base.conf

sudo alsamixer

shutdown -h now