No soundcards detected Ubuntu 14.04 Dell Inspiron [SOLVED]

Asked by Jasper James on 2017-10-19

Hi,

I was having problems playing sound through HDMI with my dell inspiron laptop and after removing (and reinstalling) two packages the sound settings only lists 'dummy output'

I've been following the steps from https://help.ubuntu.com/community/SoundTroubleshootingProcedure and it advises to post a question with the output from this command

wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && chmod +x ./alsa-info.sh && ./alsa-info.sh

The output given is:

!!################################
!!ALSA Information Script v 0.4.64
!!################################

!!Script ran on: Thu Oct 19 21:51:28 UTC 2017

!!Linux Distribution
!!------------------

Ubuntu 14.04.5 LTS \n \l DISTRIB_ID=Ubuntu DISTRIB_DESCRIPTION="Ubuntu 14.04.5 LTS" NAME="Ubuntu" ID=ubuntu ID_LIKE=debian PRETTY_NAME="Ubuntu 14.04.5 LTS" HOME_URL="http://www.ubuntu.com/" SUPPORT_URL="http://help.ubuntu.com/" BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"

!!DMI Information
!!---------------

Manufacturer: Dell Inc.
Product Name: Inspiron 7548
Product Version: A05
Firmware Version: A05
Board Vendor: Dell Inc.
Board Name: 0AM6R0

!!ACPI Device Status Information
!!---------------

/sys/bus/acpi/devices/ACPI0003:00/status 15
/sys/bus/acpi/devices/ACPI000C:00/status 15
/sys/bus/acpi/devices/DELLABCE:00/status 15
/sys/bus/acpi/devices/DLLK05E3:00/status 15
/sys/bus/acpi/devices/INT3400:00/status 15
/sys/bus/acpi/devices/INT3402:00/status 15
/sys/bus/acpi/devices/INT3403:00/status 15
/sys/bus/acpi/devices/INT3403:01/status 15
/sys/bus/acpi/devices/INT3403:02/status 15
/sys/bus/acpi/devices/INT3403:03/status 15
/sys/bus/acpi/devices/INT3404:00/status 15
/sys/bus/acpi/devices/INT3404:01/status 15
/sys/bus/acpi/devices/INT3433:00/status 15
/sys/bus/acpi/devices/INT3437:00/status 15
/sys/bus/acpi/devices/INT3F0D:00/status 15
/sys/bus/acpi/devices/INTL9C60:00/status 15
/sys/bus/acpi/devices/LNXPOWER:00/status 1
/sys/bus/acpi/devices/MSFT0001:00/status 15
/sys/bus/acpi/devices/PNP0103:00/status 15
/sys/bus/acpi/devices/PNP0C02:03/status 15
/sys/bus/acpi/devices/PNP0C0A:00/status 31
/sys/bus/acpi/devices/PNP0C0E:00/status 11
/sys/bus/acpi/devices/PNP0C0F:00/status 9
/sys/bus/acpi/devices/PNP0C0F:01/status 9
/sys/bus/acpi/devices/PNP0C0F:02/status 9
/sys/bus/acpi/devices/PNP0C0F:03/status 9
/sys/bus/acpi/devices/PNP0C0F:04/status 9
/sys/bus/acpi/devices/PNP0C0F:05/status 9
/sys/bus/acpi/devices/PNP0C0F:06/status 9
/sys/bus/acpi/devices/PNP0C0F:07/status 9
/sys/bus/acpi/devices/SMO8810:00/status 15
/sys/bus/acpi/devices/device:00/status 15
/sys/bus/acpi/devices/device:11/status 15
/sys/bus/acpi/devices/device:13/status 15
/sys/bus/acpi/devices/device:19/status 15
/sys/bus/acpi/devices/device:37/status 15
/sys/bus/acpi/devices/device:52/status 15

!!Kernel Information
!!------------------

Kernel release: 4.4.0-97-generic
Operating System: GNU/Linux
Architecture: x86_64
Processor: x86_64
SMP Enabled: Yes

!!ALSA Version
!!------------

Driver version: k4.4.0-97-generic
Library version: 1.0.27.2
Utilities version: 1.0.27.2

!!Loaded ALSA modules
!!-------------------

!!Sound Servers on this system
!!----------------------------

Pulseaudio:
      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes

!!Soundcards recognised by ALSA
!!-----------------------------

--- no soundcards ---

!!PCI Soundcards installed in the system
!!--------------------------------------

00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)
00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)

!!Advanced information - PCI Vendor/Device/Subsystem ID's
!!-------------------------------------------------------

00:03.0 0403: 8086:160c (rev 09)
 Subsystem: 1028:066f
--
00:1b.0 0403: 8086:9ca0 (rev 03)
 Subsystem: 1028:066f

!!Modprobe options (Sound related)
!!--------------------------------

snd_atiixp_modem: index=-2
snd_intel8x0m: index=-2
snd_via82xx_modem: index=-2
snd_usb_audio: index=-2
snd_usb_caiaq: index=-2
snd_usb_ua101: index=-2
snd_usb_us122l: index=-2
snd_usb_usx2y: index=-2
snd_cmipci: mpu_port=0x330 fm_port=0x388
snd_pcsp: index=-2
snd_usb_audio: index=-2

!!Loaded sound module options
!!---------------------------

!!ALSA Device nodes
!!-----------------

crw-rw---- 1 root audio 116, 1 Oct 19 22:49 /dev/snd/seq
crw-rw---- 1 root audio 116, 33 Oct 19 22:49 /dev/snd/timer

!!Aplay/Arecord output
!!--------------------

APLAY

aplay: device_list:268: no soundcards found...

ARECORD

arecord: device_list:268: no soundcards found...

!!Amixer output
!!-------------

!!Alsactl output
!!--------------

--startcollapse--
--endcollapse--

!!All Loaded Modules
!!------------------

Module
drbg
ansi_cprng
ctr
ccm
bnep
rfcomm
binfmt_misc
arc4
iwlmvm
mac80211
uvcvideo
videobuf2_vmalloc
videobuf2_memops
videobuf2_v4l2
videobuf2_core
v4l2_common
videodev
media
i915
amdkfd
intel_rapl
x86_pkg_temp_thermal
intel_powerclamp
coretemp
kvm_intel
kvm
amd_iommu_v2
radeon
iwlwifi
btusb
btrtl
btbcm
btintel
bluetooth
cfg80211
snd_hwdep
joydev
dell_wmi
sparse_keymap
hid_multitouch
dell_laptop
ttm
dcdbas
dell_smm_hwmon
irqbypass
crct10dif_pclmul
crc32_pclmul
ghash_clmulni_intel
aesni_intel
drm_kms_helper
aes_x86_64
lrw
gf128mul
glue_helper
ablk_helper
cryptd
snd_pcm
drm
input_leds
serio_raw
wmi
snd_seq_midi
snd_seq_midi_event
mei_me
snd_rawmidi
mei
acpi_als
kfifo_buf
industrialio
int3403_thermal
snd_seq
snd_seq_device
snd_timer
snd
dell_smo8800
video
lpc_ich
soundcore
shpchp
i2c_algo_bit
fb_sys_fops
syscopyarea
elan_i2c
sysfillrect
sysimgblt
i2c_hid
dw_dmac
dw_dmac_core
int3400_thermal
acpi_thermal_rel
intel_smartconnect
dell_rbtn
mac_hid
acpi_pad
i2c_designware_platform
int3402_thermal
i2c_designware_core
int340x_thermal_zone
parport_pc
ppdev
lp
parport
hid_generic
usbhid
hid
ahci
libahci
fjes

!!ALSA/HDA dmesg
!!--------------

Following this I also ran the command given by Step 4 on the troubleshooting guide which gives this output

>>> 1 sink(s) available.
  * index: 0
 name: <auto_null>
 driver: <module-null-sink.c>
 flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
 state: SUSPENDED
 suspend cause: IDLE
 priority: 1000
 volume: 0: 46% 1: 46%
         0: -20.50 dB 1: -20.50 dB
         balance 0.00
 base volume: 100%
              0.00 dB
 volume steps: 65537
 muted: no
 current latency: 0.00 ms
 max request: 344 KiB
 max rewind: 344 KiB
 monitor source: 0
 sample spec: s16le 2ch 44100Hz
 channel map: front-left,front-right
              Stereo
 used by: 0
 linked by: 0
 configured latency: 0.00 ms; range is 0.50 .. 2000.00 ms
 module: 12
 properties:
  device.description = "Dummy Output"
  device.class = "abstract"
  device.icon_name = "audio-card"
>>> aplay: device_list:268: no soundcards found...
Unloading ALSA sound driver modules: snd-seq-dummy snd-hwdep snd-pcm snd-seq-midi snd-seq-midi-event snd-rawmidi snd-seq snd-seq-device snd-timer.
Loading ALSA sound driver modules: snd-seq-dummy snd-hwdep snd-pcm snd-seq-midi snd-seq-midi-event snd-rawmidi snd-seq snd-seq-device snd-timer.
Support status summary of 'jasper-dell':

You have 84 packages (2.8%) supported until October 2022 (5y)
You have 2114 packages (69.3%) supported until May 2019 (5y)

You have 2 packages (0.1%) that can not/no longer be downloaded
You have 851 packages (27.9%) that are unsupported

Your Hardware Enablement Stack (HWE) is supported until April 2019.

Run with --show-unsupported, --show-supported or --show-all to see more details
  *-multimedia:0 UNCLAIMED
       description: Audio device
       product: Broadwell-U Audio Controller
       vendor: Intel Corporation
       physical id: 3
       bus info: pci@0000:00:03.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:f7214000-f7217fff
  *-multimedia:1 UNCLAIMED
       description: Audio device
       product: Wildcat Point-LP High Definition Audio Controller
       vendor: Intel Corporation
       physical id: 1b
       bus info: pci@0000:00:1b.0
       version: 03
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi cap_list
       configuration: latency=32
       resources: memory:f7210000-f7213fff

Sorry for the lack of code formatting. Thank you in advance!!

Jasper

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu alsa-driver Edit question
Assignee:
No assignee Edit question
Solved by:
Jasper James
Solved:
2017-12-22
Last query:
2017-12-22
Last reply:
2017-10-20

Do you get sound in headphones?

Jasper James (jj364) said : #2

EDIT: I'm not getting any sound through headphones.

Jasper James (jj364) said : #4

I'm afraid that didn't work. I'm slightly confused as to why I can't find the ALSA driver for my laptop seeing as it was working yesterday.

Jasper James (jj364) said : #5

It does work through bluetooth speakers but the sound is very low quality.

Do you have the latest BIOS?

Jasper James (jj364) said : #7

I don't think so. My BIOS version is

A05 (found by running sudo dmidecode -s bios-version)

Looking at the Dell website there seems to be an Inspiron 7548 BIOS update from last year.

Will I need to update my BIOS?

Worth a try

Jasper James (jj364) said : #9

I've finally managed to fix the issue! The list of things I did was to

1) Upgrade Dell BIOS to A07 - Had no effect
2) Upgraded to Ubuntu 16.04 - Had no effect ( was going to do this anyway so wasn't really intended to fix the problem)
3) Upgraded the kernel to 4.10 - This fixed the issue

The command I used was
sudo apt-get install --install-recommends xserver-xorg-hwe-16.04

The specific kernel version I have is 4.10.0-42-generic.

Thanks for all your help :)